Question about 1989 kawasaki ZX 10

2 Answers

1987 kawasaki ninja zx10 wont stay running when warmed up it

1987 kawasaki wont stay running when warmed up it sputters and backfires i tried different coils,pick up coils,cdi,gas tank,new plugs still the same

Posted by pyroboy68 on

Ad

2 Answers

Claire southern

  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

  • Contributor
  • 1 Answer

How do i remove seats on a 1987 zx10 when the lock cable has snapped, need to charge the battery. Ta

Posted on Apr 25, 2015

Ad

steve t

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 921 Answers

You didnt mention anything to do with the carbs so try some "Sea foam".... purchase at Autozone ($10) pour 1/3 can to two gallons fuel and drive it around for a good 10 to 15 miles and get on it once in awhile, ride safe..if the carbs are dirty or clogged... they wont be after your ride..there might be a little hesitation your first couple of miles till it starts to work..it took my bike 10 miles before it cleared out..bump start your bike if you have to to get it going and keep it going till it clears up.

Posted on Apr 08, 2010

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

No spark


Try new spark plugs first, install them and see if it starts..if it won't start, try to fllod it.. them remove the spark plugs and make sure the plugs are wet when you remove them, this proves you are getting gas to the cylinders. No spark...then you will need a factory service manual to check the resistance values according to the manual for the pick-up coil, the cdi box, the main ignition coil, the plug wires. Check the on/off switch on the handlebar if it has one.

Good luck!

Jul 26, 2014 | 2001 kawasaki EL 125 Eliminator

1 Answer

I have a 85 kawasaki eliminator Zl900 that i have been running for about two months without mufflers,bike was running fantastic until one day i went to crank and she would not start,it would turn over all...


Hi, Big 9 and the usual suspects are:
1. Fuel tank empty.
2. The fuel tank has old dead gas.
3. Fuel tank bottom contaminated with ethanol sludge, dirt, water, rust, etc.
4. Fuel supply valve/petcock turned off.
5. Fouled spark plugs.
6. Engine flooded as a result of overuse of the enrichner.
7. Vacuum hose to the fuel supply valve/petcock disconnected, broken, cracked, or pinched.
8. Fuel valve/petcock or filter clogged.
9. Fuel line to carburetor or throttle body pinched, kinked or blocked.
10. Carburetor float stuck.
11. Fuel injectors clogged.
12. A severely discharged or damaged battery, you need 12.5 volts or better and be able to pass a load test if necessary.
13. Check battery terminals for damage or corrosion, check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
14. Loose or corroded wire connection at the coil or plug between ignition sensor and ECM module.
15. Spark plug cables in bad condition and shorting check for spark leakage in the dark, cable connections loose, or connected to the wrong cylinders.
16. Ignition timing incorrect due to a faulty ignition coil, ignition module or MAP, CMP, CKP, O2, TPS, ETP, IAC sensors.
17. Faulty neutral, clutch lever, or kickstand safety switch.
18. Faulty fuel pump or fuse or relay.
19. A stuck bent or burnt valve.
20. Tilt sensor needs a reset.
21. Security system not disarming alarm needs a reset.
22. Check for engine trouble codes.
For more information about your issue and valuable "FREE" downloads that you will need please click on the blue links below. Good luck and have a wonderful day.
ZL900 won start hit and backfire only HELP
Kawasaki Eliminator 900 Electrical Worries Classic Motorcycle Repair...
Kawasaki ZL900 ZL1000 Eliminator 1985 1986 1987 Service Manual Repair... $10 cheap
OEM Parts for Kawasaki
http://mybikemanuals.com/kawasaki

Btw, I’m available to help over the phone in case u need at https://www.6ya.com/expert/gregg_c0ec1df182c7330e

Apr 15, 2017 | kawasaki Motorcycles

1 Answer

I have a 2005 KXF250 and the bike continuously backfires when i let off the gas and wont stay running at idle. it dies even after its warmed up. whats up?


check/clean the carburator, adjust the air screw... lack of fuel, causing the the engine to backfire when you close the throttle... adjust idle...

Jun 04, 2011 | 2005 kawasaki KX 250

1 Answer

Polaris classic 1997 500 when warm out loads up . run down trail at about 20mph feathering gas at about 3/4 then after awhile well clear out and the next time slow down start all over again . this is only...


Easiest first, put dry gas in and run it if that don't work, try draining gas, take tank off, drain carbs. You may have water in tank. If not next best thing is try changing the coil. If it backfires it is electrical.

Feb 07, 2011 | Polaris New Genuine Polaris Snowmobile...

1 Answer

What is the spark plug gap for a kawasaki ke100 1975


.35plug gap .. points .12 to .17 or a match book cover is around 13+14 1000s of an inch ,,cdi pick up coil gap .30 should be fine

Jul 05, 2010 | 1987 kawasaki GPZ 500 S - GPX 500 R

2 Answers

93wrangler6cyl,auto when cold backfires, sputters until warms up


Check EGR value, clean or replace. Also PCV valve replace it is cheap.

Dec 16, 2009 | Jeep Wrangler Cars & Trucks

2 Answers

1996 zx11 getting sprk to one bank only


Hi and welcome to FixYa,

The voltage on the green wire must be pulsating when cranking/starting the bike, not steady. Confirm by similarly testing the voltage on the black wire on the left ignition coil. If the green still reads a constant voltage, then the CDI is faulty; to be more specific, most likely that the switching tansistor inside the CDI that drives the right ignition coil has shorted.

Good luck and thank you for asking FixYa.

Jul 09, 2009 | 1996 kawasaki GPZ 1100

3 Answers

Running on three !!


check the carb on that cyl is getting fuel

by removing air box an squirting fuel in that cyl's carb with a windex pumper bottle, if engine picks up speed you need to clean that carb

Mar 31, 2009 | 1996 kawasaki ZZR 1100

3 Answers

19-95 KLF300 ATV Kawasaki 4x4 no spark put new ignitor unit on.


You said the motor cut out and popped and backfired when it quit, this is almost always one of two things; either the low speed pulse coil or the actual CDI "black" box. You will almost never lose a main coil. One thing I would also check to make sure did not happen is shearing a flywheel mag key. When the motor backfires you can easily shear a mag key if you have a heavy flywheel, (external). However when this happens you don't usually lose spark but it will certainly cause the backfire.
One other item of importance is that the bike you are in question about does not emit a bright spark when you are checking for fire. Make sure you are using a brand new plug and ground it on the head. Try to make sure you are in a dark environment when you check the spark.

Dec 13, 2008 | kawasaki KLX 300 Motorcycles

Not finding what you are looking for?
1989 kawasaki ZX 10 Logo

608 people viewed this question

Ask a Question

Usually answered in minutes!

Top kawasaki Experts

Arnie Burke
Arnie Burke

Level 3 Expert

6339 Answers

Marvin
Marvin

Level 3 Expert

85239 Answers

Gino Cussen
Gino Cussen

Level 2 Expert

217 Answers

Are you a kawasaki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...