Question about Power Motorcycles

2 Answers

No electrical power 1987 Yamaha Venture Royale 1300

1987 venture royale 1300. There is no power when the key is turned to the on position. I did check for power out of the main fuse. Yes, it is there. @

Posted by on

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    One Above All:

    The expert with highest point at the last day of the past 12 weeks.

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

  • Power Master
  • 59,811 Answers

Hi, Douggofton before testing any electrical component in the Starting Circuit it is "IMPERATIVE" that you have a fully charged battery of 12.5 volts or more and be able to pass a proper "LOAD" test if necessary, you may have a preliminary reading of 12.5 volts or more but little or zero amperage, the battery is faulty and must be replaced. AGM type batteries fall into this scenario more so than lead-acid batteries.
1. Ignition Switch not in the "ON" position.
2. Engine Run Switch in the "OFF" position.
3. Engine Run Switch is "FAULTY" or corroded.
4. Check the battery terminals for damage or corrosion check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter.
5. Bank angle sensor needs a reset or is faulty.
6. FOB battery low or dead.
7. Faulty ignition switch.
8. Faulty starter button.
9. Faulty kickstand, clutch, neutral safety switch.
10. Security alarm needs a reset.
11. Starter relay, solenoid, starter motor or circuit wiring faulty.
12. Starter armature or field coils have failed.
13. Main fuse or circuit breaker may be blown or faulty.
14. Faulty ignition relay.
15. The electric starter is working but starter clutch has failed.
16. Check for engine trouble codes.
For more information about your issue and valuable "FREE" downloads that you will need for viewing or printing please click on the blue links below. Good luck and have a wonderful day.
https://www.venturerider.org/forum/showthread.php?68047-No-power
https://www.youtube.com/watch?v=60Xlecdxq_s
http://www.werder.ee/Manual/XVZ1300.pdf
https://www.partsfish.com/page/oem-parts-for-yamaha
https://www.yamahaventure.nl/pdf/ownersmanualxvz13tf.pdf

Posted on Dec 02, 2019

Ad

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 5,971 Answers

The switch needs some rubbing alcohol poured in to rid corrosion. But it cud also be worn..take it out n inspect. Buy a bike shopbook

Posted on Oct 15, 2019

Ad

6 Suggested Answers

6ya6ya

6ya staff

  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Charles Scheiner

  • 28 Answers

SOURCE: 1193? Oldsmobile royal 88 Relay?

How rusty is your vehicle? Been in any collisions?

Posted on Oct 05, 2008

goofduck

Jeff Adkisson

  • 490 Answers

SOURCE: choke on 2002 royal star venture hard to move

change the choke cable it is rusted inside

Posted on Apr 13, 2009

SOURCE: 1986 Yamaha Venture Royal 1300 will only start in neutral now.

There is a tiny switch at the clutch lever housing assembly, the wires that are on tht switch may hve been distrubed unknowingly whilst you were refitting the cable.
Not bad too if you can check the switch which has a tiny protusion towards the clutch lever, it may probabley need a little adjusting or cleaning,spray some WD40 to it.
To access it from the lever side , it would be best to remove the clutch lever.
Hope this helps!

Posted on Jul 14, 2009

Anonymous

  • 4 Answers

SOURCE: location of fuel filter 1987 yamaha 1300 venture

it is behind the side covers be low seat and thats where the fuel pump is

Posted on Jan 10, 2010

tukalook

David Harding

  • 1 Answer

SOURCE: My 2004 Yamaha Royal Start Venture will not start.

On left hand side, remove rear foot board and plastic cover ,you may remove battery and in behind their is a block which has 2 - 30 amp fufuses . That is your solution . Check and replace as required.

Posted on Feb 06, 2013

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1988 Yamaha XVZ 1300 Royal Star Venture 30 amp main circuit breaker location


Hi, Jeff for this scenario you will need your service manual that has all fastener torque specs and a wiring diagram on the back pages, parts fiche, and owners manual if you can't find the best tool you ever bought for your Yamaha, despair not, for a mere $15 you can download another one.
For more information about your issue and valuable "FREE" downloads that you will need for viewing or printing please click on the blue links below. Good luck and have a wonderful day.
1988 Yamaha XVZ 1300 Royal Star Venture 30 amp main circuit breaker...
The Venturers Yamaha Venture Technical Support Library
DOWNLOAD YAMAHA XVZ 1300 VENTURE REPAIR MANUAL 1986 1993 Download Manuals... $15
https://www.partsfish.com/page/oem-parts-for-yamaha
http://mybikemanuals.com/yamaha

Btw, I’m available to help over the phone in case u need at https://www.6ya.com/expert/gregg_c0ec1df182c7330e

May 11, 2018 | Yamaha Royal Star Venture Motorcycles

1 Answer

1996 yamaha royal star 1300. Where is the main power fuse located


Hi, John for this scenario you will need your service/owners manual if you can't find the first and best tool you ever bought for your Yamaha, despair not, for a mere $0 you can download another one. For more information about your issue and valuable "FREE" downloads that you will need please click on the links below. Good luck and have a nice day.
The Venturers Yamaha Venture Technical Support Library
Yamaha Royal Star XVZ13CTV Owner Manual Replacing The Fuses
http://www.yamahaventure.nl/pdf/ownersmanualxvz13tf.pdf
OEM parts for Yamaha

Btw, I’m available to help over the phone in case u need at https://www.6ya.com/expert/gregg_c0ec1df182c7330e

Jun 16, 2015 | Yamaha Motorcycles

1 Answer

Absolutely no power when the key is turned


Hi, Anonymous and the usual suspects are:
1. Ignition Switch not in the "ON" position.
2. Engine Run Switch in the "OFF" position.
3. Discharged battery, needs to be 12.5 volts or better and be able to pass a load test if necessary, check battery terminals for damage or corrosion, check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
4. Bank angle sensor tripped and ignition/light key switch not cycled to the "OFF" position and then back to the "ON" position.
5. Faulty starter button/switch.
6. Faulty jiffy stand or clutch pull in switch/sensor.
7. Security alarm needs a reset.
8. Starter control circuit, relay, or solenoid faulty.
9. Main fuse or circuit breaker may be blown or faulty.
10. Electric starter shaft pinion gear is not engaging or over-running starter clutch slipping.
For more information about your issue and valuable "FREE" downloads that you will need please click on the links below. Good luck and have nice a day.
The Venturers Yamaha Venture Technical Support Library
http://www.venturers.org/Tech_Library/?action=category&cat_id=002007
http://www.yamahaventure.nl/pdf/servicemanualxvz13tf.pdf
OEM parts for Yamaha

http://www.yamahaventure.nl/pdf/ownersmanualxvz13tf.pdf

Btw, I’m available to help over the phone in case u need at https://www.6ya.com/expert/gregg_c0ec1df182c7330e

Sep 22, 2013 | 2008 Yamaha Royal Star Venture

1 Answer

Royal star no electrical power


Hi, Anonymous and the usual suspects are:
1. Ignition Switch not in the "ON" position.
2. Engine Run Switch in the "OFF" position.
3. Discharged battery, needs to be 12.5 volts or better and be able to pass a load test if necessary, check battery terminals for damage or corrosion, check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
4. Bank angle sensor tripped and ignition/light key switch not cycled to the "OFF" position and then back to the "ON" position.
5. Faulty starter button/switch.
6. Faulty jiffy stand or clutch pull in switch/sensor.
7. Security alarm needs a reset.
8. Starter control circuit, relay, or solenoid faulty.
9. Main fuse or circuit breaker may be blown or faulty.
10. Electric starter shaft pinion gear is not engaging or over-running starter clutch slipping.
For more information about your issue and valuable "FREE" downloads that you will need please click on the links below. Good luck and have nice a day.
http://www.starbikeforums.com/forums/14-royal-star/23673-no-electrical-power-when-key-turned.html
Re No electrical power Road Star Forum Yamaha Road Star
http://www.yamahaventure.nl/pdf/servicemanualxvz13tf.pdf
OEM parts for Yamaha
http://www.starmotorcycles.com/assets/service/manuals/1998/Lit-11626-11-17_320.pdf

Btw, I’m available to help over the phone in case u need at https://www.6ya.com/expert/gregg_c0ec1df182c7330e

May 28, 2012 | 1997 Yamaha Royal Star XVZ 1300 A

2 Answers

My 2004 Yamaha Royal Start Venture will not start. Battery is good. nothing turns on in any key position. Just got back from a ride and was going to go on a quick one. Got on the bike, turned key, bike...


1st check the fuse(s) including the main fuse on the starter solenoid.
Then check battery connections are tight.
If OK then check wiring & connections from battery to starter solenoid to ignition switch, but with no meter it will have to be a visual check for bad connections or squashed wires

Hope this helps (if so please mark as very helpful)

Ride Safe
Bike-Doc

Apr 15, 2010 | 2004 Yamaha Royal Star Venture

1 Answer

Battery was not good and was replaced but still no power


check main fuse 30a i think. also check the ground to frame

Apr 09, 2009 | 2005 Yamaha Royal Star Venture

Not finding what you are looking for?
Motorcycles Logo

Related Topics:

31 people viewed this question

Ask a Question

Usually answered in minutes!

Top Power Experts

Marvin
Marvin

Level 3 Expert

85216 Answers

Lawrence Oravetz

Level 3 Expert

10543 Answers

Vernon Taylor

Level 3 Expert

5961 Answers

Are you a Power Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...