Question about Motorcycles

Open Question

PGO Trex 150 will not move forward

My PGO Trex 150cc lost all power to the wheels while driving down a hill. It still starts and the engine runs fine, however, applying acceleration won't make the wheels turn. any advice. A scooter @

Posted by Garry Stevens on

Ad

5 Related Answers

Anonymous

  • 1605 Answers

SOURCE: Auto transmission. When in

go to a transmission guy.
they should able to let you what the problem is.
check the transmission fluid first.

Posted on Oct 30, 2008

Ad
muttandjeff

Allen Neal

  • 359 Answers

SOURCE: No power accelerating or going up a hill

HAVE SOMEONE CK THROTTLE POSITION SENSOR AND CATALYTIC CONVERTER MAKE SURE EXHAUST IS CLEAR

Posted on Feb 03, 2009

Ad

Anonymous

  • 190 Answers

SOURCE: Cold starting! PGO T Rex150 scooter just will not start when cold

solenoid needs a diode across it with stripe on positive side.

can be a vacume air lock try open fuel cap to start cold to see if starts?

or sounds to me that the orfice is to small on the cold start port or dirty ...not enough fuel due to your hand choking

other is a air leak between carb to intake valve/port

when engine running spray some WD-40 around intake gaskets to see if rpm picks up if do its leaking

Posted on Apr 26, 2009

Anonymous

  • 218 Answers

SOURCE: Engine/Fuel Pump; Engine sputters when I hit the accelerator.

CHECK THE FUEL FILTER FIRST.IF THE FILTER IS PLUGGED U CAN HAVE THE SAME PROBLEM.IF THAT DOES NOT FIX IT U NEED TO CHECK THE FUEL PRESSURE.THERE IS A FUEL PRESSURE TEST PORT ON THE FUEL INJECTION RAIL(TOP OF THE ENGINE)THE PRESSURE SHOULD BE 40-47PSI.KEY ON ENGINE OFF.

Posted on Apr 30, 2009

lsteward68

Raymond Ramirez

  • 333 Answers

SOURCE: Engine boggs down

either fuel filter or fuel pump...replace filter since its cheaper. 6-12 dollars at autozone

Posted on May 24, 2009

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What causes the speed to fluctuate when you set the cruise control?


if it just started to happen you may have lost a magnet off the drive shaft. If it is a front wheel drive then you would have two magnets on the flywheel if you lost one magnet it would cause problems.
The other possible cause if the sensitivity setting is set too sensitive then the cruise control will surge .
Setting it lower will allow it to slowly respond to speed changes but if going up hill it will take a while to increase the acceleration . Or going down hill it could accelerate too much before the cruise control realises it is going downhill
Also a very wet road can cause the wheels to spin and cause the cruise control to lose the plot and accelerate to dangerous speeds.
I have had this happen to myself once so be wary of cruise control use in wet conditions.

Jan 14, 2017 | 1992 Honda Accord

2 Answers

Truck drives fine on flat surface but acts like it wants to die out going up hills


Surges under load but only while going uphill Page1 - Chevy High ...

forums.superchevy.com > ... > General Chevy Technical Discussion

Mar 6, 2011 - 14 posts - ‎8 authors
Trying to help out a friend. ... The truck starts, runs, and drives fine until you get to a hill. When going up hill it begins to surge, almost stalling but not quite. ... rubber fuel lines suck shut under a heavy load and act like that. .... tranny fluid level o.k.? ya got me stumped. runs great when it's on a flat surface?

Ford 460 engine - RV mechanic

www.rvmechanic.com > Discussion Forum > Mechanic's Corner - Engines
Will not take gas going up a hill but will maintain speed at 55 mph. ... Want to do a diagnostic test on my 1997 F250 with 460 engine. ... only get to about 40 miles an hour if i push it the engine acts like its running out of gas,thank you .... The truck hesitates on acceleration, while driving on flat surface is fine, however climbing ...

rough idle, stalling, loss of power. - CarGurus


Dec 14, 2015 | Cars & Trucks

1 Answer

Why does my engine run hot and lose power when I am 4 wheeling in the mud?


Check engine fan operation and make sure radiators not packed with dirt and debris.When your on the highway you have the speed you are traveling at air cooling the radiator.

Mar 17, 2015 | 1995 Nissan Pickup

1 Answer

Vehicle drive smooth then all of a sudden the wheels starting to tighten car slow down.


what makes you thing the tires/wheels tighten (felt by hand off ground?)
my guess , you meant it seems. like???
1: lost engine power?
2: transmission not up shifting?

is this a auto A/T or manual M/T tranny,
if A/T , you need to look at the engine RPM when you lose
power (acceleration on demand)

RPM rises, car dont move faster ,this is tranny slip.
RPM fails to increase, and speed, up hills. this is called lost engine power.
lost engine power can be caused by , bad spark (tuneups skipped?)
or weak fueling.
weak fueling too can be cause by skipping the fuel filter step in the tune up list.


Nov 26, 2013 | 1995 Jeep Cherokee

1 Answer

My fiat punto loses power when driving uphill


I have a 98 punto sporting nd today it started running like it was misfiring but wen i accelerate slow its fine but wen u accelerate as normal it spits and splutters :'( any suggestions??i have change fuel filter nd injectors ????

Sep 22, 2012 | 2005 Fiat Punto 1.2

2 Answers

I have a 1997 landcruiser,when driveing at 40 to 50mph a vibration appers when accelerating up to 70mph it gets worse take foot of accelerater goin down hill thers is no noise or vibration


Check your universal joints in the drive shaft. When you remove your foot fromt the accelerator you are no longer applying power to the rear wheels and in turn there is no load on the drive shaft. When you accelerate below 40mph, there isn't enough centrifugal force to cause the driveshaft to wobble, but once you go above 40mph, it begins to show slop.

Another thing to check is your wheel bearings.

Mar 07, 2011 | 1997 Toyota Land Cruiser

3 Answers

2002 s10 zr2 runs rough bogs down when you


First check for any cracked pipes leading into the intake manifold If all OK (with no codes showing it probably is OK) try checking the fuel pressure regulator. If you smell fuel from the pressure regulator vacuum side arm (when the vacuum line has been disconnected) it needs to be replaced.

May 28, 2010 | 2002 Chevrolet S-10

2 Answers

Sudden loss of power, Backfiring, starts then stalls


Your timing belt could be broken. You want to have this checked as soon as possible to prevent any further engine problems.

If you need further help, I’m available over the phone at https://www.6ya.com/expert/david_62314e5b2470e8b5

Nov 27, 2008 | 1991 Honda Civic

1 Answer

Clunking noise w/ acceleration


Ya know it sounds like one of the U-Jonts in the front drive line to the front wheels has failed or even one of the driveline U- joints is either Dry and lost its bearings and is worn out,
One of the easiest ways to make sure its not the engine is while driving down a hill put the car in neutral, turn off the engine coast down a small hill and turn to either direction and see if you still hear it , if you still hear it its gonna be somewhere in the drive lines, becareful you will not have power steering or power brakes with the engine off, but you can restart the engine inn neutral at any time . Please let me know.

Aug 24, 2008 | 2004 Ford Expedition

Not finding what you are looking for?
Motorcycles Logo

Related Topics:

53 people viewed this question

Ask a Question

Usually answered in minutes!

Top Motorcycles Experts

Arnie Burke
Arnie Burke

Level 3 Expert

6521 Answers

Marvin
Marvin

Level 3 Expert

85239 Answers

Brad Brown

Level 3 Expert

18562 Answers

Are you a Motorcycle Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...