Question about 2010 Husaberg FE 390

1 Answer

Quit running 2010 Husaberg FE 390

Fe390 husaberg stops midway ride won't start to wait 30 minutes goes then stops change fuel filters still the same problem @

Posted by Anonymous on

Ad

1 Answer

Gregg Mahin

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    One Above All:

    The expert with highest point at the last day of the past 12 weeks.

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

  • Husaberg Master
  • 63,486 Answers

Hi, Anonymous and the usual suspects are:
1. Severely discharged or a damaged battery must have 12.5 volts or more and be able to pass a proper "LOAD" test if necessary, you may have a preliminary reading of 12.5 volts or more but little or zero amperage the battery is faulty and must be replaced, AGM batteries fail in this scenario more so than lead-acid batteries.
2. Faulty alternator/generator and or voltage regulator.
3. Loose or corroded battery terminals and or cables especially the "NEGATIVE" cable, look for loose, corroded, or broken connectors inside the cable harness at "BOTH" ends.
4. A faulty main circuit breaker or ignition switch, check for loose connections and continuity.
5. Faulty system relay or ignition relay, check for continuity.
6. Faulty ignition coil, ignition/electronic module.
7. Faulty CKP, CPS, CMP, MAP, TPS, or BAS sensor, corroded, loose or broken wire connector pins/sockets.
8. Throttle cables and or idle speed improperly adjusted hot idle speed should be 950 RPM to 1000 RPM.
9. Faulty neutral, side stand or clutch lever safety switch.
10. Fuel tank empty
11. Fuel tank contaminated with ethanol sludge.
12. Water or dirt in the fuel system, or clogged filter.
13. Quick disconnect check ball stuck.
14. Restricted, blocked or kinked fuel line.
15. Faulty fuel pump.
16. Faulty pressure regulator.
17. Faulty or clogged fuel injectors.
18. Lean angle switch is faulty or needs adjustment.
19. Catastrophic engine failure, perform a compression test.
For more information about your issue and valuable "FREE" downloads that you need for viewing or printing please click on the blue links below. Good luck and have a wonderful day.
https://thumpertalk.com/forums/topic/774831-2010-husaberg-390-dying-after-2-days-help
http://www.dirtbikeworld.net/forum/archive/index.php/f-93.html
https://www.emanualonline.com/Motorbikes/Husaberg/FE-Models.htm
http://www.cyclebuy.com/husaberg/parts.htm
Husaberg 400 User Manual

Posted on Jun 13, 2019

Ad

2 Related Answers

Anonymous

  • 490 Answers

SOURCE: i need 2001 husaberg fe 400 plastics

dennis kirk

Posted on Apr 21, 2009

Ad

David Shaub

  • 2976 Answers

SOURCE: husaberg 600 wont start on the kick

How much do you weigh? If you have strong compression, that's what you want.

Posted on Aug 06, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2000 Grand Vitara breaksdown, backfires and dies while driving after about 30 minutes. Starts again in about an hour. Changed fuel pressure regulator. Made no difference.


The check engine will be on if the key is on but engine not running . This is normal. If the check engine goes out when the engine starts there are no codes present . Did you check the fuel filter . Sometimes when a filter is dirty there is sedement laying in the filter canister . When the pump starts working the flow picks up the sedement and plugs any remaining open screen and stops the fuel completely . The engine stops . When the flow stops the sedement falls back allowing flow again. and the engine will run for another while . If the filter is old it should be changed anyway . Also when the engine stops check to see if there is spark at the spark plugs while cranking the engine .

Dec 28, 2013 | Suzuki Vitara Cars & Trucks

1 Answer

After highway driving for 2 hours and stopping for gas the car would initially start and then stall, it would run again until the car cooled for 30 minutes.


Sounds like your coolant level might be low. At highway speed you probably have enough coolant and with the air passing thru the radiator keeps the temp down, but at idle not so much. Or depending whether you have a belt drive or electric fan. Belt driven, could need a new belt.

Apr 06, 2017 | 1991 Mercury Colony Park

1 Answer

My2011 570 seems to run out of fuel and simply stop. After about 5 min it will start then a few minutes latter after riding it simply stops again. It will not start immediately. Tried the basics of taking...


Sounds like you have the common problem of a plugged fuel pick up. You need to remove the fuel pump, pickup, and sender unit deep in the fuel tank. Its quite common for these bikes to come with a substanitial amount of junk in the tank. There are fuel pickup sceens available for the pickup that seem pretty good at preventing this problem form reoccuring. once you remove the pick up unit, clean the screen (usually plugged with plastic mold remnants. You may want to check the injector if it doesn't run 100% after reassembly. Injector fouling is rare nut not unheard of. Husaberg.org is a good forum for owners

May 31, 2011 | 2011 Husaberg FE 570

2 Answers

Engine acts like it is vapor locking.. Can Mow 30


heat related problem, probably needs the valves adjusted. When the engine gets hot the valve clearances change

Jul 10, 2010 | Craftsman 17.5 hp 42 in. Deck Lawn Tractor...

2 Answers

Mower stops running after I've been mowing for about 30 minutes. I changed the spark plug and fuel filter. It seemed to work and I was mowing the lawn then it just started acting like it was running out of...


Mower stops running after mowing about 5 minutes. acting like it was running out of gas unitl eventually stops. I wait 10 minutes and then it restarts, runs good, then erratic...then quits again?

Aug 23, 2009 | Garden

1 Answer

Truck won't start, but after ride on tow truck starts right up, please help?!


Typically when the fuel pump goes it is gone. Have you ever changed the fuel filter? On my 2000 expedition it is inside the frame on the drivers side about midway. Try this first, it is cheaper and easier than a fuel pump. Takes about 10 minutes.

May 27, 2009 | 2000 Ford Expedition

Not finding what you are looking for?
2010 Husaberg FE 390 Logo

Related Topics:

23 people viewed this question

Ask a Question

Usually answered in minutes!

Top Husaberg Experts

Arnie Burke
Arnie Burke

Level 3 Expert

6386 Answers

Marvin
Marvin

Level 3 Expert

85239 Answers

Bill Boyd

Level 3 Expert

53812 Answers

Are you a Husaberg Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...