Question about 1993 Chevrolet S-10 Blazer

1 Answer

Digital display cluster

Speedometer and odometer display. fuel,oil ,tach,water temp no display

Posted by coastie88 on

  • 3 more comments 
  • coastie88 Sep 06, 2008

    yes,digital display came on for a week and went out again

  • jmeluaces Jan 06, 2009

    I alson have nothing working on my dash. The guy we bought it from said he checked into buying a whole new cluster online.Till then we just go slow and put gas in all the time.

  • mitch12 Feb 06, 2009

    93 s10 blazer speedometer and odometer display. fuel,oil ,tach,water temp no display

  • cubewiz Feb 10, 2009

    Same thing... only recently I removed the cluster and just put it back in, then tapped on a white relay or something to the left of the cluster and it started working. That only lasted about 10 minutes and it went dark again.

  • mike watson
    mike watson May 11, 2010

    does the cluster even light up?

×

Ad

1 Answer

Anonymous

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

  • Contributor
  • 4 Answers

Chevy is known for using a cheap grade of wiring harnesses that corrode over time and short out. my 93 s10 blazer had a bad wire in the transmission harness resulting in only 2nd and 3rd gear and wouldnt shift by itself, i dont know if im right but something to check into.

Posted on Sep 08, 2008

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

97 plymouth breeze speedometer,tach gauge,temp gauge,brake lights, dont work.


circuitry behind the gauge panel. you will have to pull the dash to see behind there and track the problem down

Nov 28, 2013 | 1997 Plymouth Breeze

1 Answer

All gauges stop working


CHECK GAUGE FUSE . CLUSTER ASSEMBLE FAILED

Feb 21, 2013 | 2003 Chevrolet Tahoe

1 Answer

Instrument cluster on 97 Wrangler


IF YOU REMOVE INSTRUMENT CLUSTER AND UNPLUG IT,PLUG IT BACK IN AND UNPLUG IT AGAIN..DO THIS A FEW TIMES..IT SHOULD CLEAN OFF SLIGHT OXIDATION ON CONNECTOR TERMINALS..HAVE SEEN THIS BEFORE..I ALSO THINK REPAIR CONNECTORS AVAILABLE FROM DEALER

Jun 21, 2009 | 1998 Jeep Wrangler

1 Answer

Speedometer and Tachometer not working


check the vehicle speed sensor located on the transmission housing.

Apr 11, 2009 | 1992 Oldsmobile Custom Cruiser

1 Answer

Everything on dash panel not working.


Fuse for the instrument panel is possibly blown. Check your owners manual for the proper location of the fuse. If you do not have a manual they are available online in PDF version.

Jan 09, 2009 | 2000 Chrysler Town & Country

1 Answer

Tach and speedometer work intermittenly and sometimes trans doesnt shift until 4500 rpm. vw cabrio 1999 automatic.


Good question! My Cabrio's odometer works only when the outside temps are really cold... that means about freezing temp. My VW repair shop guru guy says that the Cabriolet is notorious for this failing. Since the odometer is driven through a small gearbox via the speedo cable, I suspect the odometer "transmission" is mostly kaput. The tach is also mechanically driven so it also may have a semi-functional cable. The only way to really know is to pull the cable and check it for damage. As far as the trans goes have you tested it for codes?

Sep 15, 2008 | Volkswagen Cabrio Cars & Trucks

Not finding what you are looking for?
1993 Chevrolet S-10 Blazer Logo

509 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

Marvin
Marvin

Level 3 Expert

85239 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22485 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8984 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...