Question about 1987 Nissan Maxima

1 Answer

I have a 87 nissan maxiam that will not start it cranks but has no spark and no injector pulse. The ECM doesn't flash a trouble code, but the anti-theft warning light flashes when the door is open but shuts off when the key is turned on until you start cranking the engine then it flashes again. I've replaced the crank sensor in the distributor thinking this was the problem. I don't know if the system is operating correctly or not.

Posted by osbornautomo on

Ad

1 Answer

richie46

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Nissan Master
  • 12,962 Answers

The issue is with your anti theft device in the car.

Posted on Jul 07, 2017

Ad

5 Related Answers

ginko

Ginko

  • 19396 Answers

SOURCE: no injector pulse

The electronic board that controls the injectors may be faulty, have it tested.

Posted on May 27, 2008

Ad

Anonymous

  • 3 Answers

SOURCE: 1999 nissan maxima.purchasedit and the anti theft

Can you take out the anti theft fuse out (to disable it) see if it works?

Posted on Sep 14, 2009

Villager96

Alfredo Mtz

  • 99 Answers

SOURCE: 1996 nissan quest. car wont start and just keeps

Have a bad knock sensor on my 06 villager and no problem driving it daily, most likely you may have a coil problem, fuel pump or MAF sensor problem. Hope this works

Posted on Jan 11, 2010

Anonymous

  • 1 Answer

SOURCE: I have an 87 nissan 300zx and need to reset the

unplug harness under the pasenger seat.

Posted on Feb 16, 2010

emissionwiz

Marvin

  • 85239 Answers

SOURCE: Is there a reset button for anti theft on a 87

it is reset everytime u unlock the driver or passenger door with the remote or the key, other than that there is no reset button.

Posted on Oct 23, 2010

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

0helpful
1answer

Replace engine won't Nissan altima cranks but want start please help

Have a helper crank it while you visually check for spark at the spark plugs. If spark everywhere, use a gage and check proper fuel pressure, also, check fuel injector pulse.
Check for applicable trouble codes?
I can only help with testing, you have to do the testing.
0helpful
1answer

My 2010 Nissan Altima wont start. All the fuses were checked and the crankshaft sensor was replaced. The alternator and battery are both good.

Check the basics, if it cranks good but won't, gasoline engine, have a helper crank it while you check for spark at the plugs. If spark everywhere, use a gage and check proper fuel pressure. Also check fuel injector pulse. Any applicable trouble codes? To check codes, yourself, at the least, you need an obd2 code reader, that will read manufacturer specific codes as well as p0 codes.
1helpful
1answer

No trouble codes just weak injector pulse after ignition cycle..but when starting strong injector pulse..already change crankshaft sensor learning toward camshaft sensor

strong start weak run indicates a power loss during the run cycle
Try changing the ECM with a known good unit as it may have an electronic failure internally
If you have problem cam or crank sensors, normally it will not allow spark for the engine to run
0helpful
2answers

My 2002 nissan sentra will crank but won't start. i've replace the ecm/ecu, the cam/crank sensor or position, checked the fuel pump/pressure, and it still is doing the same thing. sometimes it

I assume you checked the fuel pressure and it is normal.
Are the spark plugs getting spark when it fails to start ?
Are you getting injector pulse from the computer ?
Any trouble codes stored in the computer ?
0helpful
1answer

On spark

If it where the crank sensor there would be no injector pulse also. If it where the cam sensor you could have unplugged it and see if the car started. I think this one may have a simpler solution. Have you checked for power to the coils? Have you checked the coil fuse or the ECM relay?

I’m happy to assist further over the phone at https://www.6ya.com/expert/jeremy_d728a59f986299fa

0helpful
1answer

99 nissan pathfinder , no spark , no pulse from injectors why?????

The ECM need power and ground,in the engine fuse jubnction box is the ECM fuse this is a 7.5 amp fuse make sure its not blown
0helpful
1answer

2006 beetle no start no spark or injector pulse. Replaced crank sensor , no luck. Fuel pump runs.

No spark no injector pulse your saying you check pulse. With the key in the igition is there a key sign flashing and does the key have a battery for alarm. For the fuel pump to operate it need a crank signal so you got the crank correct but no spark so the crank works. Can you check the ignition for pulse you know how it is shape its curved on one side staight on the other side well the curve side and at that end is the ground after that on is the control from ECM. If you can check pulse there then we can go to the ECM . What I am trying to get at is this your alarm is the only thing beside the ECM that can cause this.
1helpful
1answer

My 2005 Kia Optima will run after sitting a while but sometimes it will just shutdown with no notice at all. It started to hesitate a little about a month ago

SOUNDS LIKE THE CRANKSHAFT POSITION SENSOR . HAD SOME TROUBLE WITH THEM ON THE 4 CYLINDERS VEHICLE STALLS AFTER DRIVING AWHILE LET IT SIT AND WILL RESTART WILL ALSO THROW A CODE IN THE ECM FOR THIS . WHEN IT DOESNT START CHECK AND SEE IF YOU HAVE SPARK. IF THE ECM DOES NOT SEE THE CRANK SENSOR YOU WILL HAVE NO INJECTOR PULSE AND NO SPARK
0helpful
2answers

1990 plymouth lazer rs cranks but no start

If you have no flashing noid light then it will most likely be a cam or crank sensor. One of those sends signal to the ECM for injector pulse. You should have it scanned to see if it has a code for either. I know Autozone does it for free!
1helpful
1answer

Little to no injector pulse only when starter is engaged

95-97 Maximas had a problem where condensation from the A/C would accumulate in the a/c evaporator case from the drain becoming restricted or blocked, When this would occur, condensation would drip onto the ECM and a problem would develop with misfire and/or starting. I would look at the ECM where the harness connects to it for corrosion problems. If you find it, there is a chemical spray which can be used to clean the terminals and/or you can clean them, although it is time consuming and difficult to due because of how small the terminals are. After things are cleaned up, lightly coat the connections with a dielectric grease. This will prevent electrolysis.I believe you can buy these at Radio shack and possibly at an automotive parts supplier.
Also a drop in voltage during the cranking phase will cause a weak spark. Your ignition is what pulses the injectors. It takes a minimum of 9.6 volts, but ideally you want at least 10.5 or more during the cranking phase if you want to get a spark worth anything. Check the voltage on the primary side of the coil while cranking the engine.
I'll watch to see if things work out for you, let me know. ....mybunkey
Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

137 views

Ask a Question

Usually answered in minutes!

Top Nissan Experts

gerry bissi

Level 3 Expert

4390 Answers

Thomas Perkins
Thomas Perkins

Level 3 Expert

14942 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6928 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...