Question about 2002 Toyota Camry

2 Answers

Car starts but will rev up a couple of seconds then cut off. but will stay running if I accelerate but will potential cut off again if come to a stop. does this for about the first half hour its on. What could be the problem? Fuel filter? Fuel pump? Engine?

Posted by outlaw_1979 on

Ad

2 Answers

Vincent G

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Toyota Master
  • 2,363 Answers

Are you one of those people who TOP OFF the tank when filling up?

When the EVAP recovery system soak with few ounce of gasoline......the trap vapor will take few days escape.

EVAP system is design to handle fuel vapor. Few ounce of gasoline can damage the fuel vapor recovery relay and decrease the service live of the recovery lines.

=========

You can accelerate the process by locating the charcoal canister (near the nose of the car and same side as your gas filler door)

MOVE the car to outdoor.

Disconnect the EVAP line and let it air out by itself.

DO NOT introduce any heat source or fan to speed up the process.

Reconnect this EVAP hose and use a small amount of starting fluid at the intake manifold.


Please post more information by Clicking on the comment link.

I will follow up.

Posted on Dec 03, 2009

Ad

Anonymous

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 308 Answers

If the problem of your car is the fuel filter .You have to locate the fuel filter and prepare the equipment or tools to be used in checking the or repairing the fuel filters.there are two filters , the primary filter and the secondary filter.Disconnect the fuel lines at fuel filter observe safety practices. if the present fuel filter is dirty and not any more use full then replace and install new fuel filter. If the problem is the fuel lines then you have to locate the fuel pump then prepare the tools or equipment to be used in servicing the fuel lines.Visual inspection on duel line for learage.Disconnect lines at fuel pump and fuel tank.Use compress air to remove sediments on fuel lines .Re install fuel lines to the unit.Locate the fuel pump . Prepare the tools or equipment in repairing the fuel pump.So that fuel pump will operate properly. locate the fuel pump.Disconnect the fuel lines from the fuel pump.Remove fuel pump from the engine.Dis assemble fuel pump.Check daiphram for defects .Replace defective parts.Assemble and install fuel pump.If you don't have time to do it then it is advice. that you go to the toyota car shop and let the mechanic to do the job .One of the kind of engine that I studied as a mechanic are toyota 3K ,and 4K .

Posted on Oct 15, 2009

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Corsa 1.3i over revs


run fault codes and check for MAF/MAP sensors and HO2S and HO2 sensors.

Feb 18, 2014 | Cars & Trucks

1 Answer

1993 festiva replaced the throttle body gasket now will not accelerate at temp


I have a 1997 ford E 150 customize mark 3 van have driven back and forth to work 5 years ran great Christmas Day drove down to the garage and back up to house and now it will not start turns over has spark will not fire

Jan 07, 2014 | 1993 Ford Festiva

1 Answer

Engine will idle but will not accelerate


Fuel pump faulty, clogged fuel filter. Check for those.

Dec 04, 2013 | Volkswagen Cars & Trucks

1 Answer

Pathfinder "cuts out" at 2,300 rpm


Replace your MAF, its a little pricey around $280.00 or so but this will clear the code but make sure you have the ECM reprogrammed to perform a "learning" sequence since sometimes the code will not clear even though the vehicle will run like new. This reprogramming will most likely have to be a dealer performed procedure.

May 02, 2013 | 2003 Nissan Pathfinder

1 Answer

Overheat and accelerating automatically


Time to change the thermostat if you not already have done so. This is the cause of most overheating problems, although a good radiator flush may solve the problem also. The fan will stay running until the engine coolant reaches the proper parameters and then shut off.

Jul 28, 2017 | 2003 Volvo S40

1 Answer

Car start but in like second it cut off


Just started the car and it cut straight out. It revved up like a normal start but instead of revs dropping to normal it cut out. I decided to try and drive it anyway to top up with petrol as light was on (But not near empty) and when I came to a stop it cut out. On starting it up this time the car revved up to the redline by itself and I had to quickly remove the key. It did this 3 more times then on the fourth start it decided to stay on but rev itself and kept reving between 1 and 2000 revs as seen in the video here I just took: YouTube - Alfa 156 constant reving


When I turn the car off it doesn't just cut out as usual either...now it sort of takes an extra few seconds as seen in this second video I just took: YouTube - Delay in turning off (The key is turned at 7 seconds)

I know the is a hole in my exhaust somewhere because there is alot of hot air coming from the drivers door area and its been like this for a few months now but surely a hole in an exhaust can't cause all this. Any ideas?


Oct 20, 2012 | 1989 Ford Tempo

1 Answer

2000 vw beet bogs out after few seconds


hallo
remove, clean throtle body with throtle body cleaner or nitro.
Marko

Dec 05, 2009 | 2000 Volkswagen Beetle

2 Answers

Honda Civic 2002 1.7, when driving the car, it's seems like the car switches off for a split second and the engine management light shows for the split second. The rev counter drops. When cutting out...


Check all the wires. Especiality the ground wire.
Battery terminal.
And grounds mounted on the intake.
Normally when no codes are present, Is a lost of electrical power.

Jun 05, 2008 | 2002 Honda Civic

Not finding what you are looking for?
2002 Toyota Camry Logo

326 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

Marvin
Marvin

Level 3 Expert

85239 Answers

Thomas Perkins
Thomas Perkins

Level 3 Expert

14866 Answers

Mike

Level 3 Expert

4372 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...