Question about Cars & Trucks

1 Answer

Have a 1987,fxst,turns over good,sometimes it fires right up,and then I get no fire to plugs at all,then all of a sudden it fires up,it may run for a good while or it might shut off just real quick,as if I loose power,I've checked everything and am stumped,can you help me

Posted by Jerry Rash on

Ad

1 Answer

zoe dee honea

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    New Friend:

    An expert that has 1 follower.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 45 Answers

You might check the safety neutral switch and wiring to it. could be loosing contact

Posted on May 23, 2020

Ad

5 Related Answers

Anonymous

  • 250 Answers

SOURCE: 97 dodge stratus 2.4 ,testing a camsensor

Have you had the ignition switch changed? If the ignition switch is faulty you can have issues getting the car to turn over. Also when driving the car can just shut off. The contacts in the ignition switch just wear out over time. It's a good place to start looking.

Posted on Dec 16, 2008

Ad

Anonymous

  • 463 Answers

SOURCE: my 2000 v8 toyota tundra suddenly lost power

Does this motor have the equivalent of crank-trigger ignition? If so, is the sensor A-OK?

Posted on Mar 02, 2009

Anonymous

  • 6 Answers

SOURCE: 1995 camaro z28 keeps loosing fire

it might be the optispark harness wire.it starts and runs good. once u turn it off its hard to turn back on?

Posted on Apr 06, 2009

Toyota Ed

  • 1861 Answers

SOURCE: 2000 Toyota Tundra starts occassionally. Sometimes

Welcome to FixYa! You need to replace the starter solenoid contacts, or the starter itself.

Note that the starter is UNDER the intake manifold. This is a VERY difficult job, and is not recommended to those who do not have sufficient automotive experience.

If you DO remove the intake, you MUST replace the intake manifold gaskets, or your engine will not run properly, due to air leaks at the intake mating surfaces.

Posted on Sep 12, 2009

c17hydro

Greg Bernett

  • 2989 Answers

SOURCE: 1987 olds 88 with a 3.8 , will fire, backfires won't run

It takes less than an hour. Removal & Installation

  1. Disconnect the negative battery cable.
  2. Raise and safely support the vehicle. Remove the right front wheel and tire assembly.
  3. Remove the right inner fender access cover/splash shield.
  4. Detach the electrical connector from the CMP sensor.
  5. Unfasten the retaining screw, then remove the CMP sensor.

8885e91.gif
Exploded view of the Camshaft Position (CMP) sensor mounting

To install:
  1. Install the CMP sensor, and install the retaining screw. Tighten the screw 35-53 inch lbs. (4-6 Nm).
  2. Attach the electrical connector to the CMP sensor.
  3. Install the right inner splash shield/fender access cover.
  4. Install the right front wheel and tire assembly, then carefully lower the vehicle.
  5. Connect the negative battery cable.

Posted on Oct 11, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My mule will not keep running. Stopped suddenly after good start. Replaced the fuel pump. Still will not keep running. Fires. Then stops. Fires on starting fluid. What could it be?


When you say it fires with starting fluid can you keep it running with the starting fluid or does it just fire while cranking the starter then stop when the key is turned to run if it keeps running with the starting fluid then you still have a pump problem or the filter could be plugged or the carb could be bad but if it'd fuel injection then it might just not getting enough pressure fuel injection takes high pressure

Sep 18, 2017 | Cars & Trucks

1 Answer

1987 dodge d150 w/3.7 running rough. replaced distributor,spark plug,cap and rotor.now the truck won't start. tried rotating dist 180 degrees still nothing.


take #1 plug out bring the cylinder up on T.D.C.(top dead center) check timming marks making sure that it is T.D.C, on the firing stroke, look at rotor see if it is pointing at #1 on the cap,also check plug wires make sure they are on the right place on cap , and plugs,and check firing order
hope this helps!

Feb 19, 2011 | 1987 Dodge Ramcharger

2 Answers

My 2001 pontiac grand am all of a sudden quit running.went to start it wont start.changed spark plugs nothing.took off main fuel line right at fuel rail turned key gets plenty of gas.put carb cleaner in...


It depends on the # 1 ijector to fire then the rest follow,i u have test for injectors teat the 3 1 TO SEE WORKING PROPERLY,WHAT ELSE SOMETIMES ON GRANDAMS THE INGNITION SWITCH GOES OUT....

Aug 23, 2010 | 2001 Pontiac Grand Am SE

2 Answers

What is the firing order for an 87 honda civic dx


9k=
hope this helps

images?q=tbn:and9gctvecsmcfurspcu6uxiv4sblkd7kqgyyxr1nfdfrygqi9jhzjk&t=1&usg=__fctvclp78gjluiuohcfa1_xlnim= dist.jpg
287 × 328 - Make sure that you have the spark plugs wires in the right order... IT WILL RUN LIKE **** if they are not in the right order. here is the firing order on ...
htarchive.org
Similar

Aug 19, 2010 | 1987 Honda Civic

2 Answers

1987 olds 88 with a 3.8 , will fire, backfires won't run


It takes less than an hour. Removal & Installation
  1. Disconnect the negative battery cable.
  2. Raise and safely support the vehicle. Remove the right front wheel and tire assembly.
  3. Remove the right inner fender access cover/splash shield.
  4. Detach the electrical connector from the CMP sensor.
  5. Unfasten the retaining screw, then remove the CMP sensor.

8885e91.gif
Exploded view of the Camshaft Position (CMP) sensor mounting

To install:
  1. Install the CMP sensor, and install the retaining screw. Tighten the screw 35-53 inch lbs. (4-6 Nm).
  2. Attach the electrical connector to the CMP sensor.
  3. Install the right inner splash shield/fender access cover.
  4. Install the right front wheel and tire assembly, then carefully lower the vehicle.
  5. Connect the negative battery cable.

Oct 11, 2009 | 1987 Oldsmobile Delta 88

1 Answer

1987 Jeep wrangler fires up, but stalls after 1 or 2 seconds


when you take alternator out of play. the vehicle runs. i would be replacing the alt. these units are complex containing modules, regulators that can give you erratic problems, but i think u answered your own question alternator


hope2help shack

ps. good mechanic wont leave you stranded

Apr 17, 2009 | 1987 Jeep Wrangler

1 Answer

1995 camaro z28 keeps loosing fire


it might be the optispark harness wire.it starts and runs good. once u turn it off its hard to turn back on?

Mar 30, 2009 | 1995 Chevrolet Camaro

1 Answer

Bmw 535 ,1987 stops abruptly on the road !


Had similar problem on my 97. Replaced main computer. No more problems after 28k miles.

Jul 24, 2008 | 1987 BMW 5 Series

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

17 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

Marvin
Marvin

Level 3 Expert

85239 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22485 Answers

john h

Level 3 Expert

23401 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...