Question about Isuzu Rodeo Sport

1 Answer

The Isuzu idles very bad " but just on idle " I just put in a new mass air flow sensor,the car would not run at all. Runs ok now but still have a rough idle I would like to get rid of. Oh! it's a LS model 4x4 with 79500 miles. Larry.....

Posted by lbrown55 on

  • 1 more comment 
  • lbrown55 Aug 14, 2009

    Smith: sounds like you know what your talking about, but what is the ICS valve and where is it located in the engine compartment, I don't have a clue what to look for. Thanks Larry

  • lbrown55 Aug 14, 2009

    Smith: I hope you can find i diagram, it would be a great help to a not so great mechanic like me. Thanks again Larry

  • lbrown55 Aug 15, 2009

    Hey! just thought I'd let you know I looked under the hood and there's so many things with wires going to them I would never be able to guess which is the idle control. I only knew where the mass air flow thing was because some one showed me where it was. Hope you have a diagram or can tell me a closer location. Larry

×

Ad

1 Answer

Shereena M Smillan

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 601 Answers

Hi…

This is issue with the ICA valve.
You can try get it cleaned as it works many time.
If not it have to be replaced.

Thanks
Smith

Posted on Aug 14, 2009

  • Shereena M Smillan
    Shereena M Smillan Aug 14, 2009

    Sorry i miss spelled it is IDLE AIR CONTROL VALVE (IAC).

    It is located at the front side of the engine.

    Let me check if i can find a diagram.



    Thanks

    Smith

  • Shereena M Smillan
    Shereena M Smillan Aug 15, 2009

    Hi..

    I cannot find the diagram showing the exact position of the IAC valve in the car but this is the part that you are looking for.Check this




    Thanks

    Smith

×

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1993 ford ranger 3.0


Replace map sensor

Mar 10, 2013 | Cars & Trucks

2 Answers

Replaced mass air flow sensor, fuel filter, air filter, plugs, wires, cap and rotor. Truck would not go past 2500 RPM before I installed new maf sensor. Now it wont idle when stopped. Runs fine down the...


Make sure there are no vacuum leaks around the mass air flow sensor. If it won't idle when stopped, change the Idle Air Control Valve. Reset the ECU module by removing the negative battery terminal and leave it aside for ten minutes and then reconnect it.

Jun 23, 2011 | 1997 Nissan Pickup

1 Answer

1996 t bird 4.6l idles up and down


If it idles up and down real high, its the throttle body sensor. If it's a low up and down idle and runs rough it is mass air flow meter. If you unplug the mass airflow meter and it will just low idle (no up & down) then the mass air flow meter is bad.

Feb 11, 2011 | 1996 Ford Thunderbird LX

1 Answer

Poor idle dtc P1151, P1131,P0174, P0171. runs ok


Change plugs, and Mass Air Flow sensor. This should do the trick

Nov 29, 2009 | 2003 Ford Taurus

1 Answer

'93 D21 ka2.4. miss fire,surge, and runs rich


sounds like you have a very dirty mass air flow meter. invest in a new one and be sure to clean the throttle body with an appropriate cleaner and tooth brush.

Nov 03, 2009 | Nissan Hardbody Cars & Trucks

1 Answer

1989 ford bronco idles low and dies when stuck in reverse


Check the fuel pressure. If good, then see if there is vacuum leak with a vacuum gauge. If good take the idle control valve off and see if there is a lot of grim inside. Or it may be the mass air flow meter maybe bad. Try cleaning it with some mass air flow cleaner. See if it idles better with intake cleaner being sprayed in the intake with it running. First see if it runs a little better with the mass air flow unplugged. If so then the sensor is bad.

Sep 17, 2009 | 1987 Ford Bronco

1 Answer

97 ford taurus idles and kills when putting it in gear


check the vaccum hoses to make sure none are off and check the timing and also the drive belt and also check the vacuum hose behind the throttle body

Dec 31, 2008 | 2006 Ford Taurus

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

290 people viewed this question

Ask a Question

Usually answered in minutes!

Top Isuzu Experts

Marvin
Marvin

Level 3 Expert

85239 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22485 Answers

Thomas Perkins
Thomas Perkins

Level 3 Expert

14846 Answers

Are you an Isuzu Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...