Question about Cars & Trucks

1 Answer

Hi,I had a 4g93 engine srgc5 and I replaced it with 4g93 srgc8 I realised that the fuel pressure switch harness are different , the engine is running but check engine light is on. How can I modify it

Posted by Linus Odhiambo... on

Ad

1 Answer

Jonathan Buck

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Cars & Trucks Expert
  • 370 Answers

....plug it into a computer to erase the code

Posted on May 28, 2018

Ad

5 Related Answers

daves944

Dave C

  • 1050 Answers

SOURCE: Buick Regal dying

You have a problem in the fuel pump relay circuit for sure then. I'm betting the relay, but it could be that dropping resistor.

Posted on May 11, 2009

Ad

Anonymous

  • 218 Answers

SOURCE: 94 dodge ram 1500 5.2 replaced fuel pump still no

U NEED TO CHECK THE FUEL PUMP AND AURO SHUT DOWN RELAY.THEY ARE IN THE UNDERHOOD FUES & RELAY CENTER.U CAN SWITCH THEM 1 AT A TIME WITH A/C RELAY.IF THAT DOES NOT WORK U MAY HAVE A PROBLEM WITH THE PCM

Posted on May 13, 2009

SOURCE: 1987 Chevy S10 TBI 4cyl 2.5 L will not run. I

Check the injector for 12v on one wire. if good check the other wire for a ground witth the key on. The ground wire pulses from the ECM If you dont have 12v from one wire to the other but you have 12v from one wire to battery ground then be sure the ground wire is good to the computer. If you don't have 12 v at any time check for open hot wire or bad fuse. ADD 12v to the hot wire at the injector. DO NOT add to the wrong wire or you will fry the computer

Posted on Jul 15, 2009

pippall

Philip Long

  • 1486 Answers

SOURCE: 1987 chevy S10 engine idle problem

relace the throtle air idle valve.The temp switch will allso cause this problem.

Posted on Jul 19, 2009

Superbovine

  • 333 Answers

SOURCE: 4G93 Interference Engine

The 4G93/1.8L is an interference engine.

Posted on Sep 24, 2009

Testimonial: "Thanks for the quick response"

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

No injector pulse on 4g93 gdi dohc engine?


On cars in the U.S., the power wire to injectors is a fused circuit- it is supplied with constant battery power anytime key is in on, or run, or start. So the fuse says hot in run or start. See if your injector connector has one hot terminal with key on. That is the power, and the ground to injectors goes right into the ecu, into what is called the injector drivers, but they really provide ground for the injector solenoid. The harness connector to the throttle body unit should have both injector power and ground wires.

Jan 09, 2018 | Cars & Trucks

1 Answer

I have a mitsubishi lancer mr 98 coupe 1.8ltr 4G93 engine I have spark have fuel and pressure if I spray some start spray it will start for 5 or so seconds but the injectors are not pulsing ideas?


the injectors are controlled by the ECU so i would have the OBDII codes read as this should pinpoint the sensor/switch that is causing the problem

Jun 28, 2015 | Mitsubishi Cars & Trucks

1 Answer

It not starting 4g93 galant


I suspect that your fuel system is faulty. Check for a clogged fuel filter, or if your fuel pump don't run at all, replace the "fuel pump relay". Sometimes your fuel pump will run, but be too weak to hold pressure, which will let your car idle somewhat, but be too weak to run the engine at speed or under load.

If your car is getting fuel, then the igniton system is faulty. Things to check or replace in the order that I would check them are here: They are the coil, igniton module, cam and crankshaft sensors, map sensor. Your car may be out of time due to a broken timing belt/chain, or it may have been loose and jumped a few teeth on their cogs. Check engine timing and condition of belt. These are not all of the igniton components, but the most common items that go bad. The rest of the components and sensors shouldn't cause your car not to start, but affect driveabiliy.

Dec 17, 2013 | Mitsubishi Galant Cars & Trucks

1 Answer

Electrical problem for the fuel no power


A lot of newer vehicles have a fuel pump cutout switch on the engine. If the engine shuts down for any abnormal reason, it loses oil pressure and one of the things that happens is the fuel pump is cutoff. This is a safety item in case of an accident which shuts off the engine. Check for the oil pressure cutout switch on the engine, which is usually different from the oil pressure gauge or light switch. Can't say exactly where it is, sometimes on the upper rear part of the engine behind intake manifold or on lower side of engine right into the block. The fuel pump run circuit is different from the fuel gauge circuit although they usually run in the same wiring harness if the fuel pump is in the tank. If the pump is not in the tank then the fuel level sender in the tank is probably defective and should be replaced.

May 12, 2013 | 2001 GMC Savana

2 Answers

Pajero V6 still will not start (6G74)


Did you erased the code manually or the code clear itself?

Feb 02, 2013 | 2005 Mitsubishi Pajero 3.5

1 Answer

I have a 2001 rodeo V6 standard. The check engine code is for mulitple missfires. Sometimes when you stop the rpm go down to zero and acts like it wants to die. Have tried taking off the coil packs one at...


whats your fuel pressure when this happens are there any O2 sensor codes also? or fuel trim codes?
if low is pump at fault? or is fuel filter blocked?
check fuel pressure regulator on rear of inlet manifold left side of car- pull off vacuum hose going to inlet manifold while engine is running to make sure fuel isnt leaking out of hose, might have to take of protecting bracket dont usually have to though.
what is your fuel quality like?(no water or contamination/stale fuel)
how many KM's what are plugs like or plug gaps?
and check is it burning oil? fouled plugs?

there was a problem with earth crimp in engine harness on left bank front section near injector that needs to be cleaned and soldred to repair or replace with new engine harness, its for O2 sensors, TPS, canister purge solenoid and IAC motor injectos also wires break in same harness on the front left head(rocker cover/cam box cover) while its running wiggle and pull on loom if engine starts to run rough or stumbles its probably wiring related.

dont disconnect coils wiring looms while engine running it can damage driver circuits in engine ECU!!!

so some things to look over hey.

Mar 10, 2011 | 2001 Isuzu Rodeo

1 Answer

I have a Silverado 1500, 4.3 with 132,000 miles. After start, it runs fine, no signs of malfuntion. However it takes extended cranking to start. The fuel pump & filter was replaced 10,000 miles ago....


You need 3 things.
Compression
Good hot blue spark to all plugs.
Good gasoline and proper fuel pressure. 63-64 lbs.
If you have all 3 then move on to injector pulse to all injectors.

You may be weak on fuel pressure . even a couple of lbs low on a cold start will cause a no start. Double check cold start cranking fuel pressure. If under 63-62 lbs you have problems. One test is to give it a squirt of carb cleaner not starting fluid. If it starts then you have a fuel pressure problem. Run the full fuel pressure test and post back pressures. Here is the guide lines on testing.
Hard to start cold.
Check cold start fuel pressure.
Check engine running fuel pressure.
Check engine running on the road fuel pressure.
Then shut it off and watch for fast leak down.
Pinch off at rubber part or block off return line and check full pressure.
Later V6 and V8 gm engines should have 60-66 fuel pressure.
Cold start should be 64-65 lbs of pressure.
If you do not have full fuel pressure on a cold start the injectors will not squirt fuel.
Do not leave home without it.
Engine running should be 60-66 lbs pressure depending on engine load.
Full pressure with return pinched off should be 75-85 or more.
And if it has a fast leak down after shut off you have a leak.

Also you mentioned that you replaced the fuel pump, it's common for the $15.00 wire harness from the fuel pump to the frame will break and there is a bad connection till the wires heat up. You can try this trick, turn your ignition on for 30 seconds "engine not running" and then turn it off for for 5 seconds and then try to start. This will energize the fuel line if the fuel line check valve is bad which is a part of the fuel pump and will heat up the wire harness which will make a better connection and see if the engine starts easier. Regardless, inspect the wire harness for corrosion and the ground is good. Good luck and keep me posted.

Dec 15, 2009 | 2000 Chevrolet Silverado 1500

3 Answers

Gdi 1800 cedia wagon-odometer 80,000km exact, starting, no power


Hi it sounds like your high pressure pump needs replacing. the pump can be repaired but you will have to find someone who knows about it, i fix a lot of them before. there is a spring that pushes out the piston in the pump so it can compress the fuel that spring losses its ability to extract the piston back out. i have pictures of one if anyone wants to see

Jan 03, 2009 | 2002 Mitsubishi Lancer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

39 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

Marvin
Marvin

Level 3 Expert

85239 Answers

john h

Level 3 Expert

23504 Answers

Arnie Burke
Arnie Burke

Level 3 Expert

6487 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...