Question about Proton Cars & Trucks

1 Answer

Hi Guys I bought a proton savvy. The problems is when the car gets hot it starts to cut out while idling. As soon as the revs drop it starts to cut out. Does anyone have an idea of what it could be?

Posted by Danie on

Ad

1 Answer

Kaye Young

  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

  • Contributor
  • 2 Answers

It sounds like you need your timing needs adjusting/ good luck K...

Posted on Mar 19, 2017

Ad

5 Related Answers

emissionwiz

Marvin

  • 85239 Answers

SOURCE: e46 318i idle rev problem

GO TO A KRAGEN OR AUTOZONE AND HAVE THEM RUN A TROUBLE CODE TEST, THIS COULD BE A TPS PROBLEM, VACUUM LEAK OR STUCK/WARPED THROTTLE PLATE.

Posted on Feb 14, 2009

Ad

Anonymous

  • 5 Answers

SOURCE: 1994 bmw e36 325 tds

There is a company in Northern Ireland called Exact Engineering that can convert your dual mass flywheel to single mass using a complex engineering process ending with a finely balanced guaranteed single mass product. They have a complete courir service.

You can see their website at www.exact-spec.com and contact them at [email protected]

Posted on May 29, 2009

Anonymous

  • 5 Answers

SOURCE: CAR STARTS DROPS TO IDLE AND DIES.

Maybe the spark plug wires? Spark plugs?

Posted on Jul 14, 2009

simba2403

  • 32 Answers

SOURCE: car wont idle at all

ok idle valve is playing up small device on your throttle body that controls you idle look up on web or here is a link were you will see it
http://www.cobbtuning.com/info/?ID=3481

Posted on Nov 05, 2009

Anonymous

  • 1 Answer

SOURCE: VW Golf Mk3 2.0L 16v low idle rev/cold cut out

hi i have the same problem.but i cat find what to do.iff u eill find out please le me know.07853592087

Posted on Jan 18, 2010

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

09 proton savvy engine starts first but wont rev up


after read up on this engine fitted im guessing its an automatic. there are a few things to check
first is to check the MAF sensor. unplug it and start engine. if it revs after being removed then it could be this.
other one is the D don't use it place it in number 1 and see if the revs go up and vehicle moves.
the other is the throttle sensor. is there any change on the movement of the engine while moving the accelerator, does the engine change sounds etc.

Jun 29, 2017 | Proton Cars & Trucks

3 Answers

Proton savvy 1.2 automatic 2006 model. immobilizer light flickers but when ignition on shines constantly. engine turns over but fail to start.


Hi. Thanks for your question. For assistance on proton savvy 1.2 automatic 2006 model you can visit https://www.reliable-store.com and download the entire workshop manual which includes all the information along with the diagrams for better understanding. Good day!

Nov 12, 2016 | Proton Cars & Trucks

1 Answer

Proton savvy 1.2 runs for a while then stalls


hi,
savvy engine is same with renault engine. there's a flywheel sensor/engine speed sensor between engine and gearbox. change the engine speed sensor.
The engine speed sensor is control the ignition timing, if the sensor can't read the 0' angle the engine won't fire up.

Jul 10, 2014 | 2009 Proton Savvy 1.2

1 Answer

Why proton savvy won't start again after 3 mile journey


hi,
the engine speed sensor should replace
your engine won't start if the sensor can't read the 0 timing angle point on flywheel.

Jul 08, 2014 | 2009 Proton Savvy 1.2

1 Answer

I have a Proton Savvy 2009 model milliage still very low but sometimes it does not want to start at first i thought it may be the battery but the battery is fine, when you turn the key all the lights light...


Hi. Thanks for your question. For proton savvy milliage issue you can visit https://www.reliable-store.com and download the entire workshop manual which includes all the information along with the diagrams for better understanding. Good day!

Jun 05, 2017 | 2009 Proton Savvy 1.2

1 Answer

1998 VW Golf Tdi idle problem, it starts fine wean cold but as soon is hot does start up to 1100 revs for about 2 minutes.


sounds like a failing o2 sensor. or MAF sensor. but it could also be a blocked egr valve, its common on the tdi over time. sometimes don't even register as a fault on ecu codes.

Jul 25, 2017 | Cars & Trucks

2 Answers

How to fix this problem?


A big vacuum leak will do this it can be from a open PCV valve sticking open EGR valve to a sticking a IAC (idle air control valve) sticking open. You basically have something get stuck and closing.

Mar 09, 2012 | Cars & Trucks

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

406 people viewed this question

Ask a Question

Usually answered in minutes!

Top Proton Experts

gbob59

Level 3 Expert

3063 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22485 Answers

john h

Level 3 Expert

23438 Answers

Are you a Proton Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...