Question about Cars & Trucks

1 Answer

Car wont start ,no spark after replacing crank sensor

Cambeld broke got it Fixed.After fixing car wont start no spark .Diagnostis gave po335 .I replaced crank sensor with new one but still wont start and no spark and it gives me the same po335.Can u help pls

Posted by Cobus van der Merwe on

Ad

1 Answer

magna buff

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Cars & Trucks Master
  • 3,828 Answers

What maker of vehicle and motor are we talking about

EDIT Proton Arena 15i

something else is wrong
what ever is causing the no start does not have a code

yes PO335 right code and right part to replaceCar wont start ,no spark after replacing crank sen - 6f1d8180-d547-4234-91c5-2b7b4c4df33f.jpg


Posted on Jun 22, 2016

Testimonial: "Make off car Proton Arena 15i Cambeld broke send head to ing works they did replace all valves.Got it back ,done cambelt try to start ,no spark Then i replaced the coil,cam sensor,and ecu took diag test codePO335 replaced sensor still no spark.I did clear code try to start again not starting do test again PO335"

  • 2 more comments 
  • magna buff Jun 22, 2016

    on the same page as you
    picture of car and engine in first answer

    so timing marks are correct and there is good compression on cyl one
    engine light should be on

    have you got continuity tester an led test lamp / amp /volt meter as part of you r tools
    i am thinking
    if all the wires are sound and test ok
    replacement cas could be faulty
    replacement ecu has that code stuck in its memory

    massive coil on that car


    if you did coil cas and ecu at the same time
    bit difficult to know what was faulty


    wonder if the pin into the ecu is bent/corroded or cas plug or coil connection
    did your ecu replacement have the same casing numbers

  • Cobus van der Merwe
    Cobus van der Merwe Jun 22, 2016

    yes it did

  • Cobus van der Merwe
    Cobus van der Merwe Jun 22, 2016

    I will do a few tests and let you know asap
    Thank you

  • magna buff Jun 22, 2016

    while testing stuff
    unplug a few other sensors
    see if the diagnostic tool picks up the ones you unplugged
    and then if all those fault codes clear after plugging them all back in

×

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I have these codes reading now po700 po335 and po727 any idea what to check first on 03 kia sorento. my car lost power then shut off, then wouldn't start


p0335 is a crank shaft sensor error. This sensor is what tells the ECM when to send spark to plugs. That is why it wont start.

Apr 02, 2016 | Kia Cars & Trucks

1 Answer

Trouble code PO335


fuse or fuel filter first! Cam sensor.

Nov 02, 2015 | Cars & Trucks

2 Answers

Fuel pump went bad fixed that now my car wont start


Now you check fuel pressure at motor with a gauge

Also check for spark & injector pulse while cranking

Dec 15, 2012 | 1996 Nissan Maxima

1 Answer

Why the motor wont runn after alternator fixed


The computer is not getting a signal from the crank sensor.
A low battery could cause this, but normally it is the sensor or a wiring problem.

Jul 03, 2012 | 2002 Kia Sedona

1 Answer

I have a 2005 hyundai sonata 2.7L. The car is loosing power at about 35mph, the car gave me a po335 code crankshaft sensor. Were can I find it exacly, the book does not give me the correct location. I...


PO335 crank shaft postion circuit "A" circuit malfunction This sensor is mounted on the left side of the engine block,Near the flywheel. If you replace this because its a code let me know if it worked and if you are getting more than 35 mph.

Apr 25, 2011 | 2000 Hyundai Sonata

1 Answer

Hard start


Is it harder to start in cool weather?...My Olds would crank but not start in cool weather, she would cough and sputter and finally start...Shop fixed her, replaced COIL.

Mar 12, 2010 | 1997 Chevrolet Cavalier

1 Answer

Car wont start


being 94' im sure it has high miles, cam and crank sensor common to fail over time do to wear and heat exposure. check the basic, make sure you getting fuel and sparks. fuel pump only work as long the engine is turning over due to the crank sensor sense the flywheel turning. crank sensor may be faulty. no sparks, check coil make sure is good and putting out 12v, auto zone can test it for free. good coil, than check cam sensor, cam sensor senses the cam turning and tell the ecu to tell the coil to disperse the sparks to the plugs. cam and crank sensors, there no way of testing it but replacing the unit unless you have the special equipment to test it; both is fairly cheap to replace, check ebay.

Oct 24, 2009 | 1994 Mazda MX-6

3 Answers

My 1997 chevy cavalier wont start.its getting spark and fuel.but wont fire it has a 2.2 ecotec.


Sounds like cam belt has snapped. If it broke while starting, could be cheap fix...new belt. Worst case: cylinder head off for overhaul...bent valves / pistons replaced.

Mar 09, 2009 | 1997 Chevrolet Cavalier

1 Answer

NO SPARK!


The crank and or the cam sensor has failed. If you have no way of pulling codes or checking for signals from the sensors, start with the crank sensor, its more common.

Feb 08, 2009 | 1997 Chrysler LHS

2 Answers

Wont start


did you check the fuel pump relays?

Aug 29, 2008 | 1996 Chevrolet K1500

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

117 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

Marvin
Marvin

Level 3 Expert

85239 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22485 Answers

john h

Level 3 Expert

23438 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...