Question about Cars & Trucks

1 Answer

I have a 07 Mack CXN 613 & the fan clutch won't shut off . I have 3.4v to ground side of the clutch fan connecter cause everything checks out good. It has a Horton electric/air clutch . HELP!!!!!!!

Posted by Anonymous on

  • 8 more comments 
  • Anonymous Apr 19, 2016

    I changed the heater control unit the a/c pressure sensor a/c is working properly. I ohmed the harnesses (no breaks) i checked coolant temp sensor harness I changed air temp sensor. Changed ALL the relays all fuses and breakers r good.

  • Anonymous Apr 19, 2016

    I it has good air press

  • Bill Boyd Apr 19, 2016

    yes it probably has but is that pressure actually getting to the air clutch or is the leak from the valve /solenoid allowing just enough to make the fan spin but slip at high engine rpms

  • Anonymous Apr 19, 2016

    There is no air leaks. I ohmed all harnesses and checked good

  • Anonymous Apr 19, 2016

    I changed air temp sensor coolant temp sensor and high pressure sensor for the a/c

  • Anonymous Apr 19, 2016

    I changed heater control unit. There's no breaks in the wires. It's getting 3.4v to ground side to the solenoid which isn't alowing the solenoid to send air to the fan to disengage

  • Anonymous Apr 19, 2016

    No because it has no ground to open the solenoid to let air get to the fan. The fan is not slipping it won't disengage cause there's voltage at ground to the solenoid and all wiring is checking out good

  • Bill Boyd Apr 19, 2016

    the electrics should be 12 volts or 24 volts
    The resistance in the coil of the solenoid will reduce that input voltage to around what you are reading
    to disengage the fan solenoid there should be no voltage into the solenoid and there should be a spring in the solenoid to push the rod into the air control valve to close it off and open an exhaust port to allow air in the clutch system to exhaust
    As I originally stated the problem is in the solenoid, power to the solenoid or the air control to the clutch

  • Anonymous Apr 19, 2016

    The problem isn't i. The solenoid its brand new and the voltage is good but I'm not supposed to have voltage to ground. I have a fleet of all the same yr same model trucks so I tested another truck to c and the ground has 0 voltage. Like I said I checked everything and everything is checking good.

  • Anonymous Apr 19, 2016

    Cause if I manually ground it the fan works perfectly the way it should but throws a code so obviously I can't do that. By the way thanks for helpin Bill.

×

Ad

1 Answer

Bill Boyd

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Cars & Trucks Master
  • 53,814 Answers

Replace either the solenoid for the air valve or the air valve as you are still getting air pressure to the clutch
While that may not seem important, it is to be considered that if the clutch is not getting full air pressure to keep fully engaged, it will slip at any thing less and that will burn out the clutch facings in the long run
there are manuals for horton fan clutches so go google and type in --workshop manual for horton fan clutch ( model)---and see if there is a pdf version for down load

Posted on Apr 19, 2016

Ad

5 Related Answers

Anonymous

  • 64 Answers

SOURCE: 2003 Saturn Vue electric fan always running

Check the fan relay, probably in fuse box in the engine compartment. Check owners manual to be sure. I have seen these melt causing fan to run all the time.

Posted on Feb 18, 2009

Ad
dr_greg

greg arizmendez

  • 192 Answers

SOURCE: right condenser fan doesn't work

that fan comes on when the a/c is on...replace the a/c condensor fan relay if the fan isnt working..but first.make sure there isnt any burnt wires and the fuse is good as well

Posted on Apr 07, 2009

cj2176

Chris Jones

  • 520 Answers

SOURCE: 2000 ford f250 ac not cooling at idle cools good

What this sounds like is an under charged unit. If you just had the work done then there is a posibility that they under charged it or it has developed a leak. That is posible. Hope this helps and good luck.

Posted on May 07, 2009

genisis98

  • 31 Answers

SOURCE: A/C blowing hot air on driver's side

You have a faulty switch. Go to the salvage yard and buy a used one, pull off the trim panel and replace it. I just did one of these last week with the same symptoms.

Posted on Oct 24, 2009

steve pierce

  • 105 Answers

SOURCE: 1986 chevy S10 has no power (12v) at fuse box on

hello, check all fuses, and relays, make sure wires to ac is not broke or has been pinched, sometimes you can run hot wire from battery, to compressor, touch hot side of plug in on comp wire see if it will kick on, if so sounds like a short, if compressor dont kick on with hot wire run to it, tap the out side of comp clutch and see if it kicks on, these compressors will not kick on any way if they are low on freon, once freon is full it should work.

Posted on Apr 08, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1990 Mack dump truck 6 cylinder jake brake works driving but shuts down moter when clutch is pushed in.So l shut switch off till l start going again,turn it on,works fine till l need to stop again?


check for a wiring short circuit or broken from the clutch switch to the brake wires
take it to a service dealer or auto electrician for diagnosis
remember there are slight differences between Jacob brakes and the Mack dyna brakes

Jun 14, 2018 | Cars & Trucks

1 Answer

07 sportage. Ac clutch goes off after 5mins


Woody have refrigerant level checked may be low. have a good shop recharge A/C system if checked and found low. Check the attached links,instruction and guides, Good luck
"I hope this helped you out, if so let me know by pressing the helpful button. Check out some of my other posts if you need more tips and info."
FIXED Car Compressor Clutch Won Engage
The Trainer 40 When the compressor won compress
Diagnosing AC Compressor Clutch Problems

Jun 30, 2016 | AC Cars & Trucks

1 Answer

Just had a new p.t.o to a 07 mack vison it wont lift the tipper so i fitted a dummy hose the p.t.o engages and does pump but very slowly im talking like under 20litres a minute?


if you have a mack tri shaft box then check that the pto pump has been fitted to the correct hole. Some pto pumps run directly onto the counter shaft and others use an adaptor to increase the pump rpms or run from a larger gear in the box that runs the pump at higher rpms. . I suspect that the installation of the pump is incorrect and not in accordance with the fitting instructions for the pump.
Pto pumps fitted to road ranger box can be either on the side or underneath and each position connects with a different gear to drive it.

Feb 26, 2015 | Cars & Trucks

2 Answers

I have a 2002 Hyundai accent . The car was dead so I got a new battery the car started then would not start again after I shut it off so I bought a new starter it cranked up and now she won't crank...


other possible causes if battery and starter and starter solenoid been replaced.battery cables could be bad causing poor ground.if you have manual transmission could have faulty clutch pedal safety switch and automatic transmission could have faulty neutral safety switch.and could have fault in the theft security system.

Jun 11, 2013 | Cars & Trucks

1 Answer

Is there any fan grounds


Yes, they would all be grounded. May be hard to find them because the electrical connector at the fan has the ground wire going back into the harness. The ground should be on the engine somewhere. Check the ground by using a voltmeter right there at the electrical connector for the fans. Figure out which wire is the ground, put positive lead of voltmeter on the positive battery post, and the voltmeter's negative lead into the ground wire terminal on the connector's harness side. If that ground is good, the voltmeter will register battery voltage. If the ground is bad, the voltmeter won't register.

Nov 14, 2012 | 1992 Ford Mustang

1 Answer

1993 nissan pick up won't start


Possibly a bad connection on the positive side coming from the battery or a weak ground. Check where the leads join the terminal clamps. Has the battery been verified as good? It doesn't take a lot of amps to run lights but it does to turn over the engine. Jump starting it does not require a fully charged battery.

May 01, 2017 | 1993 Nissan Pickup

3 Answers

The heater/ac fan only works on speed settings 4 & 5


you might check your switch sounds like to me that your two lower speed sides of the switch maybe burnwed out.

Dec 19, 2009 | 2002 Chevrolet TrailBlazer

1 Answer

'03 VW Jetta a/c not cooling - it's HOT in Texas!!!


Check for power and ground to left (large) radiator fan with test light. If power and ground to connector are ok, replace faulty fan.

Mar 11, 2017 | 2003 Volkswagen Jetta TDI

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

624 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

Marvin
Marvin

Level 3 Expert

85239 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22485 Answers

john h

Level 3 Expert

23424 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...