Question about 2001 Chrysler PT Cruiser

2 Answers

My pt cruiser has code 1391. i changed cam sensor crank sensor wires plugs and coil still getting 1391 code and from 0 mph to 20 mph car skips and revs up any ideas?

Pt cruiser has code 1391. i have changed crank sensor cam sensor plugs wires and coil. still getting code 1391. from 0 mph to 20 mph or at cruising speed the motor skips and revs up any ideas on why?

Posted by Stanley Price on

Ad

2 Answers

andrew

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    New Friend:

    An expert that has 1 follower.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 102 Answers

Check wiring harness going to the two sensors

Posted on Apr 05, 2015

Ad

Randy Ohler

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Chrysler Master
  • 14,585 Answers

The cam and crank sensors have the same power wire. Go after that one. They also have the same ground, but other sensors connect to it also. So it's not the ground. And they have separate return signal wires. Not them either.

Posted on Apr 05, 2015

Ad

5 Related Answers

emissionwiz

Marvin

  • 85223 Answers

SOURCE: 2000 PT CRUISER

How about the MAF sensor?

Posted on Nov 23, 2008

Anonymous

  • 9 Answers

SOURCE: My 2003 pt cruiser won't turn over.

could be ignition relays, starter solenoid...

Posted on Apr 27, 2009

Anonymous

  • 94 Answers

SOURCE: 02 PT Cruiser LE w' Code P0340

My thought is to get a refund from the shop that tried to replace parts in order to secure your problem. The job of the shop is to diagnose the problem, not to replace items that may be the problem. Chrysler Master Techs are not trained to just replace parts, they fix the problem by diagnosing it properly.

You need to see a Chrysler dealership so they can attach a DRBIII and tell you exactly what is at stake.

I hope this helps you. I would be mad as heck.

I would not think the plugs and wires would be the problem because they would all have to fail at the same time to provide the symptom you experienced.

1. Get your money back
2. DRBIII

Posted on Jul 11, 2009

chris brown

  • 99 Answers

SOURCE: 2002 PT Cruiser no spark at coil -had code P0340

they can run with out a cam sensor but they will not run with out crank signal i would check for crank signal it may not throw a dtc because it wont start.

Posted on Dec 15, 2010

hotrodshop

Brian Franklin

  • 106 Answers

SOURCE: location speed sensor pt cruiser 03 touring car do

It sounds like the module is in limp mode. The speed sensor is most likely the cause, but it can be some other things as well. A scan will give a code stating the problem area.

The speed sensors are on the side of the trasmission that faces the front of the vehicle. There are 2 of them, and they are the same sensor. One is an input speed sensor located closest to the engine, the other is the output speed sensor.


hotrodshop_0.png

Posted on Jun 17, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Where is the fuel reset button located on a 2002 pt cruise Chrysler


There is no fuel reset button. What kind of testing have you done? Engine cranking, did you check for spark at the spark plugs? Is there a fuel injector pulse? Any applicable trouble codes?
If your missing everything, I'd check the cam and crank sensors.
If you have narrowed it down to only the fuel system, we can go that way.

Apr 06, 2017 | 2002 Chrysler PT Cruiser

1 Answer

Replased head on 04 pt cruiser cranks but wont start


Make sure your cam and crank timing is correct, might have changed when you had the head off.

Feb 24, 2016 | 2004 Chrysler PT Cruiser

1 Answer

2002 PT Cruiser no spark at coil -had code P0340 changed cam sensor and no more code but still no spark what else can it be


they can run with out a cam sensor but they will not run with out crank signal i would check for crank signal it may not throw a dtc because it wont start.

Dec 15, 2010 | 2002 Chrysler PT Cruiser

2 Answers

My pt cruiser just quit driving down the road one day put it on computer said coil pack was bad changed it still wouldnt start hooked back up to computer said cam sensor was bad changed it still wouldnt...


On this type of vehicles' "Diamler-Chrysler" for some reason the Crank and Cam sensor go bad at the same time but it will still tell you its either one or the other, if you are still getting the Cam sensor trouble code, try replacing the Crank Shaft Position Sensor, I just had a Dodge vehicle with the same problem but in reverse, it kept saying Crank Sensor but it turned out it was the Cam Sensor. Good Luck.

Sep 10, 2010 | 2002 Chrysler PT Cruiser

1 Answer

2003 PT Cruiser


Crank sensor controls fuel not sprark. Check the cam sensor, this sensor is usually on the head of the engine. Check for this sensor on the top left or right sides of the engine (it depends if turbo/none turbo). Another issue that may cause no spark is failed ignition coil. The ignition coil is on top of the engine, with 4 wires routing to the spark plugs. Hopefully this helps!!

May 07, 2010 | 2003 Chrysler PT Cruiser

1 Answer

02 PT Cruiser LE w' Code P0340


My thought is to get a refund from the shop that tried to replace parts in order to secure your problem. The job of the shop is to diagnose the problem, not to replace items that may be the problem. Chrysler Master Techs are not trained to just replace parts, they fix the problem by diagnosing it properly.

You need to see a Chrysler dealership so they can attach a DRBIII and tell you exactly what is at stake.

I hope this helps you. I would be mad as heck.

I would not think the plugs and wires would be the problem because they would all have to fail at the same time to provide the symptom you experienced.

1. Get your money back
2. DRBIII

Jul 11, 2009 | 2002 Chrysler PT Cruiser

3 Answers

Spit and sputter/2004 PT Cruiser


Check for fire to the coil pack. These have a tendency to go bad on these cars. Could be a cam or crank sensor, these also go bad. If you haven't changed the plugs in 30K, this is due also, wires every 60K. May need to actually get it hooked to a machine to find out for sure.

Jun 02, 2009 | 2004 Chrysler PT Cruiser

2 Answers

2003 pt cruiser sensors


check the battery and make sure it has a fully charge,also check to make sure the start motor pinion is not jammed in the flywheel, and check the coil pack to make sure have spark.also check the crank sensor

Feb 14, 2009 | 2003 Chrysler PT Cruiser

Not finding what you are looking for?
2001 Chrysler PT Cruiser Logo

315 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chrysler Experts

Marvin
Marvin

Level 3 Expert

85223 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22485 Answers

Jonah Oneal

Level 3 Expert

14092 Answers

Are you a Chrysler Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...