Question about 1989 Lotus Esprit

1 Answer

What would cause burning smell by oxygen sensor and runs rougn and dies. 1990 lotus esperit

Posted by Michael Brescia on

Ad

1 Answer

badco001

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that got 5 achievements.

    New Friend:

    An expert that has 1 follower.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Contributor
  • 29 Answers

Possibly a rich fuel mixture

Posted on Apr 24, 2014

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

4 Answers

What would cause 93 chevy c1500 rough idle smells of excess gas at exhaust


Does the truck seem fine when you first start it & then acts up when it reaches operating temp?
That would lead me to look at my oxygen sensor, a bad sensor can cause the truck to run "rich" which would explain the fuel smell in the exhaust.

Jun 28, 2014 | 1993 Chevrolet K1500

1 Answer

Have 96 mustang 4.6 runs great until it gets to operating temp than it kicks miss fires and dies


Without seeing the vehicle and not seeing a datastream,i would suspect catalytic convertor damage causing restricted exhaust gases or shorted oxygen sensor. Most of the time a shorted oxygen sensor will set an engine code. Catalyst restriction is much harder to diagnose ,but will cause inert exhaust gases to back up into the intake manifold. Inert gases do not contain enough oxygen for complete combustion.

Mar 25, 2012 | Cars & Trucks

2 Answers

My 1990 Dodge Dakota runs strong but dies every time I slow down??? Any suggestions? I have replaced the throttle body and two injectors. All belts, hoses, filters and most sensors have been replaced. ...


1990_dakota_695308.jpg Your question about 1990 Dakota has been posted.

90 dodge dekota 2w v6 Runs rough on acceleration but smooth while maintaining speed dies when i come to a stop

  • Latest Activity:
  • Your question was escalated to Level 2 after 3 hours - 146 days ago
  • Your question was escalated to Level 3 after 12 hours - 146 days ago
  • Your question received a new solution from randylaney20 - 89 days ago
  • Your vacuum ports on throttle body is gunk up and...

Aug 28, 2011 | 1990 Dodge Dakota

2 Answers

Smells like ammonia while driving bad idle


Catalytic is plugged or O2 Sensor quit.

Feb 07, 2011 | 1990 Honda Accord

1 Answer

I have a 1990 Mercury Marquis, the fuel is running really rich. The car will only idle for a minute, then dies. It will run if you keep your foot on the gas, as soon as you let off the gas, it cuts out and...


there are two things you need to check out 1. is the check engine light on... if so its most likely an oxygen sensor that has gone bad, the oxygen sensor tells the vehicle the air/fuel ratio to use to make the vehicle efficient on fuel.. thus if its bad the vehicle will either run extremely rich, or way too lean.. and the secont thing to check out is your fuel pressure regulator, if its stuck it will allow the fuel to flow endlessly...hope this helps

Dec 14, 2010 | 1990 Mercury Grand Marquis

1 Answer

Black smoke comes from exhuast when engine gets hot


black smoke is raw gas burning. a rich condition could be the cause---a bad oxygen sensor, a bad map sensor, a bad fuel pressure regulator, a plugged up air filter, or bad injector. if it was a oil problem then you can smell it. when after running til hot. shut off engine and rub finger around inside of tailpipe to tell! have a good one!!

Nov 15, 2010 | 1998 Volkswagen Passat

1 Answer

Code 51 on a Plymouth sun dance. How do I fix it?


Code 51 = Oxygen sensor stuck in lean mixture mode. ( this will often cause engine to run rich due to oxygen sensor telling engine controller that it is running lean, thus send more fuel) This may be caused by M.A.P. sensor as well, so check vacuum lines and clean connections on MAP sensor first. It should be one of 2 things, Fault from MAP sensor, or faulty oxygen sensor.

Nov 01, 2010 | 1990 Plymouth Sundance

1 Answer

Had work done on my car (36K miles on the car): oil change, new plugs, new plug wires, new dist cap, new dist rotor, fuel filter, pvc valve, and brake work. Now it runs like ****. rough running and exhaust...


Sounds like a fuel mix problem possibly the oxygen sensor. If it ran like this immediately after the new plugs, I would check to make sure all the plug wires are on the right plugs and secure. Good luck!

Mar 10, 2010 | 1990 Nissan Maxima

1 Answer

Vehicle sputters, bucks, occasionally dies out, rich exhaust fume


The MAF sensor is the likely problem. Ca be clraned w/crc electrical cleaner only. Do not touch , rub,or use compressed air to clean or dry. It's located in the intake duct in one of the metal sections. The plug and wires will give it away. Good Luck-Ned-

Sep 18, 2009 | 1998 Ford Explorer

1 Answer

2001 mazda 626 es v6 oxygen sensor flamed up and caught fire


sulfur smell is excess fuel getting burned in the cat. convertor.

The o2 sensor itself may be bad... causing the ECM to get bad readings and send extra fuel that isnt burned during ignition.

Check the engine codes with an OBD reader, (even if the CEL is not lit) because the bulb may be out or missing.

If you get codes, ask the parts store or re-post here, and I can help you further.

Thanks for using FixYa - A FixYa rating is appreciated for this freebie question.

Feb 25, 2009 | 2001 Mazda 626

Not finding what you are looking for?
1989 Lotus Esprit Logo

Related Topics:

84 people viewed this question

Ask a Question

Usually answered in minutes!

Top Lotus Experts

Marvin
Marvin

Level 3 Expert

85239 Answers

Vincent G
Vincent G

Level 3 Expert

2363 Answers

john h

Level 3 Expert

23504 Answers

Are you a Lotus Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...