Question about 2003 Mitsubishi Eclipse Spyder GT

1 Answer

TCL, anti-lock, battery, brake lights flashing on dash, engine sputtering

I've been driving the car for a while and it's been doing fine. I've checked all the fluids and everything is topped off. But when I turn on the heat, headlights, and if I lower the top the brake and battery indicators on the dash start to flash. Normally I just let the car run and they stop eventually so I assumed it was when the battery was low and it was pulling too much power. But today when the car was on the road if the rpm's ran low the brake, battery, TCL, and Anti-Lock indicators all flashed and the engine was slightly sputtering. Before when it was idle there was a single sputter every few seconds. But it was happening today every time the rpm's got too low and when the car was idling. Any advice?

Posted by Jared Stephens on

Ad

1 Answer

Ruben Diaz

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Master
  • 514 Answers

You have problems with your idler control valve

Posted on Jan 29, 2014

  • Jared Stephens
    Jared Stephens Jan 29, 2014

    Thank you! The tubing was melted through for both the intake and outtake into the valve. Unfortunately, the brake, TCL, battery, and anti-lock lights are still on

×

Ad

2 Related Answers

Anonymous

  • 23 Answers

SOURCE: when i switch on the A\C it works for seconds then

I would suggest you call a company trained on these, make sure the tech is Nate certified, I have worked on these and they are not fun to work on and are not something i would suggest you take on unless your performing maintenance related activity. it seems to be throwing a code or powering down by your description.

Posted on Oct 02, 2010

Ad

irad

  • 161 Answers

SOURCE: Low MPH/RPM issue

Autozone will read the computer codes for free. Many other auto parts place also provide this service. You need to know the car's OBD codes to start fixing the problem.

Posted on Jan 02, 2014

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Heating stopped working


Is your radiator fluid up where it should be? Low fluid will do this.

Nov 30, 2014 | Dodge Challenger Cars & Trucks

2 Answers

My 95 Corsica Temp gauge keeps heading hard for the hot zone, between 3/4 and over heat, then dropping back to 1/4 totally at random. Fan definitely goes on. Topped off all fluids, changed oil and fil


You need to bleed it. Leave the radiator cap off, start it up and when the thermostat opens it should push out bubbles out through the radiator, if the water level drops in the raditor then top it up. When you can't see any more air bubbles, close the radiator cap.
If this doesn't help then it could be the thermostat.

Sep 25, 2014 | 1995 Chevrolet Corsica

1 Answer

I've been driving the car for a while and it's been doing fine. I've checked all the fluids and everything is topped off. But when I turn on the heat, headlights, and if I lower the top the brake and


Maybe. The battery light means the alternator is not charging the battery. Its possible the computer is disabling the alternator when the light is on. Of course it could be a problem with the brake fluid or parking brake but I assume you have checked those already.

Feb 10, 2014 | 2003 Mitsubishi Eclipse Spyder

1 Answer

Heated seats do not work on my 2006 silverado 3500. I've tried everything. ANY HELP OUT THERE?


check your connections at the seat for a signal then go into your relays-fuses breakers ect.

Sep 18, 2012 | Cars & Trucks

1 Answer

Speedometer reset while driving


Sounds like your speed sensor is failing and will need to be replaced.

Jan 22, 2018 | 1989 Cadillac Seville

1 Answer

Will not engage in reverse


Check the fluid level and condition.
If fluids low, top off.
if fluid is okay, then try the cheapest fix, changing the fliud and filter.
Last week, buddy of mine had the same problem. We racked out brains, checked everything. We tried changing his fluid (ATF) and it was like syrup. Truck works fine now.

Before the fluid change though, check all linkages to the transmission. Maybe something isn't right there. It wouldn't make total sense, due to it having to go through reverse to get to drive anyways, but it wouldn't hurt to look!

Hope this helps.

Jan 10, 2011 | 1998 Ford Explorer

1 Answer

Heating and over heating


if you smelled rad fluid then chances are you have a leak, you didnt say if you had to top it up at all, low fluid level will cause loss of heat, and the overheat prob sounds like thermastat replacement time, i would start with the thermastat

Mar 30, 2009 | 2003 Oldsmobile Alero

1 Answer

Honda accord 1996 starts, wont run


you blew your tranny from over heating it just because you have fluid doesnt meen that everything is fine your filter could have cloged not allowing proper fluid to the gears

Sep 29, 2008 | 1998 Honda Accord

Not finding what you are looking for?
2003 Mitsubishi Eclipse Spyder GT Logo

641 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

Marvin
Marvin

Level 3 Expert

85239 Answers

Thomas Perkins
Thomas Perkins

Level 3 Expert

14866 Answers

Vincent G
Vincent G

Level 3 Expert

2363 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...