Question about 1999 Jaguar XK8

1 Answer

Lambda problems Hi we have changed two times new lambda sensors. but not genuige parts, Ewery times chek engine light bigins to burn. The combuter said same things every time. cable fault and something about the heating. what i must do?

Posted by kari vartiainen on

Ad

1 Answer

Marvin

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Jaguar Master
  • 85,239 Answers

I need all the information to help, the codes received on the testing to start.

Posted on Jun 12, 2013

Ad

2 Related Answers

Anonymous

  • 1 Answer

SOURCE: Jaguar x type 2004 2.5 petrol V6, 38500 miles, codes P0171, P0174

Have exactly the same issue on 04 jag x type 2.5. So far have replaced fuel filter, air filter k&n, plugs ngk. Codes cleared, same issue. Seems to appear when air temp is cold and eng is warm.
Am replacing upstream O2 sensors and cleaning MAF next. Will keep you posted if it clears up. Did you ever find the cause?

Posted on Mar 07, 2010

Ad
raygin

Raygin

  • 322 Answers

SOURCE: s type gearbox fault light keeps coming up on the

There is no gearbox dipstick fitted to this model car. it is the ford 5n box that is ''sealed for life'' If the box is still operating okay the fault may lie in another system and its symptoms could cause a gearbox warning. The best thing would to get the codes read and see what ''pending codes'' are stored along with the current meaning of the gearbox code registered in the system. A jaguar main dealer or specialist will have the equipment to access and read the stored history. hope this helps - good luck.

Posted on Jul 22, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Car battery light keeps coming on when I come to a stop.. I've recently changed the front lambda sensor as the engine management light came on and it brought up that fault


HI,
Plz provide Year+Make+Model of vehicle.

Battery light points to battery or other electrical system malfunction such as the Alternator.

Many Auto Parts stores can test your battery and alternator for free.

GL,
Td

Oct 23, 2015 | Cars & Trucks

1 Answer

I would like to know if both Lambda sensors are the same part number on a 1.0i Vauxhall corsa. 2004 register.


Each sensor is looking for different things so the answer is most likely NO.

Jan 02, 2018 | Cars & Trucks

1 Answer

My 2003 Terios has failed on high emissions.


First thing I would do is this... Get a can of SEA FOAM and add it to your Fuel. Then drive 100 Miles and have it retested. 90% sure it will pass after cleaning the system.

Feb 12, 2014 | Daihatsu Cars & Trucks

1 Answer

Lambda sensor


this is a common prob what was the fault code logged ?there are 4 sensors on these cars 2 on each bank upstream and downsteam the issue is the ecm tries to compensate for one bank that is out of limits using the fuel control of the other bank to try and keep overall emissions within limits.this makes diagnosis difficult without proper diagnostic equip.at the last count genuine jag. sensors are EXPENSIVE and cheap pattern ones are not that good.advise. find someone with jag diagnostic equip. identify the problem

Jun 01, 2013 | Jaguar XK8 Cars & Trucks

1 Answer

I have a problem with a Fiat Strada 1,2 -02 ewery time I start the engin it starts directly and runs for a short while and than it stops after that I have to try and crank the engisn 4-5 times befor it...


have had this before and it was due to teh engine immobilisor which is built into the ECU ,had to find a scrap car and then changed the whole lot ,computer transponder and chip in key to match the donor vehicle and it run perfect for about a year ,till owner done the no no of all bad driving and drunk and drove and wrecked the car after all the work i done

Aug 26, 2011 | Fiat Strada Cars & Trucks

1 Answer

I have the check engine light on, the engine will start and run at idle when the rpm's are incresed it sound like it has a bit of a miss at about 4000rpm and when throttle is let off the engine stalls...


Probably the fuel filter or pipe is partly blocked. When it runs at idle it has inough fuel. When you push the pedal it cant suply inough fuel and the engine sucks the fuel sistem dry, thats why it is so hard to restart the engine. Ewery time, when you turn on the egnition, the fuel pump in the tank is working only for three or more seconds. Because of blocked fuel pipe, or filter, it takes more time to pump up the fuel in the sistem. Chek the fuel filter and blow the fuel pipe.

Jan 01, 2011 | 1986 Saab 9000

1 Answer

Hi Audi A4 1.8 T sport, X reg failed mot on high emissions Front Lambda replaced, and readings still high (running rich) any ideas please


hi this could be a few things but more than likely it is either the MAF sensor or MAP sensor, these things do roughly the same thing, but the MAP also adjusts the timing through the ECM , either one would cause this to "over fuel" and not burn correctly, the starting place would be try the MAF first as this is the common one, make sure spark plugs have been changed as this also will help, if you still get a fail, then try the MAP sensor...hope this helps good luck..

Sep 17, 2010 | 2000 Audi A4

2 Answers

Engine warning light says lean bank 1 low.


generally aftermarket parts are made from the original toyota models so it is doubtful that is the problem. There may be a short in the wires that are causing the sensor to burn out. I would suggest first taking to your local auto parts store and have them scan the ECU for the problem. I hope this helps. Please rate this Thank you

Mar 01, 2010 | 2007 Toyota Yaris

1 Answer

I have a 1997 1.6 carina e. the engine light is on and the computer says it is the lambda sensor. can i get some advice on how to change the sensor and is it worthwhile to get a used one new one is too...


Use aftermarket, it's new. I work at Bosch and make these sensors. It's best to buy new. And they are easily changed with a 22mm wrench. It's a simple unplug the harness from the lambda sensor, and grasp the hex the 22mm and turn left. Get your new one and it will give you better understanding as you change out the old. Very easy and you will be glad you done this.

Feb 13, 2010 | 1997 Toyota Corolla

Not finding what you are looking for?
1999 Jaguar XK8 Logo

111 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jaguar Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22485 Answers

Marvin
Marvin

Level 3 Expert

85239 Answers

gerry bissi

Level 3 Expert

4388 Answers

Are you a Jaguar Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...