Question about 2004 Chevrolet TrailBlazer

1 Answer

2004 Chevy Trailblazer - instrument panel works fine except the digital odometer reading went out and does not display anything?

The digital instrument panel was working fine and i went to start it the other day and everything is fine except where the mileage and mi. per gal showed does not light up. Changed the fuse but still doesn't light up.

Posted by Michael Dorr on

Ad

1 Answer

Freddy

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Chevrolet Master
  • 1,311 Answers

You will have to have the cluster repaired. If you are handy, you can take the cluster out yourself. There a number of vendors on Ebay who repair clusters.

Posted on Sep 09, 2012

Ad

5 Related Answers

Anonymous

  • 1 Answer

SOURCE: 2003 Chevy 2500HD Dash Gauges not working

In my case, simply removing and reseating the IPC/DIC fuse restored the gauges to full functionality.

Posted on Dec 31, 2008

Ad
emissionwiz

Marvin

  • 85239 Answers

SOURCE: no instrument panel lights on a 2003 chevy monte carlo

Most likely this is caused by either the dimmer being turned off (happens all the time on my Corvette) or the dimmer is defective.

Posted on Nov 30, 2008

josh markham

  • 1 Answer

SOURCE: 2004 Chevy Trailblazer radio and CD player works, but no sound

if you have installed a new cd player in there then the propblem could be that your speaker wires and either touching each other or grounding them selfs out.. pull of the cd player and check to make sure all the speaker wires are covered properly and no bare wires are exposed.. if you still have a factory cd player in it then you will probably need to take it to a dealership to have it checked out..

Posted on Feb 23, 2009

Anonymous

  • 1 Answer

SOURCE: headlights wont come on, but parking lights work...i dont get it

Was sent in by another poster, just posting his results which fixed mine. Problem was relay $50.00 at GM only.

Check the relay module. 45 or 46. on the engine relay block. you can swap the two they are the same part number, then you will know. Dont start the engine, just check the lights. If it works replace the relay module. You may have to order the part from the parts store. Or go to the dealer to get it.

Posted on Mar 25, 2009

Anonymous

  • 1 Answer

SOURCE: instrument panel cluster gauges and odometer has stopped working

I had all my analog instrument panel gauges stop working after they did the state emissions test. I found the proper fuse in the fuse block located under the hood. Simply unplugged the fuse, noticed it was still good, and plugged the same fuse (10A) back in and all the gauges started working again. Guess it needed a reset atfer they plugged in for the emissions.

Posted on Aug 14, 2009

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

My speedometer works but my digital odometer does not work on my 2003 old alero


This is one guy's advice: Replace the speedo head, that should take care of the problem."

This site is also interesting because the guy said
General Motors cars had instrument cluster problems from 2003 through 2006. When I researched instrument cluster problems on the Internet what I found raised concerns in me. Many of those vehicles had problems that began with the instrument cluster, but eventually led to the engine refusing to start.
(an electronic instrument cluster, digital instrument panel or digital dash for short, is a set of instrumentation, including the speedometer, that is displayed with a digital readout rather than with the traditional analog gauges. Many refer to it simply as a digital speedometer.)

http://www.instructables.com/id/Erratic-Instrument-Panel-on-GM-Cars/

Feb 12, 2017 | 2003 Oldsmobile Alero

1 Answer

Will a new carbuator on a 1985 F-150 really improve my mileage


It is against federal regulations to remove anything at all,
from any vehicle.

Doing so, may hurt more than help, unless you
understand the technology your removing

A new carb is not the answer

Rebuilding yours yourself ,may make it start & run smoother,
but every day all vehicles wear & get less mileage,even brand
new ones.

All ford trucks from 1960 to this day have gotten 13 mpg at most

Oct 04, 2012 | 1985 Ford F150

1 Answer

Instrument panel guages work one day the not the next, whats the problem?


It's tach, not tack, short for tachometer. Were these gauges installed by unionized people? It could have been the gauges' day off, as per their collective agreement.
Most instrument panel woes are caused by bad grounds. Most panels are below the front glass, and if this leaks, guess where the water goes? Dashboard problems are a bear to fix sometimes, and costly in terms of labor. Have someone steal the car.

Jun 21, 2012 | 2005 Chevrolet Monte Carlo

1 Answer

Went from 20 to 12 mi per gal in two weeks changed o2 valve and cleaned egr valve .


I had the same problem with my S-10 and it threw a code intermittently. There were
two problems, a cracked seal on the gas cap and an intermittent heater problem
with the mass air flow sensor. The truck ran but got terrible gas mileage with
the mass air flow sensor problem. You might be able to have the codes checked
at an autozone or other parts store that offers this service free. Also check the
coolant level at the radiator and not just the return tank, mine had become disconnected due to age and allowed coolant to escape the radiator and not
return to the block but appeared full because the line had fallen behind the battery.

Apr 11, 2011 | Chevrolet Tracker Cars & Trucks

1 Answer

Location of oxygen sensors on 2002 dodge grand caravan with 3.3 liter engine after considerable maintance work done by a dodge dealer my gas mileage dropped by as much as 6 to 8 miles per gal. after a time...


The o2 sensors are located on the exhaust system.The upstream in on the rear exhaust manifold and the down stream is in front of the catalytic converter.Usually when they are bad they will make the check engine like go on.Make sure the air filter is clean,tires at correct inflation,alignment is to specs.If the vehicles pulls to one side or the other or steering wheel is not straight when driving down a straight stretch of road.Also tires are wearing normal.Use cruise control where ever on highway.If you let your vehicle warm up in winter.This also uses gas.Hope this helps.Good luck.

Dec 23, 2009 | 2002 Dodge Grand Caravan

4 Answers

Instrument panel went dead


Checked Every fuse in the fuse box (no small task).This includes #4 - Power point Instrument Panel, #14 - Day time running lamps (auto lamps doesn't work nor does auto lock), #27 - ignition switch run feed, #35 - Instrument Cluster, #41 - Instrument Cluster, #42 - Delayed Accessory, #45 - Ignition switch run/start feed, #102 - Door locks body security module, #103 - Ignition switch, #110 - Ignition switch, & #116 - Ignition switch. But I also check all other ones as well, they all register OK. AC panel & radio work. Turn signals work. Mileage does not work, trip computer does. So, basically, everything works except auto head-lights, auto locks, and the dash cluster (no MPH, RPM, mileage display, Fuel, Temp, Tran Temp, and Oil Pressure).

Aug 19, 2009 | 2003 Ford Excursion

Not finding what you are looking for?
2004 Chevrolet TrailBlazer Logo

931 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

Marvin
Marvin

Level 3 Expert

85239 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8984 Answers

john h

Level 3 Expert

23504 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...