Question about 2007 Nissan Xterra Off Road

Open Question

'07 xterra had low to no power when accelerating from 40-60 mph

Posted by Shelly on

Ad

Add Your Answer

×

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2002 Ford Taurus LX Very low power and acceleration and will die after short distance. Will rev up to 4000rpm when in park.


possibly the crank shaft sensor. i had to help a family member with a change on a xterra with same issues and it fixed problem. but a mechanic will be the best one to ask

Oct 13, 2014 | Cars & Trucks

1 Answer

I have a 2002 Nissan Xterra and it dies when the bake is applied. Also as the accelerator is pressed, the car hesitates before moving forward.


I had the same problem so I dismantled my engine and found out both my heads were cracked allowing fluid to enter the combustion chamber therefore foreign fluids were gumming up my pistons causing me to lose power up hills and so forth. If you are a good mechanic replace your heads and your problem will be solved.

Feb 15, 2014 | 2002 Nissan Xterra

1 Answer

My cirrus 99 is knocking when at a certain speeds 40,60 mph, when about to stop ?


problem is electronic but exactly what i have no idea without my head under the bonnet ,try the dealer as it may be cheaper in the long run

Jun 13, 2012 | 1999 Chrysler Cirrus

1 Answer

I own a 2002 Xterra and whn i am driving and go


check the u joints in the front drive shaft

Mar 28, 2010 | 2002 Nissan Xterra

1 Answer

Shaking at low speed (25-30 mph)


low speed shakes indicates a wheel alignment problem
have the suspension and wheel bearings checked out by an accredited suspension shop
under acceleration it could be engine mounts cracked in the rubber being actuated by misfiring form a cylinder
run the fault codes as well

Aug 31, 2017 | 2003 Honda Odyssey

1 Answer

Transmission knocks at 20-30 mph and 40 mph, like it can't shift.


Well if you would elaborate some more on what kind of car you have,...that would be helpful as my ESP is very low today....

Dec 11, 2017 | 2004 Mercury Mountaineer

1 Answer

Ford Focus Engine problem


have you tried having your fuel injectors cleaned on it. the engine might not be getting enough gas at take off. it might also be that your gas tank fuel pump or the other fuel pump going bad

Dec 20, 2008 | 2002 Ford SVT Focus

2 Answers

2005 xterra


had the same problem it was the u joints....if you get a vibration at higher speeds that will also be an indicater...on the 2005 exterras you have to replace the whole drive cshaft fortunatly min was under drive train warranty.

May 29, 2008 | 2005 Nissan Xterra

Not finding what you are looking for?
2007 Nissan Xterra Off Road Logo

Related Topics:

89 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

Marvin
Marvin

Level 3 Expert

85239 Answers

Thomas Perkins
Thomas Perkins

Level 3 Expert

14852 Answers

Vincent G
Vincent G

Level 3 Expert

2363 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...