20 Most Recent 1993 Mercury Topaz Questions & Answers


left of the steering wheel and underneath your dashboard.

1993 Mercury... | Answered on Apr 14, 2019


Hey Mr. T.,
Get a tube of this... cut a small piece off the tip..(you WILL need a caulking gun to get this out of the tube).. and maybe a friend to help pry the seal around the windshield up so you can squirt this sealer COMPLETELY .. and liberally ...around the windshield...let the seal down gently.. and let it dry.. this should seal it!! (let it DRY BEFORE wiping the excess).. https://www.oreillyauto.com/detail/transtar-autobody-technologies-body-tec-5109/chemicals---fluids-16461/glues--adhesives---sealants-19861/windshield-window-repair-17686/adhesive/4502/4749716

1993 Mercury... | Answered on Sep 23, 2017


it is possible that the vacuum line for the transmission actuator was damaged during the head job
check for wiring harness connections not properly put back together

1993 Mercury... | Answered on Mar 22, 2017


I would clean the throttle body first and the idle air control motor(IAC). Clean where the plate sits and on the back of it/them. You have to remove the IAC to clean it. Brake clean and a toothbrush works fine. If it still is high. Diagnostics need done for the IAC. Most times it is the IAC.

1993 Mercury... | Answered on Dec 03, 2016


Two things I can think of. The coil is bad. They can do this from heat. They are good cold, but the heat opens a circuit and it dies. Next would be catalytic converter. It is clogged up. Check the converter first. Remove the pre O2 sensor. If it keeps going after ten minutes, This is your problem. If it dies check spark while still hot. No spark, coil. Just a note, you could still have converter problems.

1993 Mercury... | Answered on Mar 30, 2016


 It's under the steering wheel, left of the steering column. You gotta climb under the dash to see it, and look up.

1993 Mercury... | Answered on Dec 12, 2015


I don't think your car has one. But it has been a long time since I worked on one of these. I think you have a fuse and a master switch. Fuse good, switch is bad. If there is a relay( they rarely go bad), it will be under the dash. One of those 4 or 5 relays on the top. Owners manual will tell you. But my guess is, you don't have it. And I don't have the program for your car. Swap them around.

1993 Mercury... | Answered on Aug 30, 2015


turn ac off an check for vacuum leak

1993 Mercury... | Answered on Aug 17, 2015


Replace light switch assembly. Remenber some switches pull up to flash headlights and press down to change from low to high--press down again goes from high to low.

1993 Mercury... | Answered on Aug 17, 2015


The oil pump is inside the oil pan on the bottom of the engine on most models. I doubt it would have anything to do with a burning smell.

1993 Mercury... | Answered on Mar 05, 2015


must be a bad wire if you put a new battery and alternator in it. Are you sure the battery and alternator are good. One way to test the alternator is to run the engine and disconnect the battery [one post] while the car is running. If the car keeps running, the alternator is good. If engine cuts out and shuts off, alternator is bad

1993 Mercury... | Answered on Aug 16, 2014


The circuit that powers the fuel pump, ignition etc may have a bad connection in the wiring harness where the plugs come together. When extra electrical loads are being fed current through the plug connection there is voltage loss at the plug joint. Thy unplugging the multipoint connector where the wiring harnesses join together around the fusible links etc. You will be able to recognize the culprit by its discoloration due to overheating in the plug. Replacing connector pins and plug clips should take care of it.

1993 Mercury... | Answered on Jul 31, 2014


What engine is in the topaz?

1993 Mercury... | Answered on Jul 20, 2014


Power comes from the ignition switch through a fuse when you turn the key on

1993 Mercury... | Answered on Jul 14, 2014


JUNK IT!!!!! I went thru electrical problems last winter, and spent way over a thousand dollars. all the new parts were rebuilt in china. I finally got a coil pack and ignition module from a junk yard and then it ran like new ever since.

1993 Mercury... | Answered on Jul 11, 2014


bad performance at rpm's and load -speed - misfiring at idle -engine dying on acceleration.-poor acceleration

1993 Mercury... | Answered on Apr 23, 2014

Not finding what you are looking for?
1993 Mercury Topaz Logo

222 questions posted

Ask a Question

Usually answered in minutes!

Popular Products

Top Mercury Experts

Marvin
Marvin

Level 3 Expert

85239 Answers

Thomas Perkins
Thomas Perkins

Level 3 Expert

14852 Answers

Mike

Level 3 Expert

4372 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

Topaz Mercury

  • Topaz Mercury

Most Popular Question

1993 mercury topaz 4cyl dies after 10

  • Cars & Trucks
Loading...