20 Most Recent 2013 Dodge Avenger - Page 5 Questions & Answers


Some anti-theft systems need to be reset after the battery has died and/or been replaced. Check your driver's handbook for more information on this.

Dodge Avenger... | Answered on Feb 13, 2014


Had a SIMILAR problem, turned out to be a loose connection on the alternator wires and a poor earth. Maybe worth having the battery tested too

Dodge Avenger... | Answered on Feb 11, 2014


You may need a repair book to find the problem. The alternator is controlled by the engine computer.

Dodge Avenger... | Answered on Jan 30, 2014


Hello, and welcome to fixya! The reason that you are able to hear the climate control system and not feel the air coming out of the defroster, is that the damper (this controls where the air is directed when you change the vent selection on the climate controls) is not operating as it should. The damper is controlled by vacuum pressure, and the usual culprit is that the vacuum hose running to the damper is either loose, or defective(usually dry rotted) which will create a vacuum loss. Without the vacuum pressure to operate the damper, you will lose some, but not all functionality of the vent selection. I recommend that you check the vacuum line(s) that run to the damper, making sure that the vacuum hose is connected, and free of defects, like cracks, holes, and that the connections are not loose as hoses can and will lose their elasticity, which will create a vacuum loss. If that is not the issue, I recommend that you remove the climate control vent selector and make sure that all of the connections to the control panel are secure and free of defect. If that is not the issue, you may have a faulty damper (which is rarely the case), and that will need to be replaced. As far as the climate control lights not working, that could be a simple as a blown fuse, faulty bulbs, or even as simple as a poor connection to the bulbs, or to the control selector. I highly recommend that you disconnect and reconnect all of the connections to the unit. When you check the fuse panel, remove the fuse(s) & check for faults and make sure that the connection the fuse is making in the fuse panel is making a solid connection. I hope that you have found this information useful, are able to resolve the issues you are experiencing.

Dodge Avenger... | Answered on Jan 27, 2014

Not finding what you are looking for?
2013 Dodge Avenger Logo

Popular Tags

31 questions posted

Ask a Question

Usually answered in minutes!

Popular Products

Top Dodge Experts

Marvin
Marvin

Level 3 Expert

85239 Answers

Thomas Perkins
Thomas Perkins

Level 3 Expert

14852 Answers

Mike

Level 3 Expert

4372 Answers

Are you a Dodge Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

Avenger Dodge

  • Avenger Dodge

Most Popular Question

find camshaft position sensor in dodge

  • Cars & Trucks
Loading...