Question about ATVs

1 Answer

Idles fine,,push pedal and it dies

Acts like not getting gas but all is fine

Posted by Keith Ramberger on

Ad

1 Answer

Claude Kayser

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • ATVs Master
  • 9,098 Answers

Idles FINE but stalls when pedal is pressed - Yamaha Rhino Forum ...

www.rhinoforums.net > ... > Technical > Engine
Feb 6, 2012 - 9 posts - ‎5 authors it starts fine but stalls when I press the gas pedal. what do I need to check now. Sponsored Links. RhinoForums.net is the premier Yamaha Rhino UTV/ATV Forum on the internet. Registered ... Does it seem to Idle smoothly and does it start right back up after it dies? Does it .... astro push accelerator and dies.

Posted on Oct 07, 2015

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1995 Suzuki King Quad (LT-F4WDX). Wont accelerate when warmed up.


did you adjust the valves? check and make sure the fuel pump is putting out enough fuel, way past time to replace it. check your voltage too, the regulators in those are famous for dieing.

Dec 22, 2016 | ATVs

1 Answer

Polaris troubleshooting


It is possible. I have had CDI's only act up when the motor has run for over 30 min and only when I am on the throttle hard. Then acts normal when cool again. They can do odd things. You have to check everything else out to eliminate them.

Aug 27, 2014 | ATVs

1 Answer

Fuel carburator


Take the ATV to qualified professionall!!

Sep 04, 2017 | ATVs

1 Answer

2005 Polaris Ranger shuts down when hot


Could be the coil pack going bad or fuel pump. Find the coil pack and spray water on the outside of it. Not a lot just a stream to keep it cool. It should be on top. Here is a video https://www.youtube.com/watch?v=woE4OIhCvAs

Dec 30, 2017 | Polaris ATV

1 Answer

At full throttle it starts to miss and lung back and forth


if its EFI its an injector, it not fuel injected, its a carb issue

If you need further help, reach me via phone at https://www.6ya.com/expert/allen_b068623c5003aa4b

Apr 01, 2013 | Polaris 2004 Sportsman 700 Twin

1 Answer

Engine won't run properly


sounds like its running rich. check your float height and then lower your main jet needle a notch

Dec 04, 2017 | Polaris ATV

Not finding what you are looking for?
ATVs Logo

Related Topics:

528 people viewed this question

Ask a Question

Usually answered in minutes!

Top ATVs Experts

john h

Level 3 Expert

23424 Answers

Marvin
Marvin

Level 3 Expert

85239 Answers

Tom Chichester

Level 3 Expert

55562 Answers

Are you an ATV Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...