20 Most Recent Kymco 2005 Mongoose 250 Questions & Answers


You can run sae 10A-40 in it and up to sae 20w-50 as well. It varies in prices. Best place would be somewhere like a Walmart. Usually around $4-$10 depending on what ya get.
The transmission oil for it is sae #90

Kymco 2005... | Answered on Aug 02, 2015


Bad pulsar unit
Bad CDI unit
Bad gearbox electrical unit
Bad coil
Bad HT lead or caps
Bad spark plug
Bad earth wires
Bad ignition key switch
Contaminated fuel
Dirty carburetor

Kymco 2005... | Answered on May 25, 2015


clicks, wont crank ??? check ground first, then suspect a bad starter as long as the solenoid and battery are good... a 12v test light will help here

Kymco 2005... | Answered on Mar 03, 2015


Do not know where to begin. Does the engine have compression? Are the valves adjusted correctly? Is it getting fuel, fresh fuel? Is there a spare to the spark plug? Is voltage getting to the ignition system, all fuses ok?

ATVs | Answered on Sep 07, 2020


• There is a problem with one or more of the following:

1) Dead Cell In The Battery
2) Plug / Connection Came Loose / Bad Or Missing Ground Cable
3) Voltage Regulator
4) Stater Is Bad
5) Wiring Harness Has A Broken Or Grounded Wire

ATVs | Answered on Sep 05, 2020


It might be the spark plugs or plug , but it looks like a fuel, pressure, filter,and injector problems Changing the plug is really easy. If it still occurs , change out fuel and then check the fuel pressures.

ATVs | Answered on Aug 19, 2020


Remove the spark plug.
Reconnect the HT lead.
Hold the base of the plug against the engine block.
Turn the engine over with the starter and look for a fat blue spark.

ATVs | Answered on Aug 19, 2020


Request the diagram from Polaris.

ATVs | Answered on Aug 12, 2020


First check to see if it has a spark or fuel by spraying a little starting fluid into the throttle body. If it does not, check the fuse to the fuel pump. If it runs then you check to see if the spark is getting to the spark plug. If not check the fuses and connection to the ecm.

ATVs | Answered on Aug 11, 2020


Lube the shifter control box.

ATVs | Answered on Aug 08, 2020


Two possibilities. One is that the bulb is bad and the other is the gear indicator/wiring has a problem .

ATVs | Answered on Aug 08, 2020


Here is how to check the oil and more.
https://www.youtube.com/watch?v=Du8j-R35ni0

ATVs | Answered on Jul 30, 2020


Hi, Henry, you need to repost your question under the Kawasaki Mule ATV category, not Motorcycles. Thanks, Gregg

ATVs | Answered on Jul 23, 2020


Spark plug
Spark Plug lead
Coil
Wiring

in that order, test them all, swap plugs, swap leads, swap coil to find the culprit.

ATVs | Answered on Jul 11, 2020


try google or a dealer

ATVs | Answered on Jun 27, 2020

Not finding what you are looking for?
Kymco 2005 Mongoose 250 Logo

3 questions posted

Ask a Question

Usually answered in minutes!

Popular Products

Top Kymco ATVs Experts

Marvin
Marvin

Level 3 Expert

85239 Answers

john h

Level 3 Expert

23438 Answers

Kardoc

Level 3 Expert

6083 Answers

Are you a Kymco ATV Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

Mongoose 250 Kymco

  • Mongoose 250 Kymco

Most Popular Question

oil much

  • ATVs
Loading...