Kymco ATVs - Recent Questions, Troubleshooting & Support


Same problem with my mxu 500. Charged battery. Nope. Checked all connections in starting system. Nope. Swapped out solenoid relay. Fixed mine. Was cheap online- less than $20. Mine would start with jumper cables or batt charger on 80amp boost. Good luck!

Kymco 2010 UXV... | Answered on Feb 13, 2020


choke it ? gas not getting to piston air filter clogged ?

Kymco 2015 MXU... | Answered on Feb 21, 2019


belt drive ? or chain. ? belt slipping ? sprocket on chain loose?

Kymco 2011 UXV... | Answered on Feb 21, 2019


, usually due to a leaking fuel line or malfunctioning fuel injectors. However, it is normal for a small amount of gas to get into the engine oil during normal engine operation.

Kymco 2011 UXV... | Answered on Jan 04, 2019


fixya doesnt sell products try recreation action repair shops or online

Kymco 2011 UXV... | Answered on Sep 30, 2018


i have the same problem

Kymco 2004... | Answered on Sep 23, 2018


The VIN for 2007 is on the cross member IN THE BACK just under the middle just under the plastic.

Kymco 2007 MXU... | Answered on Mar 24, 2018


Try rocking quad toward and back while you try to shift out of park.

Kymco 2014 UXV... | Answered on Sep 21, 2017


general rule of thumb if you cant find specs is make the float parallel with the bottom of the carb/top of the bowl

Kymco 2008 MXU... | Answered on Sep 11, 2017

Not finding what you are looking for?
Kymco Logo

79 questions posted

Ask a Question

Usually answered in minutes!

Top Kymco ATVs Experts

Marvin
Marvin

Level 3 Expert

85239 Answers

john h

Level 3 Expert

23401 Answers

Kardoc

Level 3 Expert

5771 Answers

Are you a Kymco ATV Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...