Hoover Vacuums - Page 9 - Recent Questions, Troubleshooting & Support


I leave mine on the charger until I use it mostly more than 8 hours after charged and in 12 months nothing has happened
that is why the charger is incorporated into the stand

Hoover Vacuums | Answered on Dec 29, 2017


There are MANY models of "Hoover power drive supreme vacuum cleaners" ~ what SPECIFIC model is yours ~ please?

Hoover Vacuums | Answered on Dec 27, 2017


By all means ~ take it back to the store... I searched for your model and "problems" and got almost 400 hits like: "cutting out", "burning smells" and just plain "dead" to name a few...

In fact one site gave this model only 1 1/2 Stars! You've GOT to see this Link!

Hoover 2000 VC338

2 months is way too soon to fail ~ unless you clean motels or hotels for a living.

Anthony

Hoover Vacuums | Answered on Dec 24, 2017


If its brand new there may still be a piece of tape holding it shut. It sounds silly but I've seen it happen before.

Hoover U5444-900... | Answered on Dec 21, 2017


Check all the wheels to see if they turn freely. Perhaps one is just hung up.

Hoover U4270-930... | Answered on Dec 21, 2017


It may not be safe to use anymore, the motor may be failing from the water intrusion.

Hoover Vacuums | Answered on Dec 21, 2017


I had the same problem with my Hoover Floormate H3000 and found the solution elsewhere on this website. Try doing a search for Hoover Floormate H3000. The posted solution is basically as follows:

Remove the liquid dispenser tank and set it aside. Look into the cavity of the machine where the tank attaches and find the plastic "plunger" piece (the one on my machine is a blue/grey color) that is surrounded by a black rubber circle. Put a small drop of hot glue on the tip of this plastic "plunger" piece and let it harden. Replace the liquid dispenser tank and try the machine again. My machine dispensed liquid properly after this fix-it.

I really appreciate the poster who provided this simple solution!

Hoover Floormate... | Answered on Dec 18, 2017


IF you can use a broom stick to run through the hose to make sure that there is nothing in it, then you need to check the output filters. They get plugged up with fine dust particles and the suction is reduced. The output filters can usually be rinsed out.

Hoover UH70210... | Answered on Dec 18, 2017


we can not as that type fix needs to be hands on not wireless

Hoover SteamVac... | Answered on Dec 15, 2017


  • Defective battery
  • Defective charger

Hoover Vacuums | Answered on Dec 12, 2017

Not finding what you are looking for?
Hoover Logo

6,931 questions posted

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18424 Answers

Jim Parker
Jim Parker

Level 3 Expert

1041 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1474 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...