Hoover Logo

Hoover Recent Questions, Troubleshooting Help & Support

  • 833 Products
  • 38K Answers
  • 867K Views

Order a new one.

Good luck


Mai

Hoover UH70120... | Answered on Apr 12, 2017


I had the same problem with my Hoover Floormate H3000 and found the solution elsewhere on this website. Try doing a search for Hoover Floormate H3000. The posted solution is basically as follows:

Remove the liquid dispenser tank and set it aside. Look into the cavity of the machine where the tank attaches and find the plastic "plunger" piece (the one on my machine is a blue/grey color) that is surrounded by a black rubber circle. Put a small drop of hot glue on the tip of this plastic "plunger" piece and let it harden. Replace the liquid dispenser tank and try the machine again. My machine dispensed liquid properly after this fix-it.

I really appreciate the poster who provided this simple solution!

Hoover Floormate... | Answered on Apr 10, 2017


There are many different models of Hoover Windtunnel so I can't be specific to your model, you will need to determine where the cord enters the unit and how to gain access to the internal wiring. Disconnect the old cord and attach the new cord using the proper connectors.

Hoover Vacuums | Answered on Apr 02, 2017

Not finding what you are looking for?

Ask a Question

Usually answered in minutes!

Top Hoover Experts

yadayada
yadayada

Level 3 Expert

74843 Answers

Brad Brown

Level 3 Expert

15345 Answers

Steve F

Level 3 Expert

899 Answers

Are you a Hoover Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...