Science & Laboratory - Answered Questions & Fixed Issues


The serial number will be on the packaging that came with the software that you legally bought.

Fruity Loops... | Answered on Dec 06, 2017 | 374 views


The electrode you have is a combination electrode with an integral calomel reference half-cell and built-in temperature probe. Since the temperature reading is good, the temperature probe is okay. It isn't part of the pH circuits anyway. (Your meter uses the temperature to calculate a temperature correction of pH.) Something else is going on with the electrode proper. Its funny behavior suggests to me that it has dried out internally.
pH electrodes don't last forever. How old is this one? If it's an old one, it's probably time to replace it. If it's new and doesn't work, it may be under warranty.
If you shop for a new electrode, get a gel-filled one. And go for one with a silver/silver chloride reference instead of a mercury one -- especially if you are using it on food or other samples that may be consumed. Another consideration about calomel electrodes: they take hours to recover from relatively small temperature changes. Ag/AgCl references aren't as sluggish.
Finally, take care when storing the electrode. It should be stored under humid conditions to keep it from drying out. The best way is to put a small piece of cotton or glass wool soaked with distilled or deionized water inside the plastic end cap. For shorter-term storage, e.g., overnight, you could immerse the tip in pH 7 buffer.

Fisher Science &... | Answered on Nov 22, 2017 | 877 views


you need the software for that microscope from the manufacturers web site suitable for win 8 64 bit

Science &... | Answered on Nov 20, 2017 | 62 views


It sounds like a fuel vapor lock, check that the fuel line to the carb is not coming contact with any metal surfaces of the engine for this will boil the fuel in the line before it enters the carb. If this is the case, just stand the fuel line off from where it is touching. I hope this helps....GOD BLESS....Randy...

Mercury Marine... | Answered on Nov 07, 2017 | 1,532 views


What model? Could be the battery need to be changed.

at
http://www.tobaccogeneral.com/accur8-355-mnf.htm
tobacco is selling out their accura8

American Weigh... | Answered on Oct 29, 2017 | 819 views


You probably have done this, but......try a new and top line USB cable. rj

Fisher... | Answered on Sep 29, 2017 | 1,019 views


Note: Administrator default password is admin.

Science &... | Answered on Sep 27, 2017 | 974 views


Damage to an expensive precision instrument can result in loss of functions, distorted results, costly repair or replacement. There is also risk of contamination and injury. Damage can result from misuse or lack of maintenance.

Safety Maintenance

http://www.wpro.who.int/mvp/lab_quality/2096_oms_gmp_sop_12.pdf

Science &... | Answered on Sep 09, 2017 | 1,930 views


Service Support Nikon Instruments Microscopes and Imaging Systems

My best advice is to contact the support for the instrument. Avoid DIY without expert guidance as the potential for damage to the precision instrument exists which could result in costly repair or replacement.

Nikon Science &... | Answered on Sep 09, 2017 | 1,193 views


There are a variety of brands/models of autoclaves and your model is not adequately identified. There are ES models of an autoclave of a particular brand but I have no knowledge of their designation system. A search of an autoclave manual did not reveal an "es" error code. Why not contact technical support or the sales forces of the manufacturer with the query?

Science &... | Answered on Sep 09, 2017 | 1,394 views


The "pot" really adjustable electrical resistance feed in the bulb directly of through a triac is most likely showing intermediate contact between the resistance coil and "slider" - it will have to be replaced.

Wesco CXR3... | Answered on Aug 28, 2017 | 1,711 views


see a doctor. dont waste time

Science &... | Answered on Aug 14, 2017 | 1,253 views


Someone has pressed the reset button at the back of the unit. The memory banks are being cleared and all settings are set to default. Wait until the process finishes (hour maybe) and till the "check code 191" is displayed. This means that the restore to factory settings is finished. After that you should be able to use the unit again although all your programs are lost.

pharmacia... | Answered on Jun 30, 2017 | 1,808 views


Make sure the unit is unplugged!!!
I believe it is the lid switch. You can remove the housing and the switch is located adjacent to the latch. Test it with a multi-meter.I do not recommend bypassing the switch except to test it's operation. Serious injury can occur!!!

Eppendorf 5402... | Answered on Jun 26, 2017 | 2,595 views


$25 or $30 if it is in OK condition. maybe $50 if pristine

Tasco Science &... | Answered on Jun 26, 2017 | 2,013 views


It sounds like the backlight of the LCD display is out. The Image is still being displayed there is just no light to illuminate the image. Try shining a flashlight on it (Put the light right against the screen) and see if you can see what's on the screen. The display is fairly easy to install but I do not know where you can purchase one directly.

Zeiss Gdx/vcc... | Answered on Jun 26, 2017 | 1,826 views

Not finding what you are looking for?
Science & Laboratory Logo

Ask a Question

Usually answered in minutes!

Top Science & Laboratory Experts

Gareth Cockram
Gareth Cockram

Level 3 Expert

661 Answers

William McMath

Level 2 Expert

178 Answers

ray gallant

Level 3 Expert

46318 Answers

Are you a Science and Laboratory Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...