Question about Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

1 Answer

Kenmore direct drive model 116 31912100 lost vacuum

Replaced bag, hepa fillter. Brush rolls, but no suction. What is the problem here and how can I resolve it. Thanks. Ed Cruz

Posted by on

  • Anonymous Sep 04, 2008

    intake hose cleared, new hepa filter, cleaned motor safety filter. Vacuum made a short roaring sound then motor quit. Is the motor dead or fuse in the motor compartment burnt out. What is the function of the protector.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,673 Answers

Check the inlet where the dirt is first sucked in for a clog, also your hose may be clogged.

Posted on Sep 04, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Electrolux Ultraactive losing suction and turbo head brush won't spin. Canister is empty, no blockage in hose or nozzle of turbo head, filters cleaned, but Hepa not replaced recently. Could that cause it...


Hi, it's Jeremy from Crucial Vacuum.

There are a few potential solutions you should try to fix the suction of your Electrolux vacuum. The first thing you should check is the height of your brush-roll. Your height setting may be too high for the type of floor you are vacuuming. Raise or lower your brush-roll depending on if you are vacuuming on carpet, tile, or wood surfaces.The second thing you should check is the vacuum bag. If it is full your vacuum can lose suction. This is simply remedied by replacing it with a new and clean bag. The third reason for a loss of suction is your hose is clogged. Check the hose for debris or foreign objects that may be obstructing the flow of air in the vacuum. The last potential reason for your vacuum losing suction could be the brush-roll itself. If it is clogged with dirt and hair it may not be spinning and not picking anything up. Check to see the condition of your brush-roll. If it is clogged remove the debris.

You can purchase direct your Electrolux replacement vacuum parts from Crucial Vacuum with free shipping and an exclusive 10% coupon for Fixya.com readers, use code: FIXYA10

http://www.crucialvacuum.com/electrolux.html

I hope this was helpful. If you would like further assistance, please feel free to give us a call at 877.750.9239. We have helpful and friendly customer care representatives on the line ready to assist you.

Jeremy Lerner
Crucial Vacuum Customer Care
http://www.crucialvacuum.com

Aug 05, 2014 | Vacuums

1 Answer

Riccar 8995 no suction


If it's been over a year since you've replaced the belt that is the first place to start. Stretch belts lose elasticity and will still turn the brush roll but when the brush roll is lowered to the carpet it may not turn fast enough to pick up properly. If you have good suction at the end of the hose check to make sure there is not an obstruction in the tube where the hose goes into the bottom of the vacuum to the brush roll. Make sure your filters are replaced at least once per year and the bag is not full or has a lot of fine powder dust in it which can clog the bag.

Jun 13, 2014 | Riccar 8955 Upright Vacuum

2 Answers

Kenmore progressive vaccum lost suction


For the canister-style vacuum with the long hose, you can't see all the way thru it, since the plastic fittings on the ends are curved. Mine was clogged - I mean, really clogged! Others have suggested using a high-powered air compressor to blow it out, but I augured out my lint/hair/straw/other-unidentifiable-stuff clog with a manual (hand-crank) home sink/drain auger. Worked like a charm! Use a small mirror (like a dental mirror) and a flashlight to see a little ways into the hose if you want. Finally, run the auger all the way thru to make sure you push out anything you couldn't spear and pull out.

Oct 14, 2012 | Kenmore 31913 Progressive Direct Drive...

1 Answer

My vacuum will not pick up even fuzz on the carpet


If the suction is strong through the hose and its still not picking up, then something is definately clogged despite the strong suction and rolle brush. Check all inspection tubes including the main dirt channel behind the roller brush. You may find something that keeps getting in the way when dirt or hair is trying to bypass through.

Jan 23, 2009 | Kenmore 31913 Progressive Direct Drive...

2 Answers

Need Manual for Kenmore Progressive with Direct Drive vacuum clea


You can check for the manual at:

www.managemyhome.com

I would suggest checking the hoses for clogs. Especially the hose right after the carpet brushes. Don't forget to clean off your brush. Hope this helps.

Jan 12, 2009 | Kenmore 31913 Progressive Direct Drive...

1 Answer

Kenmore progressive Direct Drive Vacuum w/Hepa


Check the hose and dirt inlet for a blockage. Also the brush roll, check it to see if you can turn it or not by hand. If not, then something may have jammed it.

May 03, 2008 | Kenmore 31913 Progressive Direct Drive...

1 Answer

Load noise at start-up goes away after a minute, but there is no suction.


If the brush roll and motor runs and sounds ok, then that is an indication of a clog, either in the hose or the dirt inlet down by the brush roll. You should have a years warranty on this, if you can't figure it out, then take it into Sears and get it repaired.

Apr 15, 2008 | Kenmore 31913 Progressive Direct Drive...

2 Answers

Kenmore Progressive 100


Check the brush roll ends, make sure they turn freely, if not then replace it. The belt may look ok, but they stretch after a short time and should be replaced.

Mar 24, 2008 | Kenmore 31912 Progressive Direct Drive...

1 Answer

Hoover Windtunnel


Either the hose has a clog, or the inlet down by the belt is clogged. Is there suction at the end of the hose, if not then it is clogged. If there is suction, then it has to be clogged down below by the brush roll, check that inlet. There also is a filter at the bottom where the dirt cup (and bag) is, check it also.

Dec 28, 2007 | Vacuums

1 Answer

Owners manual


remove bottom plate, remove brush roll. slip new belt over motor shaft then onto brush roll. refit brush roll and bottom plate. its just meccano

Mar 17, 2007 | Kenmore 31913 Progressive Direct Drive...

Not finding what you are looking for?
Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum Logo

746 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18298 Answers

Roger Potts

Level 3 Expert

694 Answers

yadayada
yadayada

Level 3 Expert

60769 Answers

Are you a Kenmore Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...