Question about Solis Crema SL-70 Espresso Machine

1 Answer

Steamer/frother in-op First off, Javadoc.com referred me. Steamer section doesn't work properly. the symptoms are: On cold start pump will deliver water at a steady stream through the wand. However, if the steamer heat is turned on and that section is brought up to temp there is nothing through the steam tube but all of that steam is diverted over to the portafilter side and the pressure is relieved, dramatically, through the portafilter. I have tried reaming the tube with flex wire and also decalcifying the system, a futile exercise because the local water is mineral free. But anyway I did go through the drill. The machine is 8 months old and gets limited daily use. Any help would be appreciated. Thanks ~Bob

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 1,089 Answers

Hi
I think you steam knob is out of adjustment. This valve the the knob turns opens a needle, so when you close the knob it is just allowing the needle to seat. If you turn the knob harder you move the valve away from the needle, so when you try to steam everything has expanded and the valve does not touch the needle, and it won't open.
To fix.
The top comes off by removing the screw on the top back where the water tank locks in. Once the screw is removed the put both hands on the side of the machine near the top and with your 2 index fingers, push the top forward. This will push the top of the face plate forward and release the top.
Once the top is off hang it over the back for know.
You will need a #2 Allen wrench. Rotate the knob all the way counter clockwise. You will notice that there is a cam that rotates with the knob. On the back side of the cam you will find a hole. Inside that hole is a #2 Allen screw. Loosen the screw and then without moving the cam rotate the know all the way counter clockwise, then tighten the Allen screw. This is how you adjust the Solis SL machines steam valve.
To reassemble.
The top of the face plate locks into the bottom of the front part of the top, so when you put it back together slip bottom of the face plate into the machine, then put the top on the face plate so the front of both is flush whit each other. Then push down and back on the top and it will lock in. then put the screw back in and your done.

Posted on May 31, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do I get the handheld steamer to lock into the steam mop?


Hey, this is Jeremy with Crucial Vacuum,

To attach the handheld steamer into the base of your Euro-Pro Steam Mop place it into the cradle of the mop housing. Then slide the top end of the handheld Steamer into the mop housing and snap it into place. If this does not work, remove the handheld portion and check to make sure there are no obstructions at either of the points where the pieces attach to each other.

If you need further clarification please refer to page 12 in the link below. It provides a more detailed step-by-step and diagrams to follow.

http://www.sharkclean.com/shark-pro-steam-pocket-mop/support/manuals/3901/S3901WM_IB_110420.pdf

You can purchase replacement mop pads for your Euro-Pro direct from Crucial Vacuum with free shipping and an exclusive 10% coupon for Fixya.com readers, use code: FIXYA10
http://www.crucialvacuum.com/2-shark-s3101-s3202-s3250-steam-mop-pads-part-xt3101.html

I hope this was helpful. If you would like further assistance, please feel free to give us a call at 877.750.9239. We have helpful and friendly customer care representatives on the line ready to assist you.

Jeremy Lerner
Crucial Vacuum Customer Care
http://www.crucialvacuum.com

Jun 11, 2015 | Euro-Pro S3901 Shark Lift-Away Pro Steam...

1 Answer

How to change oil pump on 1996 Isuzu rodeo


why?
tell full symptoms, i bet it not the pump.
which engine.2.2 or 3.2. there are 3 engine in USA. used
nothing stated.
ii pretend you said, 3.2
the FSM shows.

  1. Before servicing the vehicle, refer to the precautions in the beginning of this section.
  2. Remove or disconnect the following:
    • Timing belt
    • Oil pan
    • Oil pickup tube
    • Oil filter adapter
    • Oil pump
all that and more, at alldata.com
but for Diagnosis, GEE< ask.
post SYMPTOMS> and get real answers.

there can be low or too much oil presssure.
low is most common, but is different
HOT?
cold?
and all rpm's.?
non of which was stated.
the #1 causes of low pressure ,is running the wrong oil viscosity.
if 10w-30 is in car, and low, the bearings are shot.
1 or all of them.

do you own a real oil pressure gauge, accurate. not some 5$ china
imported, trash?

Apr 08, 2014 | 1996 Isuzu Rodeo

1 Answer

Frezzer works but not refrigerator refer section does not get cold but frezer section works


Its defrost problem, the freezer should cool, then freeze, then defrost cycle should start. In your case freezer is cooling, then freezing, but its not defrosting. That's why fridge section is not cooling.-------

Click this link below and follow the troubleshooting:----

http://technoanswers.blogspot.com/2011/06/refrigerator-is-not-cooling-properly.html

-----------

This will help.Thanks.Helpmech/.

Oct 31, 2011 | Refrigerators

1 Answer

My jcd2389des freezer is working fine but the refrigerator isn't cooling properly


Hello Sharleen,

The leading problem when freezer works yet the refrig. section doesn't get cold is going to a problem with a automatic defrost system defect. Do ya see a bunch of frost inside of the freezer on the back wall?? if yes ya do see that frost build up ist defiently not defrosting and this tip i wrote covers what to check when it doesn't defrost http://www1.fixya.com/support/r10097882-wrong_when_freezer_frosted_refrig_warm


GENE

Oct 03, 2011 | Jenn-Air JCD2389G Side by Side...

1 Answer

My Whirlpool ET8WTKXKT0 doesn't cooling down. The fan is working, but the compressor like dead. What I have to check? Thanks. Victor


Its the problem with compressor,The problem is weak compressor.The refrigerant ( R12) in the compressor is got low.The compressor is weak.The compressor needs to be replaced.-------------- The working procedure of this unit is as follows: --- The compressor starts then it cools the freezer section. When the freezer reaches its cooling level the defrost cycle starts functioning. In this cycle the fan in the freezer section starts running and the cool air in the freezer section is passed to the fridge section and the fridge section gets cold. The air from freezer to refrigerator passes from the section, in that section the damper is located.------------ But as you mentioned that freezer not cooling this indicates problem with compressor.When compressor cools the freezer section then fridge section gets cold.If freezer section is not getting properly cold then fridge section will not cool properly/.So the problem relates to compressor.---------- In the compressor there is a refrigerant called FREON.With the help of this Freon the compressor cools the freezer section.Freon is a gaseous type cooling agent.The compressor will stop cooling when coolant gets leaked from its chamber.--------- Again recharging the Freon is possible, but the cost for that recharging is approx the cost of new compressor.So its always advisable to get compressor replaced.Because new compressor has warranty for few years.------------------ You can get required parts from from online sites like: --- www.repairclinic.com or from searspartsdirect online site. --------- This should help.Thanks.Helpmech.

Jul 08, 2011 | Whirlpool ET8WTKXK Top Freezer...

2 Answers

All lights are flashing .. cannot seem to get it to operate properly ... the water is full ... but all buttons are flashing (i.e. off/on, two cup, one cup, steam and blue water light .. any thoughts of...


sounds like you need to prime it. if the water tank is full, then there's no water in the espresso machine. even after we followed the directions in the manual for priming the sirena, we still couldn't get the water to go from the reservoir in the back into the machine.

johnshami had this solution on another post, and it worked for us:
  1. make sure the water in the tank is stone cold -- which is a no brainer since it will not heat h2o unless it's primed.
  2. take off steamer wand cover, turn the steamer knob clockwise till pump starts.
  3. then s*ck (as you would on a straw, with your lips sealed around the end of the steamer wand) the tip of the end of the metal tip hard until pump stops
  4. may need to do it a couple of times. yes this seems crazy, but it works! you are flushing out the vapor lock in the pump.

Dec 23, 2009 | Saeco Starbucks Sirena Espresso Machine

3 Answers

Starbucks sirena won't heat up; blue light flashing-brand new


johnshami had this solution on another post, and it worked for us:
  1. make sure the water in the tank is stone cold -- which is a no brainer since it will not heat h2o unless it's primed.
  2. take off steamer wand cover, turn the steamer knob clockwise till pump starts.
  3. then s*ck (as you would on a straw, with your lips sealed around the end of the steamer wand) the tip of the end of the metal tip hard until pump stops
  4. may need to do it a couple of times. yes this seems crazy, but it works! you are flushing out the vapor lock in the pump.

Sep 27, 2009 | Saeco Starbucks Sirena Espresso Machine

1 Answer

The machine lights don't turn on


sounds like you need to prime the machine. check the manual for those instructions. if (like us) nothing happens, then read on:

johnshami had this solution on another post, and it worked for us when the manual's instructions to "prime" the machine resulted in no water leaving the tank to enter the machine:
  1. make sure the water in the tank is stone cold -- which is a no brainer since it will not heat h2o unless it's primed.
  2. take off steamer wand cover, turn the steamer knob clockwise till pump starts.
  3. then s*ck (as you would on a straw, with your lips sealed around the end of the steamer wand) the tip of the end of the metal tip hard until pump stops
  4. may need to do it a couple of times. yes this seems crazy, but it works! you are flushing out the vapor lock in the pump.

Sep 05, 2009 | Saeco Starbucks Sirena Espresso Machine

2 Answers

The blue light is blinking, the water tank is full, but the water isn't heating up at all. should we return it? Or is there something that we missed? We followed the instructions and are getting no where.


johnshami had this solution on another post, and it worked for us when the manual's instructions to "prime" the machine resulted in no water leaving the tank to enter the machine:
  1. make sure the water in the tank is stone cold -- which is a no brainer since it will not heat h2o unless it's primed.
  2. take off steamer wand cover, turn the steamer knob clockwise till pump starts.
  3. then s*ck (as you would on a straw, with your lips sealed around the end of the steamer wand) the tip of the end of the metal tip hard until pump stops
  4. may need to do it a couple of times. yes this seems crazy, but it works! you are flushing out the vapor lock in the pump.

Aug 09, 2009 | Saeco Starbucks Sirena Espresso Machine

2 Answers

Kenmore Side by Side Refrigerator, freezer doesn't work, refrigerator works


Unless specifically made for use in a garage most units won't work properly. The owners manual should say what the temp range for proper operation is (usually 55F is the low range). This is because the refrigerator section doesn't need to be "cooling" to maintain 37F if the temps on the outside are below 55F. These things are made to work in a 70F room and will not work properly if under 55F. Stupid thing thinks it's cold enough so it will never turn on, the refer section will stay cold/cool due to outside temps but since the compressor never runs the freezer will just be the same temp as the refer section (at best). Sorry, but in order for a freezer or refrigerator to work in an unheated space it must have the temp control device controling the freezer section NOT the fresh food section. In other words, that model will not work in a garage unless the temps are above 55F always.

Feb 06, 2007 | Kenmore 50522 / 50524 Side by Side...

Not finding what you are looking for?
Solis Crema SL-70 Espresso Machine Logo

99 people viewed this question

Ask a Question

Usually answered in minutes!

Top Solis Coffee Makers & Espresso Machines Experts

graybeard32301

Level 3 Expert

352 Answers

Mike Cairns
Mike Cairns

Level 3 Expert

3053 Answers

isaac johny
isaac johny

Level 3 Expert

796 Answers

Are you a Solis Coffee Maker and Espresso Machine Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...