Question about Olympus FE-280 Digital Camera

1 Answer

Olympus FE-280 not working properly

Took pictures a few days ago and camera was working great. Pulled it out and tried taking pics at my sons football game and was greated with this same problem. Weird noise when I turn it on, lcd screen shows up blurry and unfocused and camera makes weird noise like it is trying to focus itself and shuts off if you try to zoom. However, my battery is fully charged and I can view my previously taken pictures. Options such as "guide" and "scene" are still accessible and camera turns on and performs other duties as if it is fine, except for the wierd focusing noises and blurry pictures and inability to zoom w/o camera shutting itself off. I notice when it is on the light on the back remains red instead of green as it usually is when the camera is functioning properly. I'm frustrated! My husband bought this for me Christmas 2007. I haven't dropped the camera or done anything to make it malfunction

Posted by on

  • 6 more comments 
  • Anonymous Sep 30, 2008

    I'm having the exact same problem. Did you figure out what happened?

  • maddy_laddy Oct 02, 2008

    i got my camera out and suddenly it just wasnt working.....it had worked fine before. I charged the battery but it made no difference.

  • Anonymous Oct 18, 2008

    yeh exaclty the same thing has happend to me. im in america and i really need it to be working again to take pictures of this lovely place

  • lyndseyh Oct 20, 2008

    I thought maybe it was a virus because same thing is happening to me. Is the only solution just to send it away? I'm in Africa until December and this is obviously inconvenient for about 1000 different reasons!

  • Anonymous Oct 23, 2008

    it makes a funny noise when it is turned on and won't focus

    it came up out of no where

  • wolvster Nov 07, 2008

    Having the exact same problem - it's been working fine for nearly a year, and then suddenly it's not working! I've contacted Olympus; waitiing for a response.

  • Anonymous Nov 12, 2008

    I have the same EXACT problem. I have no idea of how to fix it either.

  • Anonymous Nov 23, 2008

    I have the same problem as well.  It appears to be a product problem.

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Olympus Expert
  • 479 Answers

The lens could be the problem.. probably need to send to repair before the warranty runs out

Posted on Sep 03, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I HAVE A OLYMPUS CAMERA ONLY 4 MONTHS OLD AND I TAKE PICTURES GO BACK A FEW WEEKS LATER TO VIEW THEM ON THE CAMERA AND THEY'RE ALL GONE!!! WHAT'S GOING ON


review your manual in the "storing Pictures" section.
it might be something related to your card.
If it still acts up, you have a one year warranty under manufacturer. call Olympus.

Jul 01, 2010 | Olympus FE-280 Digital Camera

1 Answer

Help with the Olympus FE-280 8.0 megapixel, please!!


this is a tipically problem, of a pressure on the lens, if the lens go out. or if the camera are dopped. to resolve this problem alone you must have specifically knowledge.
the cost of the reparation is high. so if you want prove withe the exact model number, search on the ebay international seller the komlet lens with ccd for you camera. any american seller if you buy the lens, can give a guide to change the lens block. but this is not a symply job. if you make one error you loose the camera and the lens. the price of your lens block can go from 25 to 35 euro, if you can change it alone you have resolved with this money. ok.?? sorry for my bad english if you want help can you write me and i will help you

May 30, 2010 | Olympus FE-280 Digital Camera

2 Answers

Sandisk micro SD "card error"


The five pics are being stored on the camera's internal memory. The card you used was formatted and used in your phone. It's a miracle it worked at all. You need to get a new card, format it in your new camera have fun.

Dec 28, 2009 | Olympus FE-46 Digital Camera

1 Answer

Need pictures off Camera memory


memory card reader is the easiest way

Jan 02, 2009 | Olympus FE-280 Digital Camera

1 Answer

Fe-280


try taking card out... and power camera on.. should be ok... you can try to clean the card and see if it works

Sep 04, 2008 | Olympus FE-280 Digital Camera

1 Answer

Software (in use since 12/07) won't open


the software default location is in my pictures/olympus master 2/year/month/day

you will need to call olympus support for them to help correct your problem... could be due to virus protection program changing your program around

Sep 03, 2008 | Olympus FE-280 Digital Camera

1 Answer

FE-280 Wont Focus and Shust Off


I have the same problem, but my display doesn't show anything. It is just black.

Dec 10, 2007 | Olympus FE-280 Digital Camera

2 Answers

Pictures appearing black- olympus FE 170


You checked the obvious, lens cover? (sorry had to ask) any grinding noises when you take a picture or focus\zoom?

Aug 26, 2007 | Olympus FE-170 Digital Camera

Not finding what you are looking for?
Olympus FE-280 Digital Camera Logo

438 people viewed this question

Ask a Question

Usually answered in minutes!

Top Olympus Digital Cameras Experts

kakima

Level 3 Expert

96333 Answers

Willem.
Willem.

Level 2 Expert

345 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you an Olympus Digital Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...