Question about Autotek SX280 Car Audio Amplifier

1 Answer

Blown subs i have an 800watt 2 channel autotek amp which has worked fine for around 4 years. then my subs fried. i bought a new sub and this also fried after around 30mins use at medium volume levels any ideas? thanks

Posted by on

  • glennmaynard Aug 28, 2008

    it is bridgeable i think its the sx-2300 i was running 2 x diamond 12" 300w rms dual 2 & 4 ohm wired parallel the amp temp is fine just keeps popping subs

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 241 Answers

HOW do you have it wired and what is the ohms rated on the subs
and is this amp bridgeable and at what ohms is it stable at
Do you have it Bridge to the subs to lower the ohms( Series or in Parallel)
Is the amp running hotter the normal and do you have it in a well ventilated are of your car/truck
Most car audio or at 4ohms and also is the subs dual

Posted on Aug 28, 2008

  • Jayson Brollini
    Jayson Brollini Aug 28, 2008

    Are the subs rated at high enough Watts to handle the amp
    and the subs ARE blown or are the making a scratching sound
    Is the Subs wires + - connected to the coil and the sub frame(metal)
    I am just wondering what you mean by fried ( A blown Sub can be several things that can be repaired!)
    Now the Amp is powerful and it sound like nothing is wrong with it.
    Now do you have a capacitor going to the battery, because you battery can send SPIKES (high volatage/Watts) and this would cause your amp to produce higher amount of watts>


×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I just bought two rockford fosgate t1 twelves duel voice coil 4ohm I'm running a old school alpine v12 1507 mrv 2channel. I want to bridge the amp to get the most out of these subs would it be better...


Hi there,
This amp should run comfortable at 2 ohms/channel. However, your dual voice coil subs are rated at 4 ohms. This means when you connect the 2 voice coils together in parellel (positive to positive and negative to negative both coils wired to one output) the amp will see 2 ohms. So if you connect both subs to one output then your amp will see 1 ohm (not good) If you run the voice coils in parellel but the subs in series then the 2 resistances (ohms) will be added together. So that way the amp will se 4 ohms. This is fine but the amp would push more power into 2 ohms. You can run one sub on each channel if you can split the head unit output to 2 outputs, problem is then you will be halving the amount of power to each channel. Personally I would probably be more inclined to run 1 sub on this amp and run another amp from the pre-outs on the first amp for the 2nd sub. Try to find another amp the same to run the second sub. Mind you, 2 of these amps will need some big power cable to run them but should shake your teeth out!
Hope this helps

May 08, 2011 | Alpine Car Amplifiers

2 Answers

Pyle Academy 2300 watt amp not working =(


wrap a striped speaker wire around the back of the rca out put on your cd player and for the record that aint a 2300 watt amp its like a 300 watt amp

Mar 30, 2010 | Pyle PLAM2300 Car Amp

1 Answer

I have 4/3/2 ch. alpine f-240 amp- i want to hook up four 6x8 3-way and one 12''sub. the amp has bass EQ on ch. 3. how would i hook it up and get the most power. can i put the 4 6x8 bridged all together...


run two 6x8s on each of the front channels of the amp. then depending on the sub you can bridge it on the rear channels.only if its a single four ohm. if its a dual 2 ohm sub run each coil on each channel. 1 coil-1channel. the other coil-the other channel. amp should run fine may run a little hot since it will be doing all it can do at a safe ohm load. just make sure it is mounted in a well vented area. should be safe.

Dec 25, 2009 | Alpine MRP-F240 Car Audio Amplifier

1 Answer

Blown subs


check all the connections are good even hook a sub up to and cd player to see if it works if it does it will be the amp

Aug 28, 2008 | Autotek SX280 Car Audio Amplifier

1 Answer

2006 12" Kicker L7 4 ohm


first whats the range in terms of WATTS that your 12" sub can handle in 4 OHMS ? second , lets check the AMP , POWER ACOUSTIK 1800 WATTS , Now thats a lot of power to drive a single 12" sub speaker . your amp is 1800 watts , per channel is around 500 watts , if BRIDGE thats around 1600 watts rms for ONE channel , if your sub can handle that kind of wattage fine , but it will not blow the amp , what it does is shuts down , some kind of protection mode , it will come back on after a minute or so. I suggest to use one channel in stereo mode , or purchase another sub to use the other channel. i hope this helps AJ

May 06, 2008 | Kicker 06ZX750.1 Car Audio Amplifier

1 Answer

Amp has 3 modes on it ,as a switch,what is this,it has a 2,3,4 channel mode,i have the gold dhd 1000watt x4 channel


first thing 1000@4 means 250w per ch. which means150w usable power.the mode switch is only to reduce rca cables,use 2ch mode if only 1 pair rca available,60hz is a bit low for this amp,90 would work better.

Aug 21, 2007 | DHD NTX-2009 Car Audio Amplifier

2 Answers

Amp heats up and goes into protect mode


Hi Saint108. You're describing it well, and i know what the problem is already. The MA audio amp, can't hold with a 2 ohm load. It's too low for that amp, that's for sure. Those are budget amps and they are not well built enough to handle low ohm setups like that. It's overheating and there's no ways around it.. Other than wiring your subs differently ! Just wire your sub directly (not in parallel) in a 4 ohm load, you will notice it will stop overheating that much. Do it quick, you'll most likely fry your amp giving it such hard work !! The HUM you're hearing could be related to it also. Try that, and keep me posted on the status. Thanks ! Cheebster.

Jul 02, 2007 | MA Audio Hard Kore HK-898 Car Audio...

1 Answer

My Kenwood 800watt amplifier


Sounds like you have overloaded your amp. When you bridge you MUST make sure that you still have the proper speaker load. One 4 ohm speaker on one channel is fine, but when you bridge that same 4 ohm speaker, it gives you a 2 ohm load on each of the two channels that are now bridged. If you made the mistake of wiring two 4 ohm speakers in parallel (plus to plus and minus to minus) then when you bridge you will be driving a one ohm load on each channel. This is very close to a dead short. Stop using your amp at once until you get your speaker load correct. This will damage your amp and it will cause you to have to go to a repair shop to fix it. DO NOT RUN YOUR AMP ANYMORE UNTIL YOU FIX THIS. Good luck.

Jan 22, 2007 | Kenwood KAC-9152D Car Audio Amplifier

4 Answers

Amp Will Not Stop Overheating


You say you have 2 p312d2 subs. Ok so the d2 stands for dual 2homs (2 X 2homs voice coils per sub) , conecting in parallel the 2 voice coils of only one sub will create 1hom load to the amp, and if your amp is 2homs stable per chanel that means you are lowering too much your homs causing the overhwating to it.

Sep 25, 2006 | Ultra Linear UL-2200D Car Audio Amplifier

1 Answer

P3001 amp may be fried


Check this out: http://www.techlore.com/article/14696/

Aug 06, 2006 | Rockford Fosgate P3001 Car Audio Amplifier

Not finding what you are looking for?
Autotek SX280 Car Audio Amplifier Logo

Related Topics:

87 people viewed this question

Ask a Question

Usually answered in minutes!

Top Autotek Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Pablo Gonzalez

Level 3 Expert

733 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you an Autotek Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...