Question about Car Audio & Video

1 Answer

Kenwood kac 818 amp

I have a kenwood 818 amp. one day i changed the one of the fuses and turned it back on. where i had put the fuse in, it started to smoke a lil bit. and my subs made a awfull noise. since then i havent been able to get it to turn on. where tha fue goes in its burnt a lil bit. i really like ths amp and the power it gives. so i hope ull be able to help. thnk you

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I had the same problem the fuse i used was the same amperage but the plastic was a very poor grae and it actually caught on fire so i went to the auto supply and bought a higher grade fuze and havnt had a problem since good luck

Posted on Aug 30, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My kenwood excelon x1200m amp turned off randomly and will not turn back on


You may have blown a fuse. There should be one on the amp itself and the other is generally installed on the main 12V power cable. Most installers put it in the engine compartment for easy access. Pull each fuse and make sure it's still intact. If not you'll need to replace it. Most auto parts stores will carry the fuse, just take the old one in to make sure you get the correct amperage.

May 02, 2011 | Kenwood eXcelon X1200M Car Amp

1 Answer

Blows the 30 amp fuses


yes you have a internal fault of the amp. the circuit that puts it into safe mode is bad and that is a very small chip on the board know as a op amp. needs to be repaired.

Feb 03, 2010 | Kenwood KAC-9102D Car Audio Amplifier

1 Answer

Fuse blew on my lanzar amp and now it won't turn on.


that my find is some am trying to figure out
you say you turn of deck and fuse blow that dont make sense .look at it again


Apr 01, 2009 | Kenwood KAC-7202 Car Audio Amplifier

1 Answer

Kenwood KAC 7202 amp not powering on


First you should test to be sure the amps main power feed is supplying 12+ volts to the amp. and that the other connections (head unit remote lead - input & output signal leads) are properly secured, if all is well then there maybe an internal issue with the amp.

It is not recommended to affix an amp directly to a speaker/kicker box, hence the vibration that may cause wire connections and/or internal electronic components to become loose or faulty.

As far as "should i take the amp apart and look at its guts"

NO, sorry but given the way you phrased your question I can assume that your electronic troubleshooting knowledge is not up to par, and that task would be a waste of your time.

Good luck
Aduz

Mar 26, 2009 | Kenwood KAC-7202 Car Audio Amplifier

1 Answer

My 800 watt kenwood


Sounds like you shorted out the main power wire somewhere and killed the amp. Is the amp on the fuse intact or blown? Do you have 12 volts at the amp? check you connections and see if it helps.

Jun 03, 2008 | Kenwood KAC-7201 Car Audio Amplifier

3 Answers

No sound


good day, check your spkr impedance, if 4oms use a posive spkr dividing network. if stills blows up replace a higher amperage of your fuse. ex.4A raise it up to 5A. the your amps consume higier current if more spkr wattage.

May 29, 2008 | Kenwood KAC-5203 Car Audio Amplifier

1 Answer

Plz Help - unknow problem


Sounds like a short circut protection on the amp kicking in. It sences the power going to the drivers and cuts itself out before damage is inflicted on the subs.

Mar 18, 2007 | Kenwood KAC-7252 Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

71 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4724 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

yadayada
yadayada

Level 3 Expert

63291 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...