Question about Legacy 4CH 1000W RED AMP Car Audio Amplifier

1 Answer

Legacy 1470 smoke prob.

Hi i have a la1470 i plug it in just the cables and it starts smoking however the powerlight is still on and the protection light isnt why? and Normal?
thanks

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

If it begins to smoke with only the B+, ground and remote connected, the power supply transistors have likely failed.

The protection light generally won't come on if the power supply is blown because the supply must be working for the protection circuit (which protects the output transistors) to engage.

The power light may be connected to the B+ side of the power supply. If that's the case, the power light will illuminate even if the amp is inoperative.

Let me know if you have any other questions.

Posted on Aug 28, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Can i fix the transistors on my car amp it smokes when i put power to it.


stop turning it on, until you change the transistors. you will burn the entire system.

change all the transistor, not only the smoking ones.
check all other components.

Jun 01, 2010 | Legacy Audio LA770 Car Audio Amplifier

1 Answer

2000 watt american legacy amp protection ligh wont go off


Same thing happened to me so I returned it for repair turns out it was an internal 25amp fuse on the output. Got it back an it sounded very weak now it does not play at all. Nothing wrong with my setup as I have now got an 800watt amp that is running great.

Jul 01, 2009 | Lanzar MXA422 Car Audio Amplifier

2 Answers

Smoking amp


The only way you'll know is by hooking it up and testing it. Amps should not smoke, so there's a pretty good chance you fried it.

Jun 16, 2009 | Legacy LA838 Car Audio Amplifier

1 Answer

LA-1030 Protect Mode


you have an unloaded channel,so the voltage is exceeding what the protect circuit is supposed to see.you have to connect an 8 ohm resistor across the output of the unused channel.
do not drive a signal into it or you will smoke the resistor.
a 10 watt will do ok with zero signal input

May 23, 2009 | Legacy Audio LA1030 Car Audio Amplifier

2 Answers

Smoking


Gee I would think that it is kind of obvious; your amp is blown. Just because it doesn't blow fuses doesn't mean much. If you hook the power up to the ground input and the ground to the power and then turn it on you pretty much toasted the amplifier. If you don't know why the amp is smoking, but you're trying to fix it yourself, you are basically telling me that you have no business doing so. I have been an installer for 15 years and even I am not dumb enough to try to fix a bad amplifier. Do everyone a REALLY big favor; stop messing around with something that you don't understand of have knowledge about before you hurt yourself.

Mar 16, 2008 | Legacy LA838 Car Audio Amplifier

2 Answers

Smoking Amp/Fuse Blowing


Sounds like you may have a shorted switching Transistor in the switch mode power supply causing a short to ground. If you are technical enough. Remove power remove cover and do a continuity test on the transistors on the heatsink. non of them should read zero resistance between the three legs. in all connection configuration you use to hook up your meter. If one or Two or even all of them do you must replace with proper part.

Aug 02, 2006 | Legacy LA838 Car Audio Amplifier

1 Answer

No sound and some smoke


If you got smoke comming out its already has damage my friend.. Was this unit bench tested before you bought it or was it hooked up in another vehicle and you seen it work or did you buy it sight unheard??

Mar 23, 2006 | Alpine MRV-T707 Car Audio Amplifier

Not finding what you are looking for?
Legacy 4CH 1000W RED AMP Car Audio Amplifier Logo

Related Topics:

100 people viewed this question

Ask a Question

Usually answered in minutes!

Top Legacy Car Audio & Video Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

isaac johny
isaac johny

Level 3 Expert

796 Answers

xxxxxx xxx

Level 3 Expert

4724 Answers

Are you a Legacy Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...