Question about Car Amplifiers

1 Answer

Amp power my samson S1500 will not power up. i've checked all of the fuses that i can see with the top cover off, and they are fine and the circut breaker is not tripped. im stuck my rockford punch 1200 w will not switch off from its protect mode. everything seems fine and the problem occured when i put in a new car battery... dont no if that has anything to do with it.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Champion:

    An expert who has answered 200 questions.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 232 Answers

If one amp powers up and the other one doesn't in the same car,it tells u its not the wire, both amps seem to be damage and will require repair.if your having problems with amps u are over demanding the amp for power. try higher ohm speaker configuration for less amp break downs

Posted on Aug 30, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hi! I have a Jensen XA2150 Amplifier, from the speaker output I have connected a Subwoofer Sony 10 inch 1100W. Tha'ts gave me a nice bass sound, but now it's death! The amplifier have a 25A fuse,...


Have you checked the fuses inside the amp?Unscrew the cover and with the amp sitting on its back,remove the cover.You have 2-4 fuses,old round type,in there.

May 21, 2011 | Jensen XA2150 Car Audio Amplifier

1 Answer

I recently purchased the mtx terminator amplified bass system and wired everything in, but the amp seems to not be working, i checked the power and the wires going in are a good circut but none of the...


If none of the lights are coming on for the amp then the amp is not getting power and/or ground. Check the connections. Check the fuses. Or the amp is no good.

May 05, 2011 | MTX Car Amplifiers

1 Answer

I have everything hooked up correctly and cleanly, but when i turn my truck on the blue light flashes on then off and my subs do nothing. I don't know if its shorting out or what is going on.


sounds like a loose ground, or a loose positive cable or possibly a blow inline fuse, and the only power your unit is getting is from the remote. triple check all your connections. use your senses, smell the amp, smell for a burned order, this usually identifies if it is something internal. but it sounds like in your case (from experience with) a bad ground. If your gound or positive is connected but not tight it may be enough to power the remote circut, but not good enough to handle the actual turn on (Click) of the circut. powering the led light usually takes about .5 amps, but powering the turn on switch usually takes anywhere from .5 to 20 amps, then the inital charging of the capacitors that are internal on every amplifier... that quick charge pulls a decent amount of curren fast (usually the first 2-3 seconds) to fully charge a small amplifer after it has clicked on. hopes this helps

Aug 08, 2010 | Sony XM-2002GTR Car Audio Amplifier

1 Answer

I have a 1976 kenwood am fm stero receiver, the stero works great but just recently the face and power single lights went out, is their a fuse inside. I open the cover and did not see one.


A stereo or amp, either one should have a fuse, fuses for radios would be in the wiring harness behind the radio deck. An amp fuse should be obvious were they insert in the fuse blocks by the amps main power cable connector. If you see that all fuses are fine then check your ground wires if not then your radio is bad.

Jun 19, 2010 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

My amp will not power up


try hotting your remote wire to your batter if it don't come on u will need a new amp

Jun 14, 2010 | Diesel Audio NS-1000 Car Audio Amplifier

1 Answer

Amplifier protect circut is on and wont shut off


ALL AMPS HAVE PROTECTION CURCUITS, U NEED 2 CHECK ALL YOUR WIRES THAT HAVE ANY POWER RUNNING THREW THEM, U PROBLY HAVE A PINCH IN A WIRE CHECK ALL UR CONNECTIONS.

Mar 20, 2009 | Lanzar 2H 1000W MOSFET AMP Car Audio...

1 Answer

Samson Rubicon 5 Studio Monitor speaker is Popping


It seamns like its pretty commom =(
We should organize and complaint with samson!!
Read this:

http://www.gearslutz.com/board/low-end-theory/314545-samson-rubicon-r5a-problem.html#post5794093

Mar 12, 2009 | Car Amplifiers

1 Answer

Plz Help - unknow problem


Sounds like a short circut protection on the amp kicking in. It sences the power going to the drivers and cuts itself out before damage is inflicted on the subs.

Mar 18, 2007 | Kenwood KAC-7252 Car Audio Amplifier

1 Answer

Kenwood KAC-9152D Car Amp


use a multimeter to check for power on the +ve wire, could be your fuse, it only rus a sec when you jumper the remote to +ve because the remote cannot give out the nessary current to run the amp.

Sep 13, 2006 | Kenwood KAC-9152D Car Audio Amplifier

Not finding what you are looking for?
Car Amplifiers Logo

Related Topics:

82 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Pablo Gonzalez

Level 3 Expert

733 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...