Question about Washing Machines

2 Answers

My modeal 580.752000 pressurewasher runs great but as soon as there is a load on motor [pull triger on spray head] motor stalls

Posted by on

  • valspence Apr 14, 2009

    clean and carry pressure washer, starts and idles ok. As soon as I squeeze the trigger sprayer it dies. Was working great until last week, engine seems noiser now. Is pressure head loading down the engine? I may have to disconnect the pressure head from engine to check under load.

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Be careful, sound like the sealed bearing between the motor and pump may be bad. If it gets hard to crank or pull start then the spline bearing are shot

Posted on Jan 05, 2010

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 639 Answers

Dear tenpointx2,
ngfam at you service!

This sounds like it will only fixed by service

Yes sounds like you need service!
Call A&E Factory Service /They service nation wide
And are available 24/7 for making appointments!

If the appliance is 10 years old or more,it may make sense not to invest any money to fix it!
Happy to assist you,
Neil

PS.Before you sign off!
PLEASE GIVE ME A GOOD RATING HERE ON FIXYA.COM

Posted on Aug 26, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Elect. motor dosnt turn off when i release triger


high pressure cut out switch is faulty or not enough pressure to activate switch . more likely the first.
it migh be a simple micro switch . inside a platic housing on the end of the pump inside cover.

Jul 10, 2013 | Campbell Hausfeld Elec pressurewasher...

1 Answer

Pressurewasher runs fine then shuts down and cant pull


Same thing happened to me and I found out that water was getting into the carb filter media. Try taking the carb filter cover off and see if the foam filter is wet. If so, try starting without the filter and see if it works. THis issue used to drive me crazy on my unit, hope this helps.

Jan 20, 2013 | Garden

1 Answer

Ryobi leaf blower stalls when i give it gas idels fine but when i pull the triger it stalls


remove the muffler and run it if ok with the muffler off open it up and clean the screen inside

Jun 14, 2012 | Ryobi Garden

1 Answer

Motorturns over hard with pullstarter on my gx340 pressurewasher


You have a nice setup, lots of power. The honda gx340 has a compression release built into the engine so it should be relatively easy to start. With the pressure pump under load however, it will be very hard to pull the rope. With water connected hold spray gun open so water is running out tip and pull rope to start (for easy start, remove tip from gun) . If it still feels very hard to pull rope while holding gun open, most likely problem with lubrication in pump or engine valves are not adjusted correctly preventing compression release. If you suspect problem, go to store where you purchased the unit or any store that sells gx340 and pull the rope to get a feel of what force is required to start engine and compare to yours. Good luck.

Feb 15, 2011 | Honda Pressure Washer PSI 3000

1 Answer

92 max Sputtering and stalling out??


sounds like your crank triger after it cools then does it fire up fine then when it warms up it dies if so it would be your crank triger

Aug 09, 2009 | 1992 Nissan Maxima

1 Answer

Air leaks not the problem


sounds like the piston or the head valve is stuck. Open up the back with an allen wrench. Look it over really well. Clean it out with some WD40 after you pop out the head valve and take out the piston and cylinder. You're probably gonna need a kit with seals and o-rings. There is also a bumper (towards the front of the gun that seats inside the cylinder, make sure everything looks good and not dry-rotted or dirty. Lemme know. Please rate me

Jun 16, 2009 | Hitachi NR83A2 2" To 3 1/4" Full Head...

2 Answers

93'Saturn engine problem:


engine coolant temp sensor is most likely cracked.. I know it sounds strange but pull it if your looking at the engine it is on the right side of the head Will make the car hard to start, smoke, and the idle will often race up and down.. easy to fix 15 dollars or so..

Jan 07, 2009 | 1993 Saturn SC2

Not finding what you are looking for?
Washing Machines Logo

Related Topics:

207 people viewed this question

Ask a Question

Usually answered in minutes!

Top Washing Machines Experts

Gerry Harvey
Gerry Harvey

Level 3 Expert

1456 Answers

yadayada
yadayada

Level 3 Expert

67912 Answers

Brad Brown

Level 3 Expert

14742 Answers

Are you a Washing Machine Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...