Question about Technics SL-1200MK2 Turntable

1 Answer

What is the best way of cleaning your whole tone arm and hight adjustment on a technics 1200 mk2 as just brought second hand one and works great but very dirty thanks dj fluant-c

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 515 Answers

Use common sense when cleaning. Don' t use water. Instead I find Windex works well. Just spray enough to loosen up any dirt/grime build up. DO NOT OVERSOAK. And just wipe clean. There really is no real trick to cleaning these things.

Get yourself some cotton swabs, a can of air, and paper towels, and your all set.

- OPTiC
The 1200s Expert
www.1200s.com

Posted on Sep 08, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do I connect my technical pro dual 10 band equalizer to my professional hybrid amplifier


Use the pre in out connections or any in/out connectors that you have. Can you send a picture?
ELECTREPAIRUSA@ELECTREPAIRUSA or you can contact us at that address as we repair/renovate all items electronic and electrical old and new.

Dec 09, 2016 | Dual Audio Players & Recorders

1 Answer

MY PANASONIC 5CD STEREO SKIPS WHILE PLAYING CD'S I HAVE USED A HEAD CLEANER AND IT STILL DIDN'T WORK.I HATE TO DISCARD IT.


The laser pick-up unit fault [weak]. You have to replace it with a new one of similar number. Contact any service technician. To replace this part, you have to take out the whole mechanism from the system; and this is a skilled work.
If you wish to get some details; check the site linked here. Pull up older posts. Surf the site with patience. Electro help

Dec 26, 2014 | Audio Players & Recorders

1 Answer

I have a Toshiba Satellite A665-S6088. The last time I used it was last night and everything worked fine. It works with Windows 8.1, it has for a few months now, never had any problems until now. No...


Unplug the unit from ac power. Remove the battery. Wait a minute. Press and hold down the power button for 30 seconds. (Yes, I know, nothing will happen visible). Replace battery. Plug unit back in. Now try the power button and see if the unit resets. Sometimes this helps when all else fails especially with a computer which has "hung up" like yours. Let me know if this worked!

Aug 26, 2014 | Audio Players & Recorders

1 Answer

Why won't my CD Player won't play CD's?


the laser that reads the cd is probably dirty - if you have a can of compressed air - insert the nozzle into the cd player and blast away any dust and debris - if this doesn't help - there are cd cleaning discs available at any major retailer - just insert the cd and it cleans the laser - worst case scenario - buy a new cd player - the prices have really come down - I replaced mine with the trim kit and wire harness for $100 - only took about 1 hour - but you do need to buy the Ford stereo removal tools (available also at any good stereo store)
6e3dbb0f-b64c-469d-81da-cd7b00f9f3ee.jpg

Aug 22, 2014 | Audio Players & Recorders

2 Answers

I have a Rowe R80 jukebox and after moving it it has no sound through the speakers I am in New Zealand


Well, in addition to all the fine suggestions that are here, I would like to add the simple and easy things that may have happened during the move.

IF YOU ARE NOT GETTING A LOUD POP WHEN THE MACHINE IS POWERED ON.......

1) Make sure that the wires on the terminals below are still connected to the screws. There is one ground and one each for left and right. The lower the tap the lower the (max) volume of the jukebox.If they are not connected there will be no sound.
84c9065c-b7c6-4417-be21-0be7a6e74b41.jpg


There is a jumpers on the terminal strip where the volume control connects. Make sure that these connections are correct and tight. Also make sure that the jumpers did not fall off.
c1d72051-525d-47ec-8725-a6a8e655b20c.jpg
7a25e260-d39b-4992-8bce-8c2d2c9b07e5.jpg

If you are getting the loud pop in the speakers when the power is turned on .....

Check the plug on the side of the mechanism, just below the back of the tone are.(looks like a little tube socket) Check to see that it is connected to the mech and the CORRECT PLACE on the amplifier. It mat be possible to have this end in the wrong place. bf77613e-82a3-4e37-b8fe-cc80f4d4dbcb.jpg

Check all all your connections against the pic.

I hope this was helpful.

Mar 24, 2014 | Audio Players & Recorders

1 Answer

My aftermarket radio won't play any music out but when I put my stock radio back in everything works fine the aftermarket radio worked for a few weeks but then it stopped playing music out recently Any...


think the amp may have blown this is the problem with some after market radio's with the same wiring code as yours. best just ot get the radio you want and buy the adapter kit for it.

Mar 23, 2014 | Audio Players & Recorders

1 Answer

Amp settings


i would start out with all adjustment in the middle you will have to adjust as you go and its hard to tell you exactly with out knowing what kind of amp you have

Mar 01, 2014 | Audio Players & Recorders

1 Answer

Wailing sound when 1971 seeburg juke box is started


I amnot very familiar with Seeburgs but the trip switch activates at the end of the record playing and THAT mutes the amp. The amp should also be muted until the tone arm lands on the record. So I would suggest the problem is in the amp.

May 05, 2009 | Audio Players & Recorders

Not finding what you are looking for?
Technics SL-1200MK2 Turntable Logo

Related Topics:

142 people viewed this question

Ask a Question

Usually answered in minutes!

Top Technics Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

4706 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

T-Comtech Repairs
T-Comtech Repairs

Level 2 Expert

417 Answers

Are you a Technics Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...