Question about Kenwood KDC-MP528 CD Player

1 Answer

No sound I have all my wires connected properly and i have function on the radio i can go through all the options but it does not however have any sound in CD or tuner mode or anyother mode for that fact. what is going on here?!

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    New Friend:

    An expert that has 1 follower.

  • Expert
  • 161 Answers

Could possibly be a defective unit....try bringing it back and switching it out for a new one of the same model.....

Posted on Oct 01, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What am i doin wrong with my boss radio? when i set a station when i shut the engine off i loss my settings


Sounds like your Memory +12V wire is not connected properly. If this wire does not have a constant source of power then you will lose all of your settings on your radio.

Things that may cause you to lose power through the Memory 12V wire:
  • Not hooked up properly to the battery
  • Bad battery
  • Bad ground
  • Loose wires



Boss 637UA manual

Sep 04, 2014 | BOSS AUDIO SYSTEMS BOSS 637UA - radio / CD...

1 Answer

Deh3800mp stereo


Most likely a shorted speaker. Disconnect all speaker wires at the radio and try them one at a time. Be sure to have radio off when making connections. The speaker that causes the sound to shut off is the shorted one.

Dec 27, 2013 | Pioneer Car Audio Receivers

2 Answers

Corner of the radio is flashing ATT


ATT is like a mute option, hit mute or ATT button to return to normal operation.

May 15, 2012 | Kenwood KDCX895

1 Answer

Installing DEH-P3700MP in mitsubishi diamante need wiring diagram


The following may help you. The first is for the vehicle the second for the stereo. Good Luck.
Battery WHITE/YELLOW (+) RADIO HARNESS Accesory WHITE/RED (+) RADIO HARNESS Ground BLACK (-) RADIO HARNESS Illumination RED/BLACK (+) RADIO HARNESS Dimmer RED (-) RADIO HARNESS Power Antenna YELLOW/WHITE (+) RADIO HARNESS Amp Turn On YELLOW/WHITE (+) RADIO HARNESS LF Speaker (+) WHITE LF Speaker (-) ORANGE RF Speaker (+) YELLOW RF Speaker (-) BROWN LR Speaker (+) RED LR Speaker (-) GREEN RR Speaker (+) BLUE RR Speaker (-) BLACK Amp Location MOUNTED TO BRACKET IN RIGHT SIDE OF TRUNK Steering Cntrls YES THIS VEHICLE MAY BE EQUIPPED WITH OPTIONAL ONSTAR® TELEMATICS EQUIPMENT. USE AN APPROPRIATE INTEGRATION HARNESS OR INSTALLATION PROCEDURE TO ENSURE PROPER FUNCTION OF THIS EQUIPMENT. Speed Cntrl NO Radio Security YES Securityiadame_18.jpg

May 14, 2011 | Pioneer DEH-P3700MP CD Player

1 Answer

Remote wire doesnt turn off amps. and when driving stereo shuts off and comes back on, or puting truck into drive,reverse,or park,the radio shuts down. not all power the lights stay on and amps stay on i...


it sounds like you either used the wrong wire to connect the ground or the wrong wire to connect to the remote power.

for ground it should go to a clean paint free spot on the body of the car - try using a screw that is already attached to the cars chassis or a metal frame point

for the remote turn on wire try attaching it to the wire for you stereo ( it should be switched properly)

if it is doing what you are saying one of these 2 options should work

good luck!!

if you need more help write back and give me as many specific details as you can

Mar 27, 2011 | Eclipse 5506

1 Answer

My radio on s430 lights up but no sound


You need to give more information.
Assuming you have incorrectly installed the radio, it can be but a few things.
The radio may not have the all power connections connected. constant and acc.
"I had this problem before."
The proper grounding.
If the wiring is incomplete it will only light, but is not officially able to function.

If it was working prior to this event, it is again incomplete wiring. (blown fuse.)

Mar 16, 2010 | Car Audio Receivers

3 Answers

Hooked up a DURABRAND CD Stereo in my '97 Ford Expedition, because the old factory radio went dead, I got the proper Ford wiring harness for the stereo and proper mount. Every thing is getting power and...


because you have a built in factory amplifier that has to be bypassed. another option is to buy the kit that they make so you can USE your factory amplifier.

Jul 31, 2009 | Durabrand Car CD Player and AM/FM...

2 Answers

INTERMITTENT POWER PROBLEMS


Sounds like you have intermittent contact between the constant 12v and the ACC 12v power inputs. Remove the head unit, and make sure that the connections are properly insulated. (using inline **** connectors preferably)

Aug 25, 2008 | Clarion DXZ375MP CD Player

2 Answers

I can't find the button to turn on my sub!


im not exactly sure but if u press the EQ3 button a couple times once the xplod option is selected i think that is the setting that i designed for subs. Another possibility might be pressing the volume knob until the subs option is selected, might have something to do with that. The only other thing i can think of is making sure all of the wire connections are correct and properly connected, this is all i can think of because i just put this radio in my car a couple of days ago and have not put my subs in it yet so i haven't needed to figure this out yet. Best of luck.

Jan 14, 2008 | Pioneer DEH-P3600 CD Player

Not finding what you are looking for?
Kenwood KDC-MP528 CD Player Logo

Related Topics:

25 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio Receivers Experts

xxxxxx xxx

Level 3 Expert

4706 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Pablo Gonzalez

Level 3 Expert

733 Answers

Are you a Kenwood Car Audio Receiver Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...