Question about Mordaunt Short 309W Subwoofer

1 Answer

My Sub has stopped working the LED light does turn green but no output comes out of the sub...... any ideas ?

Posted by on

  • 1 more comment 
  • bhav_ik Aug 28, 2008

    yeah i recently replaced the sub lead with a brand new one as the old one had a broken at the connecter, all sub settings on amp are ok as wel, i think i may have to contact the manufacturer

  • gribb0 Dec 06, 2008

    I have exactly the same problem - light comes on when test signal sent but no sound

  • tsc6369
    tsc6369 Jun 23, 2014

    transformer problem

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Check that the connection to both the amp and sub are in place and that the wire is not comprimised. Otherwise, have you changed the settings on your amp lately? It could simply be a matter of adjusting settings. If in doubt, start from the start and treat it as a piece of new equipment - set it up from the beginning and follow all steps from the manual.

Posted on Aug 28, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Green light comes on for a sec the red light comes on,1200 watt sony xplod amp 10'' Orion sub,I think the subs right around 3000 watts. What's wrong?:(


Your Sony Xplod amplifier turns on briefly (green light) then possibly senses a mismatch between the nominal output impedance of the amplifier and impedance of your Orion sub and goes into protect mode (red light) to prevent internal damage.

Jul 19, 2014 | Car Audio & Video

1 Answer

Sub group 4 went out


send a signal thru the sub 4 insert and see if it comes out the sub 4 output. You may have jarred a ribbon cable loose in transport.

Dec 28, 2013 | Allen & Heath Allen and Heath GL2400-32...

1 Answer

Cadence 400 watt active sub green light on, no sound from the sub. whats wrong?




proceed according and fix it. However yi\ou must read the diode LED for diagnose. God bless you

Mar 26, 2013 | Exercise & Fitness

1 Answer

Mackie sub swa 1501 no LED no output but light on board appears to be on


los transistores de salida estan en corto 2sa1943 y 2sc5200 reviisa los drivers tip 122 y los irf

Feb 18, 2012 | Mackie SWA1501 Subwoofer

1 Answer

Basslink has no output, but Power LED and Servo LED always on.


Hi,

One or more of the DC to DC outputs might be bad. Check the
/- 54v on the main PCB and the /-15v on the switching controller PCB.
Losing one side of the 15v will cause the limit comparator to rail and force the servo protection, even with no input signal.

Apr 02, 2010 | Infinity BASSLINK Car Subwoofer

1 Answer

JBL Amp P80.2 - Random output failure


i had an amp that did that for a while before frying. its possible that it could be overheating causing it to go into protection mode which can be fixed with a cooling fan or remounting it somewhere else so it can get some air. it needs to be mounted in a way that it will have at least 1/2" clearance under it so it can have plenty of airflow. the other thing is you may be putting too much of a load on the amp causing it to go to protection mode. check and see how u have the sub wired and if the amp is stable. if u have the sub wired at 2ohm for more power output and the amp is only stable at 4ohm, then the amp will overload and cause the problem your experiencing. thats what happened to my amp. i had it wired for more than it was stable for and it fried

Jun 04, 2009 | JBL P80.2 Car Audio Amplifier

1 Answer

Sub not working any more


mine does the same DONT BUY SONY XPLOYED THEY EXPLOYED!!!!!!!!!!!!!!!!!

Jun 23, 2008 | Sony Xplod XM-1652Z Car Audio Amplifier

2 Answers

Audio control pod


I have a similar issue too, but my problem is that the sub has green light, and my control pod has an 'off' light, but it won't turn on :(

Jun 16, 2008 | Creative Labs Gigaworks S750 Computer...

2 Answers

Subwoofer goes to sleep


The receiver automatic speaker set-up set the sub volume at -12 and since it was not getting any signals from the receiver it was doing what it is supposed to be doing (going to the standby mode). This was troubleshooted by Onkyo tech support on a Sunday. All the best about Onkyo customer support.

Apr 12, 2008 | Audio Players & Recorders

1 Answer

Stop putting out sound to subs


Ok This is a two channel High Current amp. It is stable to one ohm. If the Subs are single voice coil at two ohms the they have to be wired in Parallel that means (Red +) (Black -) are connected to the + and - of another sub and then the (RED +) (Black -) from both go to one output channel of the amp. You pair the other two in the same fashion on the other output channel. If you are getting no output (sound) at all first check if the amplifier is going into protect. (Usually indicated by a red led on the unit. If it is connect only one Sub to each output and see if the protect LED goes out. If it does then you should have sound at the subs. If not check that you have the sub output enabled on the HU some head units do not come with the sub output enabled on the HU. If every thig is enabled, with only one sub connected to each output and the protect LED is not on then your amp is probably blown and needs repair. Nice thing is that MA has a great warrenty policy. Check and make sure the protect LED is off. If it is on you probably have the SUBS wired wrong

Jun 23, 2007 | MA Audio HK802SX Car Audio Amplifier

Not finding what you are looking for?
Mordaunt Short 309W Subwoofer Logo

869 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mordaunt Short Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

4861 Answers

Vito Vacirca Jr.

Level 2 Expert

137 Answers

chris

Level 2 Expert

232 Answers

Are you a Mordaunt Short Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...