Question about Coustic Car Audio 601SE Car Audio Amplifier

1 Answer

Coustic 601se power on but bad sound

I have a coustic 601se and i can get it to poer on but the light dims from the bright green to dim green and the sound is ****. it distorts and cuts in and out. the only way i can get it to turn on is jump the remote to the b+ a few times and i can get it to work like half way i suppose. it doesnt want to put out any power. im very good with electronics and im sure all the wires are fine(checked) and i took the back off the amp but can see any burned traces or any other burned items. i will be pulling the entire pcb from the metal surround tomorrow and looking at the bottom of the pcb. i tried finding a schematic for it but no luck. the red protection light does not come on at all no matter what but the green light goes from bright to dimm when turned on. i would think its sumthing in the power circuit but not sure. please help. i ahve good soldering skills and would replace the part myself but dont know were to start. it does not blow fuses at all either. kinda wierd

Posted by on

  • 11 more comments 
  • natemiller22 Aug 23, 2008

    ok i checked the amp out and i put my multimeter on the legs as the site you linked says to do. i found 4 of them that beep meaning a closed ciruit and should be open as i understand. so does this mean that these are bad? here is a pic of the ones that beep and all the other do not beep at all.

    http://img162.imageshack.us/my.php?image...


  • natemiller22 Aug 23, 2008

    ok i checked the amp out and i put my multimeter on the legs as the
    site you linked says to do. i found 4 of them that beep meaning a
    closed ciruit and should be open as i understand. so does this mean
    that these are bad? here is a pic of the ones that beep and all the
    other do not beep at all.

    [URLhttp://img162.imageshack.us/my.php?image...][IMGhttp://img162.imageshack.us/img162/7637/...[/IMG][/URL]


  • natemiller22 Aug 23, 2008

    2 of them say
    U1620
    CQ215
    AKA
    other 2
    U1620H
    CQ210
    KAK

    as long as i hold the to multimeter leads on the 2 outer legs it will stay beeping until i take them off. just copy the link down and paste it in ur address bar and click go and the pic will work fine

    http://img162.imageshack.us/my.php?image...



  • natemiller22 Aug 23, 2008

    i did not pull them out of the board just tested them in it.

  • natemiller22 Aug 23, 2008

    try this one. idk why it wont work

    Free Image Hosting at www.ImageShack.us

    QuickPost Quickpost this image to Myspace, Digg, Facebook, and others!


  • natemiller22 Aug 23, 2008

    lol just copy the short one with jpg on the end and paste it into the address bar. it will owrk

  • natemiller22 Aug 23, 2008

    i just emailed you the inside of the amp so check your email and get back with me

  • natemiller22 Aug 23, 2008

    do you have msn messenger? it may be easier to talk about this

  • natemiller22 Aug 23, 2008

    no i havent tried powering it up since last night and that was with a 80 amp fuse in the power line and 25 amp fuses in the amp itself. wut amp fuses should i put in the amp itself and do you mean a 15 amp fuse in the power line? and the transistors im guessing are the things that were clamped down on the side of the amp with plates and screws?


  • natemiller22 Aug 23, 2008

    does it matter what size fuse is in the power line?

  • natemiller22 Aug 23, 2008

    ok thanks i will be testing it in a few minutes when i leave.

  • natemiller22 Aug 24, 2008

    ok it does the same thing as i said before just powers on and the green light is bright then goes dimm and doesnt want to stay on unless i touch the remote to the power a few times to like trick it i guess then the green light stay dimm and crappy sound and cuts in and out. no fuses blew and nothing ever smoked at all. no signs of damaged areas and doesnt stink no were. and the red light never comes on either

  • natemiller22 Aug 24, 2008

    there is no way of getting voltages before the light goes dim because it lights up and right away goes dim there would be no chance of getting the voltage from that not even a second and its dim. and what ones are the tip35c and 36c?

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

This is generally caused when there are blown output transistors but that generally causes the fuse to blow or causes the amp to go into protect mode.

If you connect a 15 amp fuse in series with the main power wire and it blows when remote voltage is applied, the amp is drawing excessive current. The problem could be either in the power supply or audio circuits.

Do NOT apply power without having the transistors clamped TIGHTLY to the heatsink. They can fail in seconds when there is a problem. The heatsink helps protect them.

The following page may be helpful when troubleshooting.

Amplifier Repair Primer

Let me know if you have any other questions.

Posted on Aug 23, 2008

  • 5 more comments 
  • Perry Babin Aug 23, 2008

    A short beep doesn't mean it's shorted/defective. A continuous beep would indicate that you have a defective transistor (assuming that you checked it as suggested). Did you pull them out of the circuit to test them?

    The image link didn't work. What were the numbers on the transistors?


  • Perry Babin Aug 23, 2008

    Those are rectifiers. Across the outside leads, you're reading the transformer windings.

    I've tried several ways to get the links to work and they all give errors.

    Can you EMAIL me a photo of the inside of the amp so I can see what we're dealing with?





  • Perry Babin Aug 23, 2008

    I have the photo. Thanks.

    Have you tried powering it up via the 15 amp fuse yet?

    You need to do that to determine if it's drawing excessive current. Don't forget to clamp the transistors before applying power.

    I don't do IMs.


  • Perry Babin Aug 23, 2008

    A single 15 amp fuse in one fuse holder on the amp should work. It appears that all of the fuse holders are connected together. Leave 2 fuse holders empty.

    Most of the devices clamped to the heatsink are power transistors. Some are rectifiers.


  • Perry Babin Aug 23, 2008

    Not for this test.

  • Perry Babin Aug 24, 2008

    With your multimeter set to DC volts and the black lead on one of the non-bridging speaker terminals...

    Touch the red lead to the center leg of the rectifiers and center leg of the TIP35C and 36C. Give me the voltages. Try to get the voltage before the light goes dim also.




  • Perry Babin Aug 24, 2008

    Look at the photo. It's written on their faces. Again, don't power up the amp without the clamps in place.

    Get the voltage after it dims.

    Also measure the voltage on the B+ and remote terminals (black lead on the chassis ground terminal of the amp).


×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Ds light green,dim green, amber then off when power is turned on


Sounds like you need to send it in for repair. I had sent my console to VideoGame911.com and they repaired mine at a great cost and got it back at the end of the week. Give them a try, they are cheaper than a manufacturer. Good luck!

May 04, 2013 | Nintendo DS Lite

1 Answer

On dim all four headlights are on, but the inner


first i would want to know that all the headlamps are in good working order. it kind of sounds like these are also bad bulbs. you will also need to look for good ground wires just behind the headlamp assemblies. to answere your question, YES. if things were not repaired properly and without attention to detail then you could have wiring issues. on the plus side it doesnt sound too difficult. try these items first.

Nov 08, 2009 | Nissan Pickup Cars & Trucks

2 Answers

Red power light and buzzing sound with red lamp light.


My Sony lost its picture and had a flashing light. Unplugging for 36 hours solved the problem.

Mar 29, 2009 | Sony KDF-E60A20 60 in. LCD HDTV

2 Answers

The screen on my Apple Powerbook G4 goes dim and sometimes out.


How long before it goes dim?

Does it start strong, then dims right away?

Feb 27, 2009 | Apple iMac G4 Desktop

1 Answer

Lights go out


Dimmer switch is going bad. If you rapid fire the switch they will switch from bright to dim or dim to bright. replace the colum switch.

Feb 08, 2009 | 2001 Dodge Ram 3500 Truck

1 Answer

Coustic 601se power on but bad sound


Still doesn't work. Email it to me.

babin_perry@yahoo.com

Aug 23, 2008 | Coustic Car Audio 601SE Car Audio...

Not finding what you are looking for?
Coustic Car Audio 601SE Car Audio Amplifier Logo

354 people viewed this question

Ask a Question

Usually answered in minutes!

Top Coustic Car Audio Car Audio & Video Experts

Greg Cann
Greg Cann

Level 3 Expert

1114 Answers

Professor_V
Professor_V

Level 2 Expert

92 Answers

JonSnell Electronic
JonSnell Electronic

Level 3 Expert

17148 Answers

Are you a Coustic Car Audio Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...