Question about Sony TA-N9000ES 5-Channel Amplifier

1 Answer

AMP PROTECT I HAVE A SONY AMP AND N ALPINE HEAD UNIT IN MY BOAT. EVRYTHING WORKS FINE UNTIL I START THE ENGINE, THEN THE AMP GOES INTO PROTECT. IF I PULL THE FUSE TO RESET THE AMP IT WORKS FINE UNTIL I TRY TO START THE BOAT AGAIN.. HELP ME OUT PLEASE..

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

MAKE SURE THAT YOUR POLARITY IS OK FOR THE SPEAKERS.TRY TO TEST THE VOLTAGE BEFORE STARTING THE ENG THEN AFTER AND SEE IF ITS THE SAME OR MUCH MORE.

Posted on Aug 23, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why does my whole boat stereo system turn off and on constantly?


Try fewer speakers, it looks like a short to the amp.

Jun 16, 2014 | Amplifiers & Preamps

1 Answer

I bought a new 1200 watt xplod amp and pluged it to a 1200 watt double coil sub with my alpine headunit the head unit is too old so i got a new xplod head unit but now i got a really freak low sound...


personally I would probaly contact the place where you bought the equipment, providing you have connected everything up correctly, it sounds like the amp is faulty

May 05, 2011 | Sony Xplod 1200W Class AB Bridgeable 2-Ch....

2 Answers

When I switch my amp on it goes to protect and switch itself off


Check for shorts in the speaker lines.The easiest way to do this is to disconnect all the speaker lines from the amp. Now, turn it on and see if it goes into protect. If it does,that tells you that the problem is in the amp.
If it doesn't go into protect, reconnect the speaker lines one at a time until you find one(or more) that shuts the amp down. That would be your short.

Jan 20, 2011 | Sony STR-DE595 5-Channel Amplifier

1 Answer

After 10 years of function a problem appears with the technics se-a900s power amplifier: When the power output reaches or aprox the 10wrms the protection circuit enabled,and the unit goes off! (no...


I would have the power supply capacitors replaced. After several years ( from heat and age) they dry out and dont put out proper DC voltages to run the amp.

Oct 11, 2010 | Amplifiers & Preamps

1 Answer

CROWN CE1000- slips into fault immediately after connection


if ur output power amp is defective u will have that problem - meaning the moment u connect load across it it will go into circuit protection to limit/stop excessive output current. make sure the speaker terminals are connected to +/- output terminals. in bridge mode use only channel 1 and that too with 4 ohms speaker only otherwise amp will clip. considering all connections are okay if it still clips when speaker is connected, u have a faulty power amp section. this the way ur amp is designed

Apr 05, 2010 | Crown CE1000 2-Channel Amplifier

2 Answers

My Sony XMGTR2022 goes into protect mode at


I discovered that there is a compatiblilty problem between the Bose receiver and the Sony amplifier. If I disconnect the receiver from the amp then the amp starts up normally. Apparently the receiver sends out a dc offset or a "thump" that the amplifier doesn't like and goes into protection mode. I solved the problem by putting a 1 second delay circuit between the receiver startup and the amplifier startup. A simple RC delay on the remote input to the amplifier solved the problem.

Sep 03, 2009 | Sony Xplod 1200W Class AB Bridgeable 2-Ch....

1 Answer

The power protection kicks in when I turn up my radio volume


ground wire connection or possibly amp is turned up to high when an amp is turned up all the way it starts pushin dc voltage also it could burn out the internal battery check all connections and settings after that make sure subs arent begining to blow a sub that starts to blow kicks of the amp hope this helps

May 21, 2009 | Sony Xplod 500W Bridgeable Multichannel...

1 Answer

Amp stuck in protection mode


Most if not all modern amps contain protection circuits that continually look at the output and shutdown the amp when a problem is detected. This can be as simple as a speaker wire that has moved and is crossed or more complex like the internal amp stage containing failed parts. Disconnect the speaker wires and power cycle the amp. If the amp remains in protect mode, there is a problem with the final stage of the amp. Without having the make and model, I can not provide any details at this time.

Please try the unit without the speakers connected and update this with the results along with the make and model. Armed with that info, I should be able to post some information about possible fixes along with their costs.

Dan

May 03, 2009 | Alpine Amplifiers & Preamps

2 Answers

Sonamp 260 cuts out


Normally this denotes a protect condition. Remove the speaker wires from the back of the amp and see if the green light stays on. If this fixes the problem, then there is a short circuit in your wires, speaker level volume control or speakers. The amp sees the short and goes into protect. After a couple seconds it closes the connection again and if the short is still present it goes back into protect.

Aug 03, 2008 | Sonance Sonamp 260 MKII 2-Channel...

1 Answer

Protect Mode With Sony str-de595


Hi snark63

Ypou have an intermittent problem that sounds to be heat related... the more work the amp does, the more heat generated by the output stages. This will be aggravating some poor solder joints that are cracked or dry. The unit needs some repair work done in these areas. If you have good experience with a soldering iron, the cure for this is to resolder the power stages of the unit, or any other solder joints that look to be failing.

I am more than happy to answer any other questions you may have about it, please get back to me here, or use the ASK function to go straight to me :) If you are still unsure, have problems, or we need to look at the situation more deeply, then before you give a rating for this advice, hit the ASK button Thanks for using FixYa, If you consider the advice I have given you as sound, a FixYa rating is a great reward for my efforts to help you. Cheers.

regards robotek

Jul 05, 2008 | Sony STR-DE595 5-Channel Amplifier

Not finding what you are looking for?
Sony TA-N9000ES 5-Channel Amplifier Logo

Related Topics:

92 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Amplifiers & Preamps Experts

 Grubhead
Grubhead

Level 3 Expert

4590 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

The Knight
The Knight

Level 3 Expert

68301 Answers

Are you a Sony Amplifier and Preamp Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...