Question about Nikon D70s Digital Camera

1 Answer

D70 Will not flash with built in flash

Wen lighting is low, the internal flash will not work. The flash opens and the light on the front of the camera lights up, but I am not getting the internal flash to work

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Try to replace the battery, maybe it's too weak

Posted on Sep 08, 2008

  • monday481 Sep 08, 2008

    or chrage it

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why will nikon d70 not flash when hooked up to topcon. camera is new and works fine


If you are speaking about connecting a cable to the hot shoe on the camera top but, the internal flash does not work then, that is a design feature. The cable connected to a flash or, flash connected to the hot show takes precedence over the internal flash.

Jul 12, 2010 | Nikon D80 Digital Camera with 18-135mm...

1 Answer

Sb600 flash has no communication with d70 camera


Have you tried using the wireless mode? Even if there is a problem with the hot shoe interface, it might still work using the wireless mode. To do this you have to set both the camera and the flash. On the D70, under the menu with the icon that looks like a pencil, select Flash Mode|Commander Mode|TTL|OK. On the flash, hold down the Zoom and [-] buttons to get the CSM menu. When you see the zigzag arrow, push the Mode button to turn on the wireless mode.You may have to use the [+] or [-] buttons to cycle through the menu to find the zigzag arrow.

Now you should be able to use the flash detached from the camera. Just pop up the D70 flash, which will tell the SB-600 what to do via light pulses. There are other settings that may be required (channel and group settings must match between camera and flash) and be careful not to block the light sensor on the side of the SB-600. If the wireless system is still working, you may find you like it better than hot shoe operation.

Dec 01, 2009 | Nikon Speedlight SB-600 TTL Flash

1 Answer

Built in speedlight on nikon d70 has stopped working. The light pops up, but no flash


If flash pops up and doesn't fire, little white pin/lever inside flash has lodged up inside flash casing and needs to be eased from where it is stuck. Careful when opening the flash up to dislodge the white plastic pin/lever, there are tiny wires you REALLY don't want to damage....

See how, with pics here:

http://www.stephanmantler.com/blog/d70s-camera-repair/

Sep 12, 2009 | Nikon D70s Digital Camera

1 Answer

D70 internal flash not firing


Check if something is preventing the flash to pop up 'fully'. Check for some dust or other particles trapped between the flash and the body. Does the screen say 'Subject is too dark'? If so, the flash has not popped up fully.

Nov 10, 2008 | Nikon D40 Digital Camera with G-II 18-55mm...

1 Answer

Nikon D70 flah not working, used to


I had this problem a while back, but was fortunate to get it fixed under warantee as it was less than six months after Nikon repaired my D70 for the "blinking green light of death" fault.

I'm afraid this is a repair job for Nikon or an autorized workshop. It is most likley the flash tube. If you fancy taking your camera apart (I warn you it would be a fairly difficult job) then please be aware that you may get a significant electric shock from the flash capacitor, which will remain charged.

Feb 18, 2008 | Nikon D70 Digital Camera with 18-70mm Lens

1 Answer

Sb 600 under exposure.


You probably haven't changed the camera and/or flash back to TTL mode from wireless mode.  Make sure they are both set to TTL, not commander mode and you should be fine.  Note that the LCD on the flash will indicate which mode it is with a little graphic.  On the D70 you had to switch between TTL and Commander mode to set it up to work using the built in flash as the commander, so you just have to switch back.

Jan 21, 2008 | Nikon Speedlight SB-600 TTL Flash

1 Answer

Does Nikon D70 come with an additonal bottom to plug in Bowen Flashfill


Are you using the built in speedlight on the camera with the lens hood fitted? If you are this will cast a shadow. Try removing the lens hood when using the pop up flash.

Nov 27, 2007 | Nikon Speedlight SB-600 TTL Flash

1 Answer

Canon EOS 1000F in-built flash unit


Set camera body for Internal Flash for Pop-Up Flash.

Set camera body for External Flash for parked flash on Hot Shoe.

atdlee@netzero.com

Nov 08, 2007 | Canon EOS-3 35mm SLR Camera

4 Answers

Nikon D70 flash doenot fire


According to my information, the camera may need a new flash PCB (printed circuit board). Check the repair service search on this site for someone in your area. The part number for the circuit board is: 1S014-020-1 and runs about 50$

Sep 21, 2007 | Nikon D70 Digital Camera

1 Answer

D70 digital camera


could be bent pin in the memory card slot

Jan 03, 2006 | Nikon D70 Digital Camera with 18-50mm Lens

Not finding what you are looking for?
Nikon D70s Digital Camera Logo

Related Topics:

227 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nikon Cameras Experts

kakima

Level 3 Expert

102366 Answers

Steve

Level 3 Expert

3287 Answers

Ric Donato

Level 2 Expert

225 Answers

Are you a Nikon Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...