Question about Dehumidifiers

Open Question

Hampton Bay Dehumidifier Power LED Light Flashing - Won't turn on

I have a Hampton Bay Dehumidifier that is a few years old. it has an electonic panel on the front. I haven't used it in a year. When I first turned it on, it ran fine for a few hours. Now when I plug it in and push power, the Power LED flashes really fast (It is supposed to flash slow but only when the power is off). Sometimes if I let it sit unplugged for a few days, it turns on OK, but after a few seconds everything goes blank and it goes back to the Power LED flashing fast. It never starts up completely and begins dehumidifying the air. I read in a different post where someone had a similar problem, and the humidity sensor was unplugged. I checked that and it's OK. I was told by Home Depot that this is a remarketed LG Dehumidifier. Any thoughts?

Posted by on

  • Michele Michael-Fulkerson

    I just brought my dehumidifier out to use and the power light just flashes quickly when I pluged it in. I can not get it to turn on, the model number is CFZ 160.

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why does compressor continue running, even with dehumidifier turned off?


Hello Bernard, thank you for your post!
I see that you are experiencing an issue with the Frigidaire dehumidifier, FAD704DWD, compressor consistently being on. This could be a possible issue with your control panel or sensor. Since it could be any one of these underlying issues I would suggest contacting the manufacturer for further assistance. Hopefully this information is helpful to you. -Matt

Feb 16, 2016 | Frigidaire a/c fad704dwd 70 pint...

1 Answer

Goldair dehumidifier GD-2020 has stopped working? 'CONT' light on front panel flashing and now cannot get to operate?


cont button just means continuous run mode . the power light is lit , the full light is out . try reseating the water catch bucket a few times , most machines have a safety that wont allow the thing to operate if bucket isn't just perfect in its slot (you don't want water on your floor )

May 23, 2015 | Dehumidifiers

1 Answer

Hampton Bay HB30 is not working


its the fan thats not working mayby

May 17, 2014 | Dehumidifiers

1 Answer

My DeLonghi dehumidifier model DE500P is tripping the breake


the motor is tight, (can't turn) lubricate the motor bearings with light machine oil. retest. rust causes this. the motor "tries" to turn, more power is needed, still can't turn, power exceeds safe limits: breaker trips.

Apr 25, 2010 | DeLonghi DE500P Dehumidifier

1 Answer

I am looking to purchase a used Hampton Bay


This unit you looking to buy only covers 1000sqft .

Mar 17, 2010 | Maytag M7DH45B2A Dehumidifier

1 Answer

There are power surges every few minutes that last for a few seconds. Other lights on the same circuit dim. This is really a Hampton Bay HB40 which I understand is the same unit. What can I do?


it sounds like the compressor is trying to start. if it hums and clicks then either the compressor relay or the compressor is bad. find the compressor and tap on the relay cover with the end of a screw driver. if it starts then change the relay

Dec 03, 2009 | Fedders RDG40 Dehumidifier

1 Answer

Hampton Bay Dehumidifier Model# HB50


MY dehumidifier leaks water from upper part of unit causing water to leak on floor while running.

Feb 23, 2009 | Dehumidifiers

1 Answer

Back of dehumidifier forms ice


I have a Hampton Bay HB50 with the same problem. I replaced the defrost control switch that connects to the compressor inlet line. The part # is 112900550001 and it was about $50.00

Dec 12, 2008 | Dehumidifiers

1 Answer

My dehumidifier stopped working. It doesn,t produce ant water. Is there a common problem with this unit. It is a model HB40 By hampton bay


Hi,
There are many reasons for a dehumidifier2_bing.gif to not work or collect water.
Here is a tip that I wrote to help people to figure out what is going wrong with their dehumidifier2_bing.gif.

Dehumidifier is running but no water is in bucket
http://www.fixya.com/support/r4662409-dehumidifier_running_but_no_water_in

heatman101

Oct 25, 2008 | DeLonghi DE500 Dehumidifier

1 Answer

KENMORE 70 PINT DEHUMIDIFIER


4681A20040R is the fan part #. Bought one on e-bay. Fixed the same problem.

Aug 18, 2008 | Kenmore 54701 Dehumidifier

Not finding what you are looking for?
Dehumidifiers Logo

Related Topics:

250 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dehumidifiers Experts

Bill Long

Level 3 Expert

587 Answers

Gil Shultz

Level 3 Expert

3368 Answers

Michael Youngman
Michael Youngman

Level 2 Expert

156 Answers

Are you a Dehumidifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...