Question about Car Audio & Video

1 Answer

Mmat amp 1200 watt

Amp keep going into protection mode without spaeker being hooked up

Posted by on

  • frederick09 Dec 30, 2008

    HEY IT'S A BOSS AMP 700*2. THE AMP WILL NOT GO OUT OF PROTECT MODE

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

If the amp is in protect mode, it probably has shorted output transistors.

What model amp is it?

Posted on Aug 20, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Car amplifier just shut off and goes on and off when it wants


Driving the amplifier too hard causes it to go into protect mode to prevent damage. The amp periodically recovers and operates normally until the next overdrive peak hits it.

Apr 21, 2014 | Clarion Car Audio & Video

1 Answer

My Mmats 3000.5 mono block amp keeps going into protection, without a load. Any ideas why? The brand is Mmats pro audio. the next page does not list this brand.


If an amp has no load, as in there are no speakers connected to it, then it will go into protection mode because it sees an infinite load. Be thankful that it has a protection mode, or it would be toasted!

Feb 15, 2012 | Car Audio & Video

1 Answer

I hooked up 2 capacitors into my amp and every time I put power to it the amp shuts off and 10 seconds later a red light comes on for 5 seconds and the amp don't turn on, basically it goes into protect...


Well, I have no idea why you would have two capacitors on a 500 watt amp but, did you charge the capacitors? Have you tried the amp without the capacitors? What size power wire are you using?

Sep 20, 2010 | Kenwood KAC-9102D Car Audio Amplifier

1 Answer

Protection light keeps flashing on and off


try hooking up only the power ground and remote see what happens if protection light is on then u have a problem with amp if it goes off then hook up rca if still off then hook up speaker wire if it turns on then u have a prob with speakers

Feb 02, 2010 | Kicker ZX10001 Car Audio Amplifier

2 Answers

How do I fix the problem so they work again.?


A 1000 WATT AMP HAS PROBABLY GONE INTO PROTECTION MODE BECAUSE YOU ARE TRYING TO RUN 1600 WATT SUBS COMBINED

Jun 08, 2009 | Car Audio & Video

1 Answer

1200 watt OV2-1200 amp diagram


It probably has shorted output transistors. Most of the time, all you need to do is replace the shorted output (and those in parallel with it).

Email me if you want the schematic. It's probably not needed for this repair.

babin_perry@yahoo.com

Dec 19, 2008 | Power Acoustik GOTHIC OV2-1200 Car Audio...

1 Answer

Car audio amp in protection mode


If you power up the amp with the RCAs plugged in, does it go into protection mode.

If you power up the amp with the RCAs plugged in, does the woofer pop?

Oct 26, 2008 | Pyle PLAD413 Car Audio Amplifier

1 Answer

My Amp


sounds like the sub that throws it into protect mode is cross wired pull sub out and make sure they are wired right make sure ground from sub goes to ground on box and do same for power wire

Jun 11, 2008 | Sony Xplod Car Audio Amplifier XM-DS1300P5...

1 Answer

Mmats d500.2


  • It is capable of driving a 2 ohm load.
  • It is a single channel amp, so bridging is not applicable. There are two speaker connections, true, but they are tied together internally.
  • It's rated at 500W @ 2 ohms
  • The issue you're going to have hooking up the subs you own is that you're not going to be able to optimize the output of the amp. If you hooked all of them up in parallel (both 15w0 as well as the dual voice coils of the 15w6), you'd be putting a 1.7 ohm load on the amp, which it may not like. In my mind, your best bet is to either put both 15w0's in parallel (125W per sub) and not use the 15w6.....OR.......use only the 15w6 with the dual voice coils in parallel (350W to the sub).

Mar 12, 2008 | Mmats D500.2 Amplifier Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

365 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4724 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

yadayada
yadayada

Level 3 Expert

63242 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...