Question about MTX Thunder 1501D Car Audio Amplifier

2 Answers

Mtx 1501d no sound

I have a 1501d that was working great when I shut it off. When I turned it back on later the red L.E.D. light comes on but no sound. The amp doesn't smell burnt. I unhooked everything and rehooked it back up just to check it over.... nothing. Hooked up another amp with same sub (15" 9500 mtx) and it worked fine. Does anyone know of same problem with these amps or how to fix. Thanks Fatcatfred

Posted by on

  • 1 more comment 
  • Anonymous Sep 01, 2008

    i have the same probleme gos on red light but no sound comes out

  • Anonymous Dec 09, 2008

    is the 9500 a dvc or a svc??? i wanna say that the 1501 was a 2ohm stable amp,but you can still go under the ohms... i had 4 mtx9515's on 4 1501d's and i went under the ohm load and popped all 4 amps.... when you get a shot. mic the sub " voltage meter " and make sure that the sub is not throwing a bad load.... especially if the sub got warm it could clip the amp. and in turn pop goes the amp.....


  • monoblockluv Mar 13, 2009

    I have the same problem, i pulled the covers off and some of the transistors are totally fried. the ones that are visibly bad are....FET: 257 and FET:441,439,435,442,440,438,436. Also R436 (looks like a resistor) looks bad as well as R435. Does anyone know what these components controll? can i replace these?

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have mtx 1501d and 81000d the 81 did same thing power with no sound.... layed amp down flat and it turned on. took lid off and not sure what they called but i put small chunk of padding on top of the lid so when i put my lid back on it pressed down on top the two round crazy looking balls of wires and bamb! amp was fixed still bumping it today mtx is great audio. its all i own. lol sorry guys in not sure what the things are called that need to be pressed onto board better but there was two of the right next to eachother and they red in color and are just bunch wire covered in glue.

Posted on Mar 08, 2013

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

There are a number of things that can cause it to act as you described. Have you pulled the covers off of it yet to see if you can see any problems?

If you do, disconnect power from it and don't touch ANYTHING on the board when ANY of the 3 LEDs (2 are not visible from the outside) are lit.

Posted on Aug 19, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I installed a MTX Thunder 3401 with a PA sub. after turning the car oh every things works great. After about 2 mins of play, the thermal light begins flashing red and it will shut off the amp. After the...


You are def overheating, If the ohms rating of the subwoofer is too low it will cause this same thermal over heat. If you have 2ohms in sub and a 4 ohms stable amp, you will overheat. Check the ohms rating of the sub to make sure this is not the problem

Jan 31, 2011 | MTX Thunder 3401 Car Audio Amplifier

1 Answer

1501d,, What subs should i use/


I would stick with Kicker or MTX. The best place in my mind to get them is soncelectronix.com
Just try to mach the specs as close as possible. Make sure to look at the recommendations of the subs for the size of the box and the port volume.

Oct 11, 2009 | MTX Thunder 1501D Car Audio Amplifier

1 Answer

I have a mtx thunder 1501d..i have the power cord connected from the battery, to a power cap and then to the amp...i have the ground connected to the metal frame of the car, to a power cap and then to the...


Hello tonytone54, The ground should go directly to the vehicle frame, never through a cap, fuse, or anything else. Also, if you are connecting positive through a cap, make sure that you charge the cap before connecting it. Hope this helps.

Jun 03, 2009 | MTX Thunder 1501D Car Audio Amplifier

1 Answer

Mtx thunder 1500 watt amp no sound


Even if there is no visible damage, it could be that one of the transistors is blown, Use a multimeter to check the resistance of the transistors.

Apr 09, 2009 | MTX Thunder 1501D Car Audio Amplifier

2 Answers

Need help MTX 1501d amp diagram


Remove cover and set in direct sunny window for long time, may be no problem with it, Took a month to dry one of my amps out enough that it decided it would come back to life, cell phone dropped in sink took 2 weeks, If you try power to it too soon --fried--, good luck finding diagram and repairing it sincerely-hope its okay, good amp, bad luck,

Mar 13, 2009 | MTX Thunder 1501D Car Audio Amplifier

2 Answers

Mtx thunder 1501d


yes you can not run amps with your speakers being grounded un ground and then try

Nov 26, 2008 | MTX Thunder 1501D Car Audio Amplifier

1 Answer

My mtx thunder 1501d car amp making noise in the subwoofers


This is common with pioneer head units, the rca jacks are not properly grounded and this lets engine noise come through the rcs cables. This thread explains a fix http://www.caraudio.com/forum/showthread.php?t=337644.

Nov 13, 2008 | MTX Thunder 1501D Car Audio Amplifier

1 Answer

Mtx 1501D


if your power light is on then check your preamps (sub out from head-unit).Maybe you need to turn on that output thru head unit's audio menu.Also when using dual voice coils if you wire them out of phase there will be no output

Sep 16, 2008 | MTX Thunder 1501D Car Audio Amplifier

1 Answer

My led red light comes on but there is no sound


Have you confirmed that you have a good signal source and the speakers are in good working order?

If so, the amp has likely failed and will have to be repaired.

Let me know if you have any other questions.

Sep 16, 2008 | MTX Thunder 1501D Car Audio Amplifier

1 Answer

Mtx 1501d


ARE U USING THE CONTROLS THAT CAME WITH THE AMP?
USUALLY THE CONTROLS CABLE GOES BAD

May 08, 2008 | MTX Thunder 1501D Car Audio Amplifier

Not finding what you are looking for?
MTX Thunder 1501D Car Audio Amplifier Logo

440 people viewed this question

Ask a Question

Usually answered in minutes!

Top MTX Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

yadayada
yadayada

Level 3 Expert

71288 Answers

Are you a MTX Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...