Question about Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

1 Answer

It does not ****

Hello experts,

I have problem with my windtunnel vacuum, first it full then replace the new bag. The problem i have now it does not ****. The motor work okay and full indicator show full.

Posted by on


1 Answer

  • Level 1:

    An expert who has achieved level 1.


    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

Greetings from,

It sounds like you have a clog in the vacuum cleaner somewhere. What you can do is remove the hose from the back of the vacuum cleaner and see if the changes the bag full indicator, and pay attention to the sound of the motor. If the motor starts making a high pitch sound as soon as your install the hose, this means that there is a clog somewhere in the hose.

If you can give me your model number, I can send you a parts schematic to your vacuum cleaner.


Chris Jones

Posted on Aug 18, 2008


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

Hoover windtunnel

Hello--How about the Flat belt? That would be my next step...then, if it's still not turning, perhaps the beater/agitator bar's bearings are the culprit...calling for a new beater bar /agitator.

Hope this helps--

Aug 28, 2014 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Why is my hoover windtunnel vacuum cleaner shutting off?

Hi there! Sounds like the thermal protector is being activated. This is usually caused by a clog or a filter that needs to be cleaned or replaced. Follow the steps below to prevent the unit from shutting off.

1. Remove the hose completely.
2. Use a broom stick to gently loosen and clear hose of clogs.
3. Remove the bottom plate and brush-roll.
4. Use a wooden spoon or something similar to break up and remove any clogs from lower hose.
5. Check the primary filter behind the side grille. If it is dirty you may rinse it under running water and allow 24 hours to air dry outside the vacuum.
6. Remove the bag door. Clean the primary filter located on the vacuum under the bag. Rinse with water and allow 24 hours to air dry outside the vacuum. The primary and secondary filters should be replaced at least once a year.
7. Check that the bag is not full. If it is, replace the bag.

The vacuum will turn back on when it cools off. This can take up to an hour. Hope this was helpful!

Jul 08, 2014 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

How replace hoover windtunnel self actuator arm

Hello! We recommend taking your vacuum in to a Hoover authorized service center to have the self actuator arm repaired or replaced. Follow the link to locate the nearest service center to you. Thanks! Service Center Locator

Jul 04, 2014 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Mach 2.1 bag?

Hello! The U6437900 takes Genuine Hoover Type Y bags. Follow the link to place an order for replacement.

Type Allergen Bag 3 pack

Jun 25, 2014 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

I need a new bag for the Hoover 3.8 Model # U5465-900 which bag is it ?

Hoover Genuine Hoover Type Y Allergen Filtration Vacuum Bags, Fits Hoover Windtunnel and Hoover Tempo Bags Hoover 4010100Y

Feb 17, 2011 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Does not move on its own. put in new back and the bag indicator says it is full

The belt that drives the self propelling feature is probably worn. Your model has two belts and they should be replaced yearly to ensure optimum performance. You can get the belts you need here:

Hoover Windtunnel Replacement Belts

Nov 02, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

2 Answers

Hi I have model u64330-900 hoover windtunnel. It

It sounds like your vacuums belt is stretched and worn. You'll need to replace it. Below is a link to a website that gives instructions with pictures on how to change the belt. You should be able to get a replacement belt at any department store or vacuum retailer.
I hope this helps you.

Sep 24, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Hoover Windtunnel has no suction


May 03, 2009 | Vacuums

Not finding what you are looking for?
Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum Logo

147 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18419 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1474 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides