Question about SPL Dynamics Z2X-820 Car Audio Amplifier

1 Answer

Amp not working

My amp is going from red light to green light to off, nothing is obviously blown on the inside.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

If the amp is in protect mode, it probably has shorted output transistors. To eliminate other possible problems, read through the following page:

Amp in Protection - Troubleshooting

Let me know if you have any other questions.

Posted on Aug 18, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Red light on on amp


take speaker wires off amp if the lit is green then speaker are hooked up wrong or blown.

Mar 29, 2014 | Pioneer GM-5200T Car Audio Amplifier

1 Answer

Amp not working


sounds like the amp is going into protection mode. maybe a sub is shorted (blown). Or, the only other possibility is the mosfet transistors on the inside of the amp are blown.

Feb 01, 2010 | Hifonics Brutus BX 1205D Car Audio...

1 Answer

Csa300.1 bazooka 500 watts


sounds like you may have blown your sub...sheck the spyder inside of it and see if it is stiff..if the speaker doesnt seem too responsive when you press on it, its probably blown...

Aug 01, 2009 | Bazooka ELA300.1 Car Audio Amplifier

1 Answer

Green and red light are on my pyramid amp and its not working


It could be even simpler than that, yes an improper impedance rating on an amp will cause it to overheat, but should function temporarily until it reaches peak temp. If the outputs were blown the protect light should not light up being that they would need to work to cause the protect light to come on. I would double check all of your connections, one small little crossed wire would cause an amp to immediately go into a protect mode.

May 29, 2009 | Pyramid PB1217X Car Audio Amplifier

2 Answers

KAC-X520 kenwood 1000w amp


a red light indicates you got no power check your wiring you may not have a good ground, you need the green light to come on

Oct 09, 2008 | Kenwood KAC-X520 Car Audio Amplifier

1 Answer

Amp green then red light then nothing problem please help


It sounds like the output transistors have failed. To eliminate other possible problems, read through the following page.

Troubleshooting - Amp in Protect Mode

Let me know if you have any other questions.

Aug 05, 2008 | SPL Dynamics Z2X-1600 Car Audio Amplifier

2 Answers

LED Light is on, but no sound from sub at all.. Have double backed on all wires but still nothing! HELP!!


if you change amps and it goes on protection the speakers are blown causing the amp to protect try changing speakers

Mar 24, 2008 | Car Amplifiers

4 Answers

Red light


something is shorted in the circuit, or your subs. unhook the subs first and try it again, if it is still in protect then it is most likely the output transistors.

Feb 22, 2008 | Sony Xplod XM-554ZR Car Audio Amplifier

3 Answers

The red light on my amp keeps coming on and it wont work


You need to check your woofers. Most likely one or both may be a) blown or at a dead short or b) the ohm rating on them may be too low. What model woofers and amp do you have??

Nov 17, 2007 | MTX Thunder TA7801 Car Audio Amplifier

Not finding what you are looking for?
SPL Dynamics Z2X-820 Car Audio Amplifier Logo

Related Topics:

161 people viewed this question

Ask a Question

Usually answered in minutes!

Top SPL Dynamics Car Amplifiers Experts

Jose Velazquez
Jose Velazquez

Level 2 Expert

227 Answers

Pablo Gonzalez

Level 3 Expert

733 Answers

matthew walsh

Level 1 Expert

69 Answers

Are you a SPL Dynamics Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...