Question about NEC MultiSync MT1050 Multimedia Projector

7 Answers

Display Stops after 5mins

Hi,
My NEC1050 stops Lamp after 5 minutes. It is put in economic mode. During startup power led is steady green and Status led is blinking green.
After about 3 minutes status led is steady green which indicates projector is running in economy mode. After about 5 minutes from startup the status led bocomr flashing red for 4 minutes off and 4 minutes on. After about 1 minute the fan stops blowing and unit becomes ready to start. It happens every time I start the lamp. Can any one help me in this regards. I do not have service manual as it is not available in net.
Regards
Manik

Posted by on

  • 4 more comments 
  • ManikKolkata Aug 18, 2008

    the link contains only user manual not service manual.
    Regards
    ManikKolkata

  • ManikKolkata Aug 18, 2008

    Dear sir,



    This thing is repeating. So by stopping for 1 minute every 5 minutes I have been able to run it for nearly two hours. I did not tried more because this will reduce the life of the lamp. I have got soldering iron, DVM etc, but due to want of a service manual I did not try to repair the machine. So what I need is Service manual of NEC MT1050 and some guidance to use the maual.

    Regards

    ManikKolkata

  • ManikKolkata Aug 18, 2008

    ALREADY i TRIED WITH ADDITONAL VENTILATION BUT WITHOUT LUCK

  • ManikKolkata Aug 18, 2008

    All I nedd a service manual preferably from NEC. But NEC website does not provide any support, other than user manual.
    Regards

  • ManikKolkata Aug 22, 2008

    Though my problem was not resolved, but I got the service manual from ravco which I did not get after many searches. Thank you

  • ManikKolkata Aug 29, 2008

    Hello,

    I am back again. With the service manual in hand, I opened the MT1050 lamp cover then front cover and top cover. Everything inside the projector seems to be OK. The only tempterature sensor I could locate is located on the main board and seems to be fine. I arranged for additional ventilation but the projector shuts down after 5 minutes and can only be started after one minute. I want to know whether there is any other temperature sensor or not.

    Regards

×

7 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 2,920 Answers

Make sure the filter is cleaned out so the fan can breathe,,,otherwise it makes it hot and shuts down on you

Posted on Aug 18, 2008

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 199 Answers

As a follow up to Benimur's post and if you are considering a DIY, the following might be of further help:

  • a cleaning of the inside with the use of a can of compressed air and a vacuum cleaner;
  • source of Service manual;
  • correct user's manual;
  • often the problem is heat related or sensor(s) erroneously reading false temperature;
  • to my knowledge the NEC MT1050 uses a JED T460 projector controller with several smaller PCBs for various sensors. A possible source of parts.
Cheers.

Posted on Aug 18, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,665 Answers

Assuming Warranty has expired;
At link below is a list of merchants and service centers that repair projectors. To get merchant pricing and policies for your projector repair, select your projector brand before you click on the merchant or service center.
http://www.projectorcentral.com/NEC-repair-suppliers.htm

Posted on Aug 18, 2008

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 163 Answers

It seems power supply overheating problem (must be checked). Try to use an external ventilation to keep lower temperature and see if different result.

Posted on Aug 18, 2008

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 157 Answers

Hi.
Clean the dust around the lamp. Sometimes dust may interfere with the picture produced by the lamp and the cooling mechanism of the lamp. After you have cleaned, take the lamp out and put it back in, the lamp could be loose. Check for loose connections of wires aroud lamp. If the projector has a reset button, press that and see what happens. If all fails, you may need a new lamp or i would advise you let a technician have a look at it if its out of warranty. If you are familiar with electronics, you may wanna have a look at the board and check if the soldiering is still ok.

Hope this helps
Cheers
Jigsaw

Posted on Aug 18, 2008

  • John Smith
    John Smith Aug 18, 2008

    P.S. your service manual may be here
    http://www.ravco.us/service.php


×

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 6,966 Answers

Hi,

Initially, pls check the filter and vent ports as well as the fan. Verify that tjhey are not clogged and that the fan is providing adequate ventilation. Should problem persist, try to locate a reset button if available and press on it. Alternately, unplug the unit from the mains for about 15 minutes to try and revert back to factory default.

If above fails, further diagnosis require familiarity with electronic components and circuitry, use of a DVM and a soldering iron. Pls post back if your are considering a DIY (do-it-yourself). Otherwise, perhaps your best bet would be to seek the services of a qualified professional.

Hope this be of initial help/idea. Pls post back as requested, how things turned up or should you need additional information.

Good luck and kind regards. Thank you for using FixYa.

Posted on Aug 18, 2008

  • Louie  Role
    Louie Role Aug 18, 2008

    Hi again,

    Appreciate the postback and additional information. As to your concern, here is a Service Manual


×

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,847 Answers

You can get the manual from this link..

http://www.support.nec-display.com/dl_service/mlt150z_en.htm

Posted on Aug 18, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Dear Sir, I have a NEC LT 260 K Lcd projector. The lamp of the lcd was busted.I replaced it with a new lamp. After replacing the lamp the lamp is not lighting when projector is put ON, I think the...


the clicking sound hopefully is the high voltage trying to start the lamp, but for some reason there may be a connection problem between the lamp and the projector power supply.
take the lamp out.

look at the lamp and check that the 2 connecting plugs are ok.
then look inside the projector at the power sockets that connect to the lamp (when it's installed).
check that the pins are not damaged or pushed down too far to prevent the lamp plugs making a proper connection with the power sockets in the unit.

Jul 01, 2011 | NEC LT 260K Multimedia Projector

1 Answer

Hello. My Nec LT35 projector will not turn on. From standby mode, I hit the power button, the power LED turns green, the fan starts, but after two seconds it switches back to standby. The...


i have the exact same error with same projector. did you manage to solve this?

my status led blinked red 6 times indicating a "lamp error" which wasn't helpful. i also tried removing and replacing lamp but didn't work.

Dec 01, 2010 | NEC LT35 Multimedia Projector

1 Answer

Cannot Reset Infocus LP 350 Projector after replacing a bad lamp


that model has a history of bad ballasts. you'll need to replace it.

Mar 03, 2010 | InFocus LP350 Multimedia Projector

1 Answer

Rest benq pe8700 projector


if the lamp comes on, hold the exit button down until the osd comes on. press enter, then the right or left arrow button to reset it, then the exit.

Oct 02, 2009 | BenQ PE8700 Multimedia Projector

1 Answer

What does it mean when that blinking green light turns to orange one in lp 350?


Hi
This would be "Standby"
When you press standby, the display and audio turn off and a blank screen is displayed for 15 minutes.
You can change the amount of time the projector stays in standby mode; see “Standby Time” on page 27 for details.
The LED lights orange while the projector is in standby.
• If you press standby again within 15 minutes, the projector returns to normal operations immediately. The LED changes from orange to green.
• If you press standby again after 15 minutes, there is about a 60 second delay before the lamp turns back on. The LED flashes green while the lamp is re-lighting.
• If you don’t press standby again, the lamp turns off after 15 minutes. The LED lights orange while the projector is in standby.
The full manual can be found here:
Infocus customer support
Infocus LP350 Manual
I hope these help
Mike

Sep 18, 2009 | InFocus LP350 Multimedia Projector

1 Answer

Nec projector vt440 wont turn on


Hello. First check the lamp! From your description, it sounds like the projector is telling you that the lamp needs to be replaced. In "eco mode", when the power is green and the status is steady orange, that is the error message. In "high brightness mode" the status will be steady red. Hope I helped you.

Feb 22, 2009 | NEC MultiSync VT440 Multimedia Projector

2 Answers

Sony HS10 error lights


you could try a new lamp, some lamps fire, but do not stay on

Nov 09, 2007 | Sony VPL HS10 Multimedia Projector

Not finding what you are looking for?
NEC MultiSync MT1050 Multimedia Projector Logo

278 people viewed this question

Ask a Question

Usually answered in minutes!

Top NEC Multimedia Projectors Experts

Electro Med Services...
Electro Med Services...

Level 3 Expert

5653 Answers

The Knight
The Knight

Level 3 Expert

68301 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a NEC Multimedia Projector Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...