Question about Creative Labs Gigaworks S750 Computer Speakers

1 Answer

Gigaworks S750 Sub - Pops and Cuts Out

This is the second time I've had a problem with my sub. First it just stopped working, so I sent it out. Now whenever I turn up the system past a low volume, the sub cuts out and pops. It almost sounds like quiet, fast popcorn. This always happens at or above a certain volume, and whenever the bass hits. It almost seems as though the amp is damaged and clipping. I know a bit about electronics, but not enough ovbiously. I was wondering if anyone knew what could be causing this so i can fix it. Also, it is out of warranty.

Posted by on

  • Anonymous Oct 05, 2008

    To fix this remove the back of the sub and pull out the amp. Its not a proper solution but it worked for me. Do not leave it in to long as I did because now 3 channels have no output.

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 99 Answers

There is obviously a problem on the amp board with 3 STA575 amplifiers. It may be that one of the diodes is shorted or one of the capacitors has dried up or shorted. For more information I have posted a link to a forum thread that contains all of the information you would need to fix the Gigaworks S750 system. If the information has not already been posted there then you can ask on there and the people there will point you in the right direction.

http://forums.creative.com/creativelabs/board/message?board.id=speakers&thread.id=8037&view=by_date_ascending&page=1

Posted on Jan 04, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My gigaworks s750 powers up and lights, but no sound


Hi, have you find any solution? I got the same problem. Can you please email me. mtlmw@hotmail.com. Thank you

Feb 26, 2012 | Creative Labs Gigaworks S750 Computer...

1 Answer

Subwoofer will not play with other speakers


Hello

It looks like you have posted this before. Unfortunately, I don't know what you have tried so I may be repeating some of your earlier troubleshooting.

The subwoofer needs its own power supply to function properly. if it isn't getting enough power, the sub will not work at all.

On the back of the unit, you should see a green LED when the power is turned on. Is this light on all of the time of does it fade / flicker? This would indicate the power supply is going bad and you need to replace it.

http://forums.creative.com/t5/Speaker-Systems/GigaWorks-S750-power-problems-green-LED-faded-and-flickering/td-p/547311;jsessionid=9B7C9D2D939336148A9036D7E7D18A12

Apr 30, 2010 | Creative Labs Gigaworks S750 Computer...

1 Answer

Creativr Gigworks S750 Subwoffer intermittent sound


The S750 system is a great sounding one but unfortunatly like many similar systems all the amplifiers and power supplies are housed inside the sub box. This means they suffer badly from heat and vibration problems (they cook themselves or shake themselves apart). I have fixed a few S750 systems in the past but due to their complexity it's not for the faint hearted.

May 26, 2009 | Creative Labs Gigaworks S750 Computer...

1 Answer

Left front speaker works the rest dont and the sub makes a hum


Either you have it configured incorrectly this time around, or the settings are defaulted back to original on your DVR........ adjust your DVR sound properties/settings. and check all wires/connections as well.

Apr 20, 2009 | Creative Labs Gigaworks S750 Computer...

2 Answers

All I need is the control pod for the Gigaworks S750


I had an extra one but I sold it. According to creative labs they do not sell any replacement parts for the speaker systems. The best suggestion that I can give is to check craigslist and ebay for the control pods.

Dec 13, 2008 | Creative Labs Gigaworks S750 Computer...

1 Answer

Sub has died overnight


Change the fuse - located at the 220V input. Use a knife ti release it. Then the system will work again.

Oct 08, 2008 | Creative Labs Gigaworks S750 Computer...

1 Answer

Gigaworks


I could buy your sub if you want the power system in the sub is vary complex and it normaly fails on most peoples systems but i already had a custom amp and know want to use the woofer in my system email me if you interested

Sep 11, 2008 | Creative Labs Gigaworks S750 Computer...

2 Answers

Audio control pod


I have a similar issue too, but my problem is that the sub has green light, and my control pod has an 'off' light, but it won't turn on :(

Jun 16, 2008 | Creative Labs Gigaworks S750 Computer...

2 Answers

Subwoofer died (again)


Read this http://forums.creative.com/creativelabs/board/message?board.id=speakers&thread.id=8037&view=by_date_ascending&page=85
I was about to buy these speakers, but not after reading this

Mar 21, 2008 | Creative Labs Gigaworks S750 Computer...

2 Answers

Gigaworks s750


Same problem just went out after about 4 years.... weak lifespan for a 500 dollar system

Feb 12, 2008 | Creative Labs Gigaworks S750 Computer...

Not finding what you are looking for?
Creative Labs Gigaworks S750 Computer Speakers Logo

925 people viewed this question

Ask a Question

Usually answered in minutes!

Top Creative Labs Computer Speakers Experts

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers

Carlos L. Burgos
Carlos L. Burgos

Level 2 Expert

508 Answers

Brad Brown

Level 3 Expert

13561 Answers

Are you a Creative Labs Computer Speaker Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...