Question about Onkyo TX-SR606 Receiver

1 Answer

I've connected my laptop and cable TV to the Onkyo Receiver TX-SR606 via HDMI. I was working fine for over 2.5 years with no issues. Lately, I'm having problems. 1. Whenever I connect laptop, I had to wait for about 15 minutes before the audio and video are heard on the receiver and TV. It used to be instantaneous in the past. I can't understand why there is a delay of 15 minutes. When I connect the laptop to TV directly, the TV displays video instantaneously. 2. Since last night, the cable TV is not working as well. After 10 minutes, the video came for a second and then disappeared. In both cases, my samsung TV saus "Weak or No Signal". I suspect something is wrong with the Onlyo receiver.

Posted by on

1 Answer

  • Official Brand Answer
  • 333 Answers

Hello, I am sorry about your issue. It sounds like your receiver needs to be serviced. Thank you, Onkyo USA

Posted on Apr 04, 2017

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 17 Answers

SOURCE: receiver - onkyo tx-sr606 problem

if the speaker settings are deactivated, there is no other way but to reset the receiver back to factory settings. press and hold down vcr/dvr and then press standby. you will the word reset and that should activate your speaker set up again. hope this helps. ^_^

Posted on Dec 09, 2008

  • 17 Answers

SOURCE: No sound from Sub Pre-out on Onkyo TX-SR606

Also, it could possibly the preout terminal itself that is not working. One way to prove that is by transferring the subwoofer cable from the preout and temporarily transfer it to the tape out section. If it ouputs sound from there, then that means the speaker and the cables are working fine and it's just the preout terminal itself that is not picking up anything. ^_^

Posted on Dec 16, 2008

  • 1 Answer

SOURCE: clicking noise from Onkyo TX-SR606 during television broadcast

I seem to recall a sub-menu setting having to do with "auto shut off" or something like that.

My receiver is packed up, ready to take to Fry's, or I would find that submenu for you.

Posted on Jan 06, 2009

  • 239 Answers

SOURCE: remote code for sony playstation 3

you cannot control a ps3 with that remote because the playstation 3 only works with bluetooth. I'm sorry to have to tell you. you can purchase a remote that works with your system at any that sells your system.

hope this helped
please rate well.

Posted on Mar 06, 2009

  • 1 Answer

SOURCE: Onkyo TX-SR606 getting no sound from HDMI sources

Not sure if this is your fix, but I had what I thought was the same problem. I played with my Onkyo quite a bit ensuring the correct assignments for HDMI, audio and all that stuff. Turns out I neglected to make sure the output devices were properly assigned. Many devices aren't default to output sound over HDMI. I changed the audio out settings on the cable box to HDMI and suddenly the Onkyo worked great. I know, I'm an idiot for not checking that in the first place, but maybe someone out there is having the same trouble as well.

Posted on Apr 05, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

No component video with my Wii (component audio and HDMI video/audio both fine). It used to work fine, but now it won't show any picture regardless of which component IN I use. I checked all assigned...


Hello, I am sorry about your issue. Did you make any changes to the output resolution on the Wii. The output must be at 480i for the receiver to up-convert to HDMI. If there is a problem with the receiver I suggest a work around by connecting the component [red,blue,green] video outputs to the TV and the audio connections [red, white] to the receiver. Thank you, Onkyo USA

May 11, 2017 | Onkyo TX-SR606 Receiver

2 Answers

I have an Onkyo TX-SR606 connected via hdmi to a Sony Bravia 52" lcd screen. My inputs are a Panasonic DMR-EX77 dvd Recorder and a PS3 via hdmi into the Onkyo. All worked well for a month but now it takes...


The problem is with the HDMI daughterboard in the AVR is bad. This is a well documented issue on this interweb! A general search in google can confirm. Here are some stuff cut and pasted frm their site and another forum. Onkyo USA Corporation (hereinafter referred to as Onkyo) hereby warrants all Onkyo products PURCHASED DIRECTLY FROM ONKYO OR AN ONKYO AUTHORIZED DEALER- WARRANTY PERIOD (from date of purchase) New Products: Receivers 2 years Parts & Labor-- You can go to the Onkyo webpage to find a n authorized service repairman.
*** I took mine to a service repair place today, the guy said that he had two that he just fixes yesterday. He said that this issue has given him a ton of work. Just make sure that you have your receipt from AN UNAUTHORIZED DEALER and that your still under warranty. Receivers 2 years Parts & Labor

Jul 02, 2010 | Onkyo TX-SR606 Receiver

5 Answers

I cannot get video signal from my Samsung p1590 Blu Ray player via HDMI to pass through my Onkyo TX-SR606 AV Receiver. I get video if I connect Blu Ray player directly to TV, and have tried all HDMI ports...


I think this one is for the Onkyo wizards:

I would write them via email here:

http://www.onkyousa.com/feedback_form.cfm

1-800-229-1687
However I did find this 2 page hookup manual with nice notes at link listed below that may help you solve the mystery:

(seems you may have to assign the digital input)

http://filedepot.onkyousa.com/Files/QuickHookup/TX-SR606_QSS_En_A.pdf?CFID=918117&CFTOKEN=40624545&jsessionid=f0306ea8a0d68bb60a49102e3e5510576756


Assigning the Digital Input
If there’s no sound, you’ll need to assign the digital inputs as
necessary using the setup menus on the TX-SR606’s display.
If you connect your DVD player to the AV receiver’s COAXIAL 1
DIGITAL IN, and your cable/satellite receiver to the COAXIAL 2
DIGITAL IN, as shown, it’s not necessary to assign the digital input.
The onscreen setup menus appear only on a TV that is
connected to the HDMI OUT. If your TV is connected to the composite video or S-Video MONITOR OUT, or the
COMPONENT VIDEO OUT, use the TX-SR606’s display when changing settings.

Thanks for using FixYa!

Kelly

Feb 19, 2010 | Onkyo TX-SR606 Receiver

1 Answer

No video


HDMI has had a multitude of issues and yours is one of them. Your receiver has either 1.1,1.2,1.2a ver HDMI. If it's still under warranty, you can have it upgraded to 1.3b which is the current and working version. So far so good. If it's out of warranty, it's a 200-300 $ repair. If you just use HDMI directly to your TV, providing you have enough HDMI inputs on the set, you can just run optical or digital coaxial to the receiver and all will work fine. Hope this helps.

Aug 10, 2009 | Onkyo TX-SR606 Receiver

1 Answer

Picture sound blackout (blink) when cable box/receiver HDMI used


Onkyo service told me, the second timethat I called them, that there is a known HDMI handshake issue with Motorola and Atlanta Scientific cable boxes. The only solution, and it was a solution, is to connect the box through the HDMI 1 port ONLY. All the other (2,3,4) result in blinking/dropping of signal. I did this, changed the cable/satelilte setting to HDMI 1 and all is well.

Apr 12, 2009 | Onkyo TX-SR705 Receiver

1 Answer

Onkyo TX-SR606 getting no sound from HDMI sources on speakers. I have a motorola cable box and a panasonic DMP BD-35K blueray player both attached to the SR606 via HDMI cables (HDMI3 and 1 respectively)...


Not sure if this is your fix, but I had what I thought was the same problem. I played with my Onkyo quite a bit ensuring the correct assignments for HDMI, audio and all that stuff. Turns out I neglected to make sure the output devices were properly assigned. Many devices aren't default to output sound over HDMI. I changed the audio out settings on the cable box to HDMI and suddenly the Onkyo worked great. I know, I'm an idiot for not checking that in the first place, but maybe someone out there is having the same trouble as well.

Feb 20, 2009 | Onkyo TX-SR606 Receiver

1 Answer

ONKYO TX-SR606 Single output to TV


Hi there. for your receiver, the only time it can upconvert is when you go out as HDMI. In your current hookup (component out to tv) the signal from your cable (using a composite) will not be able to pass through the component cable. This means you either have to hook up your cable box using a component cable as well or add a composite cable (yellow) from monitor out of the receiver to the tv. Page 22 of the manual will show a diagram of the video signal flow. hope this helps.. ^_^

Dec 02, 2008 | Onkyo TX-SR606 Receiver

1 Answer

Onkyo tx-sr606 can not get it to work w tv using hdmi cables


try using a HDMI cable connecting the receiver from the "out" to the tv, then allocate through the setup menu what you have connected, say a cable box by hdmi, you would go to cable/sat allocate the port "hdmi1 or coax 1" then return. If it is a dvd click on dvd then allocate eg: "hdmi 2" then return.

Nov 16, 2008 | Onkyo TX-SR606 Receiver

Not finding what you are looking for?
Onkyo TX-SR606 Receiver Logo

Related Topics:

82 people viewed this question

Ask a Question

Usually answered in minutes!

Top Onkyo Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5017 Answers

The Knight
The Knight

Level 3 Expert

73691 Answers

yadayada
yadayada

Level 3 Expert

75117 Answers

Are you an Onkyo Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...