Question about Computers & Internet

1 Answer

Hi i have LOGITECH X540 5.1 140W SUBWOOFER SPEAKERs and couple of months ago one day my speakers worked properly and it didnt work after i came home from work. i havent had time to look at it but i need it fixed imediatley asap. i tried everything even if i plug it in to my blackberry it doesnt work.

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 79 Answers

Hello, the problem can't be fixed in a couple of minutes, not even in a couple of hours, I recommend you to take the speaker system to an electronic technician to fix it for you, use a borrowed sound system while the other is repairing, and to avoid that problem from happening again turn it off whenever you don't need it.
Too bad I had to give you the bad news. I still wish you have a nice day.

Posted on May 28, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I just got a pair of Logitech LS21 2.1 speakers with a subwoofer for my Acer Aspire 3680. A couple months ago, I reformatted my computer & put Windows XP with Realtek HD Audio system on it. When I...


Depending on the software that runs the sound card (you can find it in the control panel), the ports may be configured differently than they used to be. Check in the control panel and see if there is way to adjust the "plugs" and what they mean. Some of the sound cards allow you to change your mic to a sub and your input to an output!

Jul 07, 2009 | Audio Players & Recorders

1 Answer

Center/subwoofer speaker out...mixed


Hi all, I also purchased a logitech x-540 a few days ago and also have the center speaker outputting sound when i test or play the subwoofer. I didn't think this is normal and am now confused. Maybe its a problem with the audio drivers? MB is a ASUS P6T Deluxe V2 with Soundmax drivers. Hopefully someone can help to diagnose/ find a soluytion.

Jun 27, 2009 | Logitech X-540 Computer Speakers

1 Answer

Left speaker problem with X-240 Logitech Speaker / Subwoofer Sys.


pul the board out of the subwoofer box and check that the connector is soldered to the board properly if not the sound will sound scratchy.
hope thes helped

Jun 06, 2009 | Logitech X-240 Computer Speakers

1 Answer

Subwoofers not working on Logitech R-20 speakers; worked until recently


did you fix it? I have exactly the same problem, I'd appreciate any help please

Jun 03, 2009 | Logitech R-20 Computer Speakers

1 Answer

Logitech Z4 sound from one side only


Reconnect all the wirings in your speaker set. Be sure you connect all the cords properly.

May 25, 2009 | Logitech Z-4 Computer Speakers

1 Answer

Sound mostly out of one speaker


my spearker will not work it saids audio default

Dec 06, 2008 | Logitech X-530 Computer Speakers

1 Answer

Subwoofers not working on Logitech R-20 speakers; worked until recently


There must be a control on subwoofer, like a volume control. Turn it and check it. Also check the connections.

Jul 17, 2008 | Logitech R-20 Computer Speakers

1 Answer

Remote control for Z-680


I have 2 sets of speakers systems for the Logitech Z-680
Both sets included Subwoofer and 5 speakers.

Note: there is no controller on both just the speakers

I bought one set and the Controller went out.
Logitch sent me a new Z-680 system then the second controller went out but speakers work great.
1 system speakers were never used
2 system speakers used for about 4 yrs (speakers work great)

Also have 2 remotes (never used)

Both speaker systems are for sale
Remotes will sell seperatly or with systems

If in need of the subwoofer speakers must go along

Email me if interested
ckaras@san.rr.com

Jun 05, 2008 | Logitech Z-680 Speakers and DVD218 System

1 Answer

Z5300e Subwoofer Problem.


in my view, it is due to any of the following
1. its fuse burnout or wire breaked, check fuse and cordwire
2. its subwoofer coil is damaged to loud volume, replace it
3. its amplifier IC is damaged, replace IC

Dec 31, 2007 | Logitech Z-5300 Computer Speakers

3 Answers

Logitech Z-680


You need a 2 Amp Slow Blow fuse. 250V. Available from eBay

Aug 01, 2007 | Logitech Z-680 Speakers and DVD218 System

Not finding what you are looking for?
Computers & Internet Logo

Related Topics:

75 people viewed this question

Ask a Question

Usually answered in minutes!

Top Computers & Internet Experts

Doctor PC
Doctor PC

Level 3 Expert

7733 Answers

kakima

Level 3 Expert

102366 Answers

David Payne
David Payne

Level 3 Expert

14161 Answers

Are you a Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...